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[bookmark: _Toc51249574]About This Course
[bookmark: _Toc51249575]Course Prerequisites
This manual assumes the user has completed or has an understanding of the materials covered in the second part of the Microsoft Office Excel courseware, including:
Creating advanced formulas
Analyzing data with logical and lookup functions
Organizing worksheet data with tables
Visualizing data with charts
Analyzing data with PivotTables, slicers, and PivotCharts
Inserting graphics
Enhancing workbooks

[bookmark: _Toc51249576]Course Overview 
Welcome to the third part of our Microsoft Office Excel courseware. This version of Excel incorporates some new features and connectivity options in efforts to make collaboration and production as easy as possible.

This course is intended to help all users get up to speed on the different aspects of Excel, including some of its more advanced features. We will cover how to automate worksheet functionality, audit worksheets, analyze data, work with multiple workbooks, export Excel data, as well as import and export XML data. 

[bookmark: _Toc51249577]Course Objectives
By the end of this course, users should be comfortable with automating worksheet functionality, auditing worksheets, using a variety of different analysis tools, working effectively with multiple workbooks, exporting Excel data, importing and exporting XML data to and from a workbook, and creating Excel forms.

[bookmark: _Toc51249578]How To Use This Book
This course is broken up into six lessons. Each lesson focuses on several key topics, each of which are broken down into easy-to-follow concepts. At the end of each topic, you will be given an activity to complete. At the end of each lesson, we will summarize what has been covered and provide a few review questions for you to answer. Supplemental learning for selected topics is provided in the form of Lesson Labs at the end of this book.

Before you begin, download the course’s Exercise Files to a convenient location. They will be referenced throughout this course and are a key part of your learning experience.



Lesson 1:
Automating Worksheet Functionality



Lesson Objectives

In this lesson you will learn how to:
Update workbook properties
Create and edit a macro
Apply conditional formatting
Add data validation criteria to a workbook



[bookmark: _Toc51249580]
TOPIC A: Update Workbook Properties

In Excel, you can view, add, or even edit the properties of an existing workbook. These properties can include information such as who authored the workbook, date information, and more. This type information is referred to as metadata, and it can very useful when managing multiple workbooks. Over the course of this topic you will learn all about workbook properties and how to work with them. 

Topic Objectives
In this topic, you will learn:
About workbook properties
How to remove personal information using the Document Inspector
[bookmark: _Toc290542267]
[bookmark: _Toc51249581]Workbook Properties
You can view your workbook’s properties from within Excel by clicking File → Info → Properties → Advanced Properties:

[image: ]

When the Workbook Properties dialog opens, you will see that it contains five tabs: General, Summary, Statistics, Contents, and Custom. 

[image: ]

The General tab shows you basic information about the current workbook including the file name, file type, and file size. Additionally, this tab will show you the MS-DOS name for the current workbook, as well as when it was created, modified, and last accessed: 

[image: ]





The Summary tab is used to view, edit, or add authorship and keyword information about the current file. Specifically, you are able to add title, subject, author, manager, and company information to the file properties. You can also add category information, as well as keywords and comments to help identify and categorize this file: 

[image: ]



The Statistics tab will display when the current file was created, last modified, last accessed, and even when it was last printed. You will also be able to determine when the current file was last saved, how many times it has been revised, and how long it has been open for editing:

[image: ]

(Like the General tab, the data here is generated by your computer and cannot be edited or removed.)



The Contents tab will show you the number of worksheets contained within the current workbook and their names: 

[image: ]

(Like most of the other tabs on this dialog box, the data in this tab cannot be modified.)



Finally, the Custom tab allows you to add custom information to the file. For example, you can add attributes like the purpose of the file or the name of the department in your organisation that created it: 

[image: ]

Keep in mind that any data that is added here will only be displayed on the Custom tab in the Properties dialog. 

[bookmark: _Toc497565999][bookmark: _Toc51249582][bookmark: _Toc497566000]Remove Personal Information Using the Document Inspector 
The Document Inspector can browse a document and search for personal information that may be hidden to you. This includes information about the computer used to create the document, your own personal information, comments, hidden information, and much more.



To begin, click File → Info → Check for Issues → Inspect Document: 

[image: ]

You will be instructed to save the file if you have not already done so:

[image: ] 



Then, the Document Inspector will open. Here, you can choose what elements the Document Inspector should look for. By default, all types of personal information will be inspected. Click the Inspect button:

[image: ]


After a moment, anything the Document Inspector finds will be listed. Details of the data are also shown, as well as the option to remove any personal information. Click Remove All to remove the items found by the inspector in each category: 

[image: ]

If you do choose to remove any personal data, we recommend that you click Reinspect. This will run the Document Inspector again to ensure that everything you want removed is taken care of. When all information has been removed, click Close to return to Excel.



[bookmark: _Toc51249583]Activity 1-1
Updating Workbook Properties

You have created a workbook and need to send it to a client. The client requires that the properties for each workbook you send to them are fully entered and current.

	
	To begin, open Activity 1-1 using Microsoft Excel:

[image: ]

	
	

	
	Let’s open the Properties dialog box for the workbook. To start, click File → Info: 

[image: ]

	
	

	
	On the right-hand side of the Info category, click the Properties → Advanced Properties: 

[image: ]

	
	

	
	The Properties dialog box will now be displayed. If it is not already displayed, click the Summary tab: 

[image: ]

	 
	

	
	Type “Sales Goals and Bonus Report” into the Title text box: 

[image: ]

	 
	

	
	Inside the Author text box, type your own name: 

[image: ]

	
	Type “ABC Widgets” into the Company text box: 

[image: ]

	
	Inside the Category text box, type “Sales and Bonuses:”

[image: ]

	
	Finally, in the Keywords text box type “Sales Goals, Bonus, Bonuses, Sales” with the commas included:

[image: ]

	
	Click OK to apply the new properties: 

[image: ]

	
	

	
	Back in the Info category of Excel, you will see this information populate the right side of the Info category: 

[image: ]

	
	Save your work as Activity 1-1 Complete and then close Microsoft Excel.




[bookmark: _Toc51249584]TOPIC B: Create and Edit a Macro

Due to the nature of Excel and how it is used, you may often find yourself repeating the same task over and over again. To help streamline your workflow, it is possible to automate those tasks by creating a macro. Macros are created using code in Visual Basic for Applications; however, you don’t need to know programming in order to create a macro. Over the course of this topic, you will learn how to create a macro using the Macro Recorder.

Topic Objectives
In this topic, you will learn:
About macros 
About the Record Macro dialog box
About macro naming 
About Visual Basic for Applications (VBA)
How to copy macros between workbooks
How to configure macro security settings

[bookmark: _Toc51249585]Macros
[bookmark: _Toc362859245]Macros are small programs that are created to complete a specific task or set of tasks. They are created by either recording yourself completing this task or by coding a macro that completes this task directly in VBA. In either case, once the macro is complete, you can bind it to a custom button or shortcut key to execute it from the window for the application that you are creating the macro for. 

For example, a macro could be created that will protect a worksheet using predetermined settings. This would save you time from digging through the Excel interface and selecting these settings manually each time the task was required.

[bookmark: _Toc51249586]The Record Macro Dialog Box
The Macro Recorder is used to create a macro by recording all of the actions that you make within Excel. For example, if you wanted to create a macro that will enable specific worksheet protection settings, you would start the recorder, complete all of the actions to apply those settings, and then stop the recorder. Once the process is complete, the Macro Recorder will translate the actions you completed into VBA code and save it as a macro that you can use again and again. 

To start recording a macro, you first need to open the Record Macro dialog box by clicking View → Macros → Record Macro: 

[image: ]

In the Record Macro dialog box, you can enter details about the macro you are recording, including the macro name, shortcut key to execute the macro, where the macro is to be stored, and a brief description of what the macro does:

[image: ] 

[bookmark: _Toc51249587]Adding the Developer tab to your Ribbon
File / Options / Customise Ribbon / Developer

[bookmark: _Toc51249588]Naming Macros
The name of a macro needs to adhere to a set of naming rules: 
The name must start with an uppercase or lowercase letter. 
The name cannot contain any spaces. 
While the name can contain any letters, numbers, and the underscore character, it cannot include any other symbols or other characters. 
Finally, a macro name cannot share the name of another object (such as a worksheet) or other built-in name (such as “Function”). 

Macro Security and the .xlsm File Format
By their nature, macros are a security risk and in the wrong hands they can cause real damage to a file or computer system. To help address this problem, any workbooks that include macros must be saved in the Macro-Enabled Workbook format (.xlsm). This format provides increased security against malicious code by prompting you to manually enable or disable macros in a file. This system allows you to determine the trustworthiness of a macro before you run it. If you choose to save a workbook that includes a macro in another format, the macro will not be saved. 

Macro Storage
When working with macros, keep in mind that they can be stored in three different locations: the current workbook, a new workbook, or your Personal Macro workbook. 

By choosing to save a macro in the current workbook or a new workbook, the macro will only be available to those workbooks when they are open. 

If you are creating a macro that you will need to use with multiple workbooks, the Personal Macro workbook is the best option. Keep in mind that this storage area is unique to your computer and your user account, so while you will always have access to them on your computer, they won’t be stored with the workbook. 

[bookmark: _Toc51249589]Visual Basic for Applications
Visual Basic for Applications (VBA) is both a programming language that is commonly used to create macros for Microsoft Office applications and an integrated development environment (IDE). Even if you create a macro using the Macro Recorder, it is still translated into VBA code. You can later edit the VBA code that was generated by the Macro Recorder using the VBA development environment (the Visual Basic Editor). 

The Visual Basic Editor
The Visual Basic Editor is the development environment that is used to construct and edit macros for Excel and other Microsoft Office applications. This application can be opened directly from Excel (Developer → Visual Basic), but it will open in a separate window: 

[image: ]

The Visual Basic Editor is comprised of five panels, plus a toolbar area. 
The Code window (1) is where you directly type or edit the code for the open object. 
The Object Browser (2) is hidden by default, but will list all of the various modules and classes that can be used. 
The Project Explorer (3) pane will list the VBA modules in any currently open documents and templates. 
The Properties window (4) will list all of the properties for the object that is selected in the Project Explorer or in the Code window. 
The Immediate window (5) will display information when the code is being debugged. 
Finally, the Standard toolbar (6) includes many commands that allow you to interact with the VBA environment in a variety of different ways.


[bookmark: _Toc51249590]Copying Macros Between Workbooks
You are able to copy macros between individual workbooks using only Visual Basic for Applications. To do this open both the workbook that contains the macro that you would like to copy, as well as the destination workbook(s) that you would like to copy the macro to. Next, open VBA and examine the Project Explorer pane. Listed inside of this pane will be all of the workbooks that you currently have open (Book1 and Book2 in this example): 

[image: ]



Still in the Project Explorer pane, click and drag the module for the macro that you would like to copy from its listing to the destination workbook: 

[image: ]

The macro will now be listed inside the original workbook, as well as the destination workbook(s): 

[image: ]

 


[bookmark: _Toc51249591]Macro Security Settings
Excel includes several safeguards that help protect you against viruses that can be transmitted through macros. One of the most important safeguards that Excel uses is the digital signature, which allows users to verify that macros are from a trustworthy source. This way, if you open a workbook that contains macros, you can verify their source before enabling them. This can help prevent virus infection as macros from untrustworthy sources are at high risk of containing malicious code. 

To access macro security settings, click Developer → Macro Security: 

[image: ]

(The Developer tab is hidden by default and needs to be enabled through the Customize Ribbon category of the Excel Options dialog box.) 

Alternatively, you can access macro security settings by clicking File → Options to open the Excel Options dialog box. Next, open the Trust Center category and click the Trust Center Settings button: 

[image: ]



In either case, the Trust Center dialog box will be displayed on your screen. Click the Macro Settings category if it has not already been selected:

[image: ]

Inside this category of the Trust Center, there are four radio buttons to choose from, each of which handles macros in different ways: 

[image: ]

These four buttons are arranged in descending order from most secure to least secure, with the default setting being “Disable all macros with notification.” This setting is a good balance between disabling all macros and enabling all macros. 

If you disable all macros, you will not be able to use macros at all, losing any functionality that is provided by them. However, enabling all macros is very dangerous; this setting will greatly increase the risk of running malicious macros. 

The middle two options are generally the most commonly used. The third option, “Disable all macros except digitally signed macros,” is an especially good choice. This will run any macro that has been digitally signed by its author, but not any that are unsigned. This ensures that the macro being run is from a trusted source.



The Developer Macro Settings section contains an additional checkbox:

[image: ]

This option is used to control access to the VBA object model from any macro. By ensuring that this box is deselected, you can prevent malicious code from self-replicating. If there is a macro that requires access to this object model, this checkbox must be selected. By default it is deselected, and is best left as such, except for unique circumstances. 



[bookmark: _Toc51249592]Activity 1-2
Creating a Macro

You need to create a macro that will protect your worksheet from changes made by other users.

	1. 
	To begin, open Activity 1-2 using Microsoft Excel: 

[image: ]

	
	

	
	Open the Record Macro dialog box by clicking View → Macros → Record Macro: 

[image: ]

	
	

	
	The Record Macro dialog box will now be on your screen. Type “Workbook_Protection” into the “Macro name” text box: 

[image: ]

	
	

	
	Leave the “Shortcut key” text box blank. Click the “Store macro in” drop-down menu and click This Workbook: 

[image: ]

	
	

	
	Click OK: 

[image: ]

	 
	

	
	The macro is now recording all of your actions in the Excel window. Enable workbook protection by clicking Review → Protect Workbook: 

[image: ]

	 
	

	
	This action will open the Protect Structure and Windows dialog box. Leave the default settings unchanged and click OK:

[image: ]

	 
	

	
	With the actions that you would like to record now complete, click the Stop Recording button ([image: ]) on the status bar in the lower left-hand corner of the Excel window: 

[image: ]

	 
	

	
	Now you should test this new macro to ensure that it operates correctly. Disable the Protect Workbook option by clicking Review → Protect Workbook: 

[image: ]

	 
	

	
	Open the Macros dialog box by clicking View → Macros: 

[image: ]

	
	

	
	With the Macro dialog box now open, click to select the macro that you just recorded (Workbook_Protection). Execute it by clicking the Run button: 

[image: ]

	
	

	
	Click the Review tab. You will see that the Protect Workbook option has been toggled back on by the macro:

[image: ]

	
	

	
	Suppose that you want to edit this macro to take advantage of the worksheet protection feature that will enforce the size of the Excel window. Open the Macro dialog box by clicking View → Macros: 

[image: ]

	
	

	
	In the Macro dialog box, click to select the Workbook_Protection macro. Click Edit: 

[image: ]

	
	

	
	Visual Basic for Applications will now be open with the macro module visible in the Code window:

[image: ]

	
	

	
	Click inside the Windows:=False line and replace False with True:

[image: ]

	
	

	
	Close the Visual Basic Editor window by clicking the Close button in the upper right-hand corner: 

[image: ]

	
	

	
	Save your changes as Activity 1-2 Complete using the Excel Macro-Enabled Workbook file type. Close Microsoft Excel.





[bookmark: _Toc51249593]TOPIC C: Apply Conditional Formatting

While Excel workbooks and worksheets can contain all sorts of important and enlightening data, those important bits can sometimes be lost in a sea of information. To help bring attention to patterns or outliers in your data, Excel allows you to apply conditional formatting. Conditional formatting is often used to highlight interesting and relevant data, but it can go much further. During this topic you will learn how conditional formatting works in Excel, as well as how to apply it.

Topic Objectives
In this topic, you will learn:
About conditional formatting 
About the conditional formats that are available in Excel
About the Conditional Formatting Rules Manager dialog box
About the New Formatting Rule dialog box 
About the Clear Rules command

[bookmark: _Toc51249594]Conditional Formatting
Conditional formatting is a formatting type that will highlight cells whose data satisfies certain criteria. It is useful for worksheets that show financial figures (where black formatting might equal positive values, while red formatting might equal negative values), test results (where results change color based on their value), or any time you want to highlight the data that falls within a certain value. 

While Excel includes some default criteria that you can use to apply conditional formatting quickly, you also have the option to create your own criteria and conditional formatting style from scratch.



[bookmark: _Toc51249595]Conditional Formats
There are a number of different conditional formats that you can quickly apply by clicking Home → Conditional Formatting. Here you will see a number of format types that you can choose from: 

[image: ]

Simply choose a rule type and then click a specific rule to apply. Here is a breakdown of all the conditional formatting rule types that are found in this menu. 

Highlight Cells Rules
This will highlight cells that are greater than, less than, between, or equal to specified values:

[image: ]

Top/Bottom Rules 
This option will allow you to highlight the top or bottom numbers or percentages in the selected cells:

[image: ]

Data Bars 
Will display colored bars that are indicative of the value in the cell. The more the cell is filled in, the higher its value compared to the other cells in the range:

[image: ]


Color Scales 
Will use different shades of color to represent different values, from low to high:

[image: ]

Icon Sets 
Will use sets of similar icons that will visually indicate a cell’s value:

[image: ]



You can apply multiple conditional formatting rules to a group of cells by simply re-selecting the group and applying another condition. Here, we have added an icon set to data that already contains data bars:

[image: ]

[bookmark: _Toc51249596]The Conditional Formatting Rules Manager Dialog Box
As you create and apply conditional formatting rules to your data, you will need to be able to manage them properly. The Conditional Formatting Rules Manager has been provided for just this purpose. It can be accessed by clicking Home → Conditional Formatting → Manage Rules: 

[image: ]





The Conditional Formatting Rules Manager will list any conditional formatting rules that have been applied to the current selection. It also includes buttons to edit, delete, and create conditional formatting rules: 

[image: ]

Below, you can see a breakdown of each button in the Conditional Formatting Rules Manager dialog box: 

	“Show formatting rules for” drop-down menu
	This drop-down menu is used to choose the workbook element for which you want to display formatting rules. This can be the current selection of cells, the current worksheet, or specific worksheets in the current workbook.

	New Rule button
	Clicking this button will open the New Formatting Rule dialog box, which can then be used to create a new conditional formatting rule.

	Edit Rule button
	Clicking this button will open the Edit Formatting Rule dialog box. This dialog is identical to the New Formatting Rule dialog box, with the only difference that you use it to edit existing conditional formatting rules. 

	Delete Rule button
	This button will delete the selected conditional formatting rule. 

	Move Up and Move Down buttons
	These buttons allow you to adjust the order of rule precedence. The top-most rule will be executed before the rules below it. 

	“Rule (applied in order shown)” column
	Lists the name of all the conditional rules that have been applied to the current selection (or whichever element has been selected from the “Show formatting rules for” menu).

	Format column
	This column shows you a preview of how the conditional formatting will look for each rule.

	“Applies to” column
	This column will list the cell or range to which each rule has been applied.

	Stop If True checkbox
	This checkbox is used to control what conditional formatting rules are applied from the list. For example, if you had four conditional formatting rules applied to a range of data, you could check the Stop If True checkbox for the second rule to prevent the remaining rules from being applied.





[bookmark: _Toc51249597]The New Formatting Rule Dialog Box
The New Formatting Rule dialog box is used to create new formatting rules from scratch. To access this dialog box, click Home → Conditional Formatting → New Rule: 

[image: ]


The New Formatting Rule dialog box is divided into two sections, Select a Rule Type and Edit the Rule Description:

[image: ]

The Select a Rule Type section lists six rule types that you can choose from. Clicking on a rule type will change the contents of the Edit the Rule Description section to incorporate controls that are relevant to the selected rule. 

Below you can find a brief description of what each rule type does:

	Format all cells based on their values
	This is the same rule type that is used in data bars, color scales, and icon sets. It is used to illustrate your data in each cell relative to the range of cells that were selected (low, medium, and high).

	Format only cells that contain
	This rule is used to highlight cells that meet a specified condition. For example, you could use this rule to highlight cells that are lower than a specified value.

	Format only top or bottom ranked values
	Using this rule you can highlight a custom number (or percentage) of top or bottom values in a selected range of data. 

	Format only values that are above or below average
	This rule is used to highlight values that are above or below the average value of the cells in the selected range. Additionally, this rule also allows you to highlight data that is equal and above the average, equal and below the average, or based on standard deviations of one, two, or three (above or below). 

	Format only unique or duplicate values
	This rule will highlight data that is either a duplicate of another value in the selected range or unique to it. 

	Use a formula to determine which cells to format
	This rule allows you to use a formula or function to highlight cells. 




[bookmark: _Toc51249598]Clear Rules
To remove conditional formatting rules, click Home → Conditional Formatting → Clear Rules: 

[image: ]

Using the options on the sub-menu, you are able to remove conditional formatting rules from an entire worksheet, selected cells, the selected table, or the selected PivotTable.



[bookmark: _Toc51249599]Activity 1-3
Applying Conditional Formatting

To help find outliers and trends within a weekly sales and bonus payout worksheet, you need to apply some conditional formatting.

	2. 
	To begin, open Activity 1-3 from your Exercise Files folder: 

[image: ]

	
	

	
	You first want to use color scales to highlight the sales associates that made above average in sales and those that were below average. Use your cursor to select cells D5:D14: 

[image: ]

	
	

	
	Next, click Home → Conditional Formatting → Color Scales. From the Color Scales gallery, click the first option: 

[image: ]

	
	

	
	You will immediately see that those sales associates who have made more than average in sales will be highlighted in green, while those who made below are highlighted in red. Those that were close to the average are a yellow or orange shade: 

[image: ]

	
	

	
	Next, you need to create a custom conditional formatting rule that will use an icon set to identify sales associates who met or exceeded their weekly goal, as well as those who met or exceeded the minimum sales goal requirement. Ensure that the D5:D14 range is selected: 

[image: ]

	 
	

	
	Next, click Home → Conditional Formatting → New Rule:

[image: ]

	 
	

	
	The New Formatting Rule dialog box will now be displayed. Click to select the “Format all cells based on their values” rule type:

[image: ]

	 
	

	
	Within the Edit the Rule Description section, click the Format Style drop-down menu and then click the Icon Sets option:

[image: ]

	 
	

	
	The controls in the Edit the Rule Description section will change to incorporate controls that are relevant to icon sets. On the row that has the green icon, click the Type drop-down menu and then click the Number option: 

[image: ]

	 
	

	
	On the same row, inside the Value text box, type “15000” (the weekly goal): 

[image: ]

(Note that you could also reference a cell that contains the value that you need.)

	
	

	
	On the row that has the yellow dot icon, click the Type drop-down menu and then click the Number option: 

[image: ]

	
	

	
	On the same row, type “10000” (the minimum weekly target) into the Value text box: 

[image: ]

	
	

	
	With the new custom conditional formatting rule configured, click OK: 

[image: ]

	
	

	
	The new rule will now be applied to the selected range of data. (You may need to resize the column so that there is room for the icon set.) In this case you will see sales associates who made or exceeded their goal, those who are slipping below the base goal, and those who have not met either goal type: 

[image: ]

	
	Save your work as Activity 1-3 Complete and then close Microsoft Excel.


[bookmark: _Toc51249600]TOPIC D: Add Data Validation Criteria

By restricting the type of data that can be entered into your workbook, you can prevent data errors and have greater control over your data. For example, some data may need to be whole numbers while some may need to be a decimal value. Over the course of this topic, you will learn about data validation and how it is used in Excel. 

Topic Objectives
In this topic, you will learn:
About data validation
About the Data Validation dialog box

[bookmark: _Toc51249601]Data Validation
Data validation is an important part of worksheet design and functionality. It is used to make sure that the right data is being entered in the right place. For example, if you had a database table that contained a column of sales figures, you wouldn’t want to accidentally be able to enter text in the same column. To make sure problems like this don’t occur, Excel lets you set up validation rules to make sure the right data is being entered using the right format in the right location.


[bookmark: _Toc51249602]The Data Validation Dialog Box
To set up data validation, you first need to open the Data Validation dialog box. This is done by clicking Data → Data Validation: 

[image: ]

The Data Validation dialog box displays three tabs: Settings, Input Message, and Error Alert. Using the controls on these tabs you are able to set criteria settings, apply an input message, as well as set an error alert if the wrong data is entered:

[image: ]

Here, you will see the commands and controls in each tab in the Data Validation dialog box and what they can do: 

	Settings
	This tab lets you define the validation rule. The Allow field in particular is used to specify the data type:
Any value, meaning no restriction on text or numbers
Whole numbers defined by a logical condition (<, >, >=, etc.)
Decimal numbers defined by a logical condition
List, as defined by a range of cells from another location
Date defined by a logical condition
Time defined by a logical condition
Text length with min/max length settings
Custom data as defined by a formula specified to your needs
Each input type comes with its own set of conditions so you can specify exactly what is allowed in this cell.

	Input Message
(optional)
	Use this option to add a notification to the cell alerting users what the cell is for and what type of input is allowed. You can enter a title and a short, descriptive message. 

	Error Alert
(optional)
	You can use this tab to write an error message explaining the details of what went wrong. This message will be displayed if someone does enter incorrect data. Usually the error message will state the limits of input for this cell. 




[bookmark: _Toc51249603]Activity 1-4
Adding Data Validation Criteria

You are building a worksheet that will record the employee review ratings for each employee in your team. As ratings are to be recorded as values between 1 and 10, you need to add data validation to ensure that nothing else is entered other than whole numbers within that range.

	3. 
	To begin, open Activity 1-4 from your Exercise Files folder: 

[image: ]

	
	

	4. 
	First you need to select the range of cells to which you want to apply data validation. Use your cursor to select cells B2:B10 on the current worksheet: 

[image: ]

	
	

	5. 
	Display the Data Validation dialog box by clicking Data → Data Validation: 

[image: ]

	
	

	
	First, you need to define the rule for data in the cell. Click the Allow drop-down menu and click the “Whole number” option:

[image: ]

	
	

	
	As you can see, once the data type has been set, there are input fields available to set the rules based on whatever operator has been selected in the Data combo box. By default, “between” is selected:

[image: ]

Leave this option unchanged.

	
	Inside the Minimum and Maximum text boxes, you are able to enter values directly. In this case the numbers need to be between 1 and 10, so type “1” into the Minimum text box and “10” into the Maximum text box:

[image: ]

	
	

	
	Click the Input Message tab: 

[image: ]

	
	

	
	In this tab you can construct a message that will inform users what type of data is acceptable in the affected cells. Inside the Title text box, type “Review Rating:” 

[image: ]

	
	

	
	Within the “Input message” text area, type the following: “Please enter a number between 1 and 10.”

[image: ]

	
	With the input message now configured, click the Error Alert tab: 

[image: ]

	 
	

	
	Leave the Style drop-down menu unchanged. Type “Employee Review Rating” into the Title text box: 

[image: ]

	
	

	
	Inside the “Error message” text box, type the following: “Only numbers between 1 and 10 will be accepted.”

[image: ]

	
	

	
	With the data validation options configured, click OK to apply them: 

[image: ]

	
	

	
	To test out the new data validation, first click any of the cells that were affected. You will see a ScreenTip appear with the input message you added: 

[image: ]

	 
	

	
	Click inside cell B2 and type “7” as a value: 

[image: ]

	 
	

	
	Click to select cell B3. As the value entered into cell B2 falls within the acceptable guidelines you configured, nothing will happen and the value will be accepted. Type “88%” into cell B3: 

[image: ]

	 
	

	
	Now try to select another cell anywhere on the current worksheet. As the data value you just entered falls outside the acceptable guidelines for the data validation rule, the error message you previously configured will appear: 

[image: ]

	
	

	
	Clicking the Retry option will allow you to enter another value within the cell. For this example, click Cancel to clear the data from the cell: 

[image: ]

	
	Save your work as Activity 1-4 Complete and then close Microsoft Excel.



[bookmark: _Toc51249604]Summary
Over the course of this lesson you learned about a variety of different ways that you can automate worksheet functionality. You should now be comfortable creating and editing basic macros, applying conditional formatting, as well as adding data validation criteria. 



Lesson 2:
Auditing Worksheets



Lesson Objectives

In this lesson you will learn how to:
Trace cells
Troubleshoot invalid data and formula errors
Watch and evaluate formulas
Create a data list outline



[bookmark: _Toc51249606]
TOPIC A: Trace Cells

To assist you in creating and troubleshooting formulas in a worksheet, the Trace Cells feature will graphically display where data is coming from and where it is going. For example, it can apply a colored outline to a range in a formula, as well as to where the solution of the formula is displayed. During this topic, you will learn about the Trace Cells feature and its related components. 

Topic Objectives
In this topic, you will learn:
About the Trace Cells feature
About tracer arrows

[bookmark: _Toc51249607]The Trace Cells Feature
The Trace Cells feature will graphically indicate the bits and pieces of data that are being used in a formula, as well as where the answer appears. For example, here you can see that a formula uses the A1:A10 range of cells (indicated in blue) to calculate a single value in the D1 cell: 

[image: ]

[bookmark: _Toc51249608]Tracer Arrows
Tracer arrows are used to indicate the direction of the data flow to and from cells and formulas. There are three tracer arrow styles that can be displayed: 
Formula Tracer Arrow: Solid blue line that will trace the path of data for a valid formula. 
Error Tracer Arrow: Solid red line that traces the path of formula that has a type of error within it. This arrow will indicate the precedent cell where the error is detected. 
External Reference Tracer Arrow: Dashed black line that will trace the path of any formula that references cells in another worksheet. 

Here, you can see the Formula Tracer Arrow being used to trace the path of a formula that calculates the sum of an indicated range of cells: 

[image: ]

Precedent Cells
Precedent cells are the cells within a worksheet that provide data for a formula. Such cells can be highlighted by clicking Formulas → Trace Precedents with the appropriate cell selected: 

[image: ]



Dependent Cells
Dependent cells are the cells that are affected by the contents of another cell. For example, a cell that contains the solution to a formula would be considered a dependent cell. Such cells can be highlighted by clicking Formulas → Trace Dependents with the appropriate cell selected: 

[image: ]

[bookmark: _Toc51249609]Activity 2-1
Tracing Cells

You have inherited the task of maintaining a worksheet that is being used to calculate sales goals and bonus payouts for your company’s sales staff. To understand how this worksheet works, you need to use the Trace Cells feature.

	6. 
	To begin, open Activity 2-1 from your Exercise Files folder: 

[image: ]

	
	

	
	Click cell G5 to select it: 

[image: ]

	
	

	
	Now click Formulas → Trace Precedents: 

[image: ]

	
	

	
	A blue arrow will be drawn through all of the precedent cells for the currently selected formula. As you can see, the value that is being calculated in this cell uses the values found in adjacent cells under the E and F columns. Additionally, the value in I2 is also used: 

[image: ]

	
	

	
	Remove this tracer arrow by clicking Formulas → Remove Arrows: 

[image: ]

	 
	

	
	With the arrow now removed, click to select cell I2: 

[image: ]

	 
	

	
	See the dependents of the value in this cell by clicking Formulas → Trace Dependents: 

[image: ]

	 
	

	
	Multiple blue arrows will point out that the value in cell I2 is being used by the formulas in cells G5:G14:

[image: ]

	 
	

	
	Save your changes as Activity 2-1 Complete and then close Microsoft Excel.





[bookmark: _Toc51249610]TOPIC B: Troubleshoot Invalid Data and Formula Errors

While you already know how to use tracer arrows to identify the components of a formula and how they interact, sometimes that isn’t enough to figure out a formula problem. Invalid data can often be the root cause of formula errors and it can greatly affect the functionality of your worksheets. Over the course of this topic, you will learn how to find and troubleshoot invalid data and formula errors. 

Topic Objectives
In this topic, you will learn:
About invalid data 
About the Error Checking command
About the different error types

[bookmark: _Toc51249611]Invalid Data
Invalid data occurs when the wrong type of data is entered into a cell or range of cells in a worksheet. Such data can create significant problems in the operation of a worksheet and any formulas that depend upon the data in question.





[bookmark: _Toc51249612]The Error Checking Command
The Error Checking command and its options are accessed by clicking Formulas → Error Checking (drop-down arrow). This drop-down menu consists of the Error Checking, Trace Error, and Circular References options:

[image: ]

Error Checking
This command works similarly to the Spelling command in a word processing program. While Excel does actively check for some errors as you are entering formulas, it does not pick up on some issues that Excel’s automatic checking cannot account for. 

For example, here a cell reference has been mistyped in the formula in cell D2. This affects the formula in this cell as well as the dependent cell in the Profit column:

[image: ]



When you click the Error Checking command, Excel will examine your worksheet for any errors. If any errors are found, they will be listed one at a time in the Error Checking dialog box: 

[image: ]

In this case, D2 contains a naming error: the cell reference “B” is incomplete. Use the buttons on the right to:
Open the Help file for specific information about this error.
Show the calculation steps that were followed in order to reach this point.
Ignore this error for the time being.
Open the Formula Bar to fix the error by hand.

Trace Error
The Trace Error command will check formulas within the current worksheet for errors that are being caused by precedent cells. When the check is complete, tracer arrows are used to indicate the results. Blue arrows indicate that no errors were found, while red arrows point to the cell that is causing an error. Black errors will only indicate that precedent cells exist on a separate worksheet; they do not necessarily indicate an error. 

Circular References
This command is used to check for errors that are being caused by cells referring back to themselves through direct or indirect means. 

[bookmark: _Toc51249613]Error Types
While troubleshooting invalid data and formula errors, you may run across one or more of the eight types of formula errors. Below you can see a brief overview of each error type and what they mean. 

	#Div/0!
	The value in the affected cell cannot be divided by zero.

	#NA!
	This formula does not have any value. 

	#NAME?
	Text appears in this cell that is not recognized by the formula.

	Null!
	Two or more cell references are separated incorrectly.

	Num!
	This formula contains invalid numeric values or a numeric value larger than Excel can represent.

	#Ref!
	This cell reference is invalid.

	#Value!
	This formula includes an improper type of argument.

	####
	The contents of a cell are too wide to be displayed. 




[bookmark: _Toc51249614]Activity 2-2
Troubleshooting Invalid Data and Formula Errors

A colleague has been having trouble with a worksheet that you designed and created. Currently it has a formula error and the bonus payout amounts are not rounded to the nearest dollar as they should be. In this activity, you will troubleshoot these problems using the tools covered in this topic.

	7. 
	To begin, open Activity 2-2 from your Exercise Files folder: 

[image: ]

	
	

	
	First, you need to check the current worksheet for any data that does not meet data validation rules that were configured when the worksheet was first created. Click Data → Data Validation → Circle Invalid Data: 

[image: ]

	
	

	
	You will see that cell I2 is now circled in red. This indicates that the contents of this cell are not up to the data validation standard:

[image: ]

	
	

	
	This cell requires that only whole values be entered into this cell. Click cell I2, type “523,” and press Enter. As the newly entered data now meets the data standards, the circle will have been removed from the worksheet: 

[image: ]

	
	

	
	Next, you need to address the invalid formula. Troubleshoot the error by clicking Formulas → Error Checking → Error Checking: 

[image: ]

	 
	

	
	The Error Checking dialog box will now be displayed. As you can see, this formula has an Invalid Name Error (#NAME?) that needs to be addressed: 

[image: ]

	 
	

	
	Review the information in this dialog box. Then, click “Edit in Formula Bar:” 

[image: ]

	 
	

	
	The Error Checking dialog will change and the cell that contains the formula will now be selected. Additionally, the dependent values for this formula will be outlined and shaded in different colors: 

[image: ]

	
	Now that you can edit the cell that contains the affected formula, fix it by ensuring that the formula reads “=IF(E5>F5,I2, 0)”. In other words, we are adding “2” to the incorrect “I” cell reference: 

[image: ]

	 
	

	
	Click the Resume button to apply the new changes: 

[image: ]

	
	

	
	The Error Checker will check the remaining formulas in the current worksheet. In this case there are no other errors found, so a dialog box will be displayed that indicates this fact. Click OK:

[image: ]

	
	The error has now been fixed. Save your work as Activity 2-2 Complete and then close Microsoft Excel.


[bookmark: _Toc51249615]TOPIC C: Watch and Evaluate Formulas

When working with complex formulas, you can ensure that they are operating correctly using the Watch Window. Additionally, by being able to evaluate formulas while you create them, you can ensure that they are operating as intended. During this topic you will learn how to watch and evaluate formulas in Microsoft Excel. 

Topic Objectives
In this topic, you will learn:
About the Watch Window 
About the Evaluate Formula tool

[bookmark: _Toc51249616]The Watch Window
Imagine that you are compiling a very large number of survey results. As you add more and more data to the worksheet, it can be challenging to keep an eye on certain key values. The Watch Window is designed to display the value of certain cells as other information is changed within the worksheet. It is a floating window that will remain open no matter what you are doing with Excel.

For example, suppose that you want to keep track of a certain value in the Profit column of the following worksheet using the Watch Window:

[image: ]



To use this tool, you would click the cell(s) you want to watch and then click Formulas → Watch Window: 

[image: ]

Inside the Watch Window, click the Add Watch button: 

[image: ]

In the Add Watch dialog box, ensure that the selected cell that you would like to watch is entered. Click Add:

[image: ]

The Watch Window will then show you the vital statistics regarding this value: 

[image: ]

While using the Watch Window, keep the following points in mind:
To add more values to this window, click Add Watch and specify the cell. 
To remove values, select the appropriate item from the Watch Window and click Delete Watch.
When you are finished with the Watch Window, click the close (X) button. 


[bookmark: _Toc51249617]Formula Evaluation
To help you work with more complex formulas, the Evaluate Formula tool will run through each operation in a formula and evaluate it to ensure that no errors are present. To begin, click Formulas → Evaluate Formula: 

[image: ]

When the Evaluate Formula window opens, you will see the first operation to be evaluated is underlined. In this case you can see that “4*4” will be evaluated first. By clicking Evaluate, you can continue to evaluate each operation in this dialog box: 

[image: ]

This tool is particularly useful when working with nested functions where even a small error can impact the results of an entire formula.

[bookmark: _Toc51249618]Activity 2-3
Watching and Evaluating Formulas

You have inherited a worksheet that was created by a previous employee. In order to understand how it works, you would like to use the Watch Window, as well as the Evaluate Formula tool. Additionally, you need to increase the weekly bonus amount by 5%.

	8. 
	To begin, open Activity 2-3 from your Exercise Files folder: 

[image: ]

	
	

	
	First, you would like to watch how the bonus formula works. Use your cursor to select cells G5:G14 on the current worksheet: 

[image: ]

	
	Next, click Formulas → Watch Window: 

[image: ]

	
	

	
	The Watch Window will now be displayed. Click the Add Watch button: 

[image: ]

	
	

	
	The Add Watch dialog box will be displayed and allow you to choose the cell(s) that you would like to watch the value of. As you already selected a cell range, that range will appear in this dialog box. Click Add: 

[image: ]

	 
	

	
	Watches for each of the cells in the G5:G14 range will now be listed in the Watch Window: 

[image: ]

	 
	

	
	On the worksheet, click to select cell I2. Change the formula to account for the 5% increase to the bonus by typing “= 525 * 1.05”: 

[image: ]

	 
	

	
	Press Enter to apply the changes. Review the corresponding totals in the Watch Window to ensure that they are updated where appropriate: 

[image: ]

	 
	

	
	Close the Watch Window by clicking the Close button in its upper right-hand corner: 

[image: ]

	 
	

	
	Next, you should evaluate one of the formulas that is being used to calculate the bonus for each employee. Click to select cell G5 and then click Formulas → Evaluate Formula: 

[image: ]

	
	

	
	The Evaluate Formula dialog box will now be displayed. Click the Evaluate button: 

[image: ]

	
	

	
	The result of the calculation will be displayed in italics. In this case, the value of cell E5 was found to be 16785.14: 

[image: ]

	
	

	
	Repeatedly click the Evaluate button until a final result is shown. Click Close: 

[image: ]

	
	

	
	Save your work as Activity 2-3 Complete and then close Microsoft Excel.




[bookmark: _Toc51249619]TOPIC D: Create a Data List Outline

The ability to isolate data lists and create outlines can be very useful when constructing and auditing worksheets. Over the course of this topic, you will learn how to create a data list outline.

Topic Objectives
In this topic, you will learn:
About outlines
About the Outline group

[bookmark: _Toc51249620]Outlines
Outlines are an organisational tool that will treat your data as a group. This allows you to remove any irrelevant data without removing it from the worksheet entirely. The first step to creating outlines is to group data either manually or automatically. In either case, once the outline has been created, you are able to collapse or expand the data when required. 

Here you can see some data that has been grouped together and expanded. By clicking the group indicators you can collapse and hide the data: 

[image: ]



You can also click the group indicators to expand/show data once again: 

[image: ]

[bookmark: _Toc51249621]The Outline Group
Data in a worksheet is grouped (or ungrouped) using commands in the Outline group on the Data tab: 

[image: ]

To group a selected range of cells, click Data → Group to manually group these items based on the rows or columns. Alternatively, you can click Group → Auto Outline to have Excel decide the best way to group the data: 

[image: ]

The Ungroup drop-down command will ungroup data based on rows or columns, while the Ungroup → Clear Outline command will clear any existing outlines: 

[image: ]

Finally, the Subtotal command will insert subtotals and totals for the grouped data automatically: 

[image: ]

[bookmark: _Toc51249622]Activity 2-4
Creating a Data List Outline

You have a worksheet that contains raw data about inventory for each warehouse in your organisation. You would like to simplify this data so that only the SKU, Total Value, and Location columns are displayed. 

	9. 
	To begin, open Activity 2-4 from your Exercise Files folder: 

[image: ]

	
	

	
	Use your cursor to select both columns B and C: 

[image: ]

	
	

	
	Next, click Data → Group → Group: 

[image: ]

	
	

	
	The selected columns will now be grouped: 

[image: ]

(You will not be prompted to choose whether to group by columns or rows as you already had columns selected.)

	
	

	
	Collapse the newly grouped data by clicking the minus button 
([image: ]) that is just below the ribbon:

[image: ]

	 
	

	
	Now only the SKU, Total Value, and Location columns will be displayed: 

[image: ]

	 
	

	
	Expand the group again by clicking the plus button ([image: ]) that is just below the ribbon:

[image: ]

	 
	

	
	Save your work as Activity 2-4 Complete and then close Microsoft Excel.




[bookmark: _Toc51249623]Summary
Over the course of this lesson, you learned about the variety of different methods that you can use to audit your worksheets. You should now be comfortable using the Trace Cells feature, as well as troubleshooting invalid data and formula errors. Additionally, you should now be able to deconstruct formulas using both the Watch Window and the Evaluate Formula tool. Finally, you should now be able to create a simple data list outline using the Group commands. 



Lesson 3:
Analyzing and Presenting Data



Lesson Objectives

In this lesson you will learn how to:
Create Sparklines
Create scenarios
Perform what-if analysis
Perform statistical analysis with the Analysis ToolPak



[bookmark: _Toc51249625]
TOPIC A: Create Sparklines

One way that you can add visual elements to data in a worksheet is to use Sparklines. Sparklines are essentially miniature graphs that can be inserted into just one cell in a worksheet. This system allows you to not only present worksheet data visually, but also not overwhelm or obstruct the numerical data itself. Over the course of this topic you will learn about Sparklines and how they can be inserted into your worksheets.

Topic Objectives
In this topic, you will learn:
About Sparklines
About the types of Sparklines that are available
Insert / Sparklines
About the Sparkline tab

[bookmark: _Toc51249626]Sparklines
Sparklines are small graphs contained within a single cell that are used to summarize data and display trends. They can be positioned anywhere and can be customized however you like. Additionally, they can be created for a single range and then extended to multiple ranges after they have been created. 

Below you can see a Sparkline that is being used to illustrate the dispersal of income generated by three separate stores:

[image: ]



[bookmark: _Toc51249627]Types of Sparklines
There are three types of Sparklines. 

Line 
This type of Sparkline is used to show the upward or downward trend for a collection of data, as if you were watching a stock price rise and fall:

[image: ]

Markers can be used to highlight points in this type of Sparkline to indicate data points where the trend changes:

[image: ]

Column 
These Sparklines are similar to line Sparklines, but the data is plotted in a bar graph instead of a line graph:

[image: ]

Win/Loss
Sparklines of this type show the number of times that data was above or below 0, disregarding what the value of the data may be:

[image: ]

[bookmark: _Toc51249628]The Sparkline Tab
Once a Sparkline has been inserted into a cell, the Sparkline contextual tab will be displayed on the ribbon: 

[image: ]


The commands on this tab are used to customize and format the appearance and function of Sparklines. Here is an overview of the available groups:

The Sparkline group contains a single drop-down command that is used to edit its source data and location on the worksheet. 
The Type group contains commands to switch between the three Sparkline types. 
The Show group contains six checkboxes that are used to toggle elements of a Sparkline on or off. 
The Style group contains the Style gallery. This is where you can choose from an assortment of preconfigured styles to apply to the currently selected Sparkline. (Typically these styles only change the colors that the Sparkline uses.) This group also contains commands to format Sparklines with a custom line and/or marker color.
Finally, the Group group contains options for grouping or ungrouping Sparklines. This allows you to format and modify multiple Sparklines as one unit. You will also find the option to change the scaling and visibility of each Sparkline axis.



[bookmark: _Toc51249629]Activity 3-1
Adding Sparklines to Your Worksheet

You are working with a table of data that displays the inventory data for all three of your company’s warehouses. To better illustrate the distribution of stock amongst these three warehouses, you would like to create some basic Sparklines.

	10. 
	To begin, open Activity 3-1 from your Exercise Files folder: 

[image: ]

	
	

	
	First you need to create a Sparkline that will illustrate the difference between the quantities of stock in each warehouse. Use your cursor to select the B2:B4 cell range:

[image: ]

	
	

	
	Next, click Insert → Column (from the Sparklines group):

[image: ]

	
	

	
	The Create Sparklines dialog box will now be displayed. You need to specify where this new Sparkline will be placed in the current worksheet. Type “B5” into the Location Range text box. Click OK: 

[image: ]

	
	

	
	The new Sparkline will now appear in cell B5:

[image: ]


	 
	

	
	Next, you need to add another Sparkline that will show the distribution of the value of products amongst the three warehouses. Use your cursor to select cells C2:C4 on the current worksheet: 

[image: ]

	 
	

	
	Next, click Insert → Line (from the Sparklines group):

[image: ]

	 
	

	
	The Create Sparklines dialog box will be displayed once again. You need to specify where this new Sparkline will be placed in the current worksheet, so type “C5” into the Location Range text box. Click OK: 

[image: ]

	 
	

	
	The new Sparkline will now appear in cell C5:

[image: ]

	 
	

	
	Save your work as Activity 3-1 Complete and then close Microsoft Excel.





[bookmark: _Toc51249630]TOPIC B: Create Scenarios

Being able to forecast future data points is a clear advantage in any industry. To assist with this, Excel offers the ability to create different scenarios based on data in a worksheet and the ability to analyze their outcomes. These scenarios allow you to predict outcomes based on your data and plan for the future in a meaningful way. Over the course of this topic, you will learn about scenarios and how to create them.

Topic Objectives
In this topic, you will learn:
About scenarios
About what-if analysis tools
About the Scenario Manager dialog box

[bookmark: _Toc51249631]Scenarios
In Excel, a scenario can be described as a set of cell values that are saved and substituted into your worksheet at your convenience. If you have multiple scenarios saved, you can load different scenarios into your worksheet and compare and contrast them to see which particular set of values gives the best results. 

Used in this way, Excel scenarios provide a powerful tool for performing what-if analysis. For example, you might use scenarios to represent different budget options or evaluate different financial forecasts. You can also use scenarios to compare different data projections based on any number of factors. 



[bookmark: _Toc51249632]The What-If Analysis Tools
Scenarios are just one of Excel’s various what-if analysis tools. This particular tool allows you to construct data models to see the outcomes of different decisions and their impact on the data in your worksheet. For example, you could create a scenario that would help determine the impact of increasing prices by 5% would have on your business income. Such information can be crucial in business decision-making processes. 

[bookmark: _Toc51249633]The Scenario Manager Dialog Box
When creating scenarios for your data, you need to access the Scenario Manager dialog box. To do this, click Data → What-If Analysis → Scenario Manager: 

[image: ]

Once open, the Scenario Manager dialog box includes controls that allow you to create new scenarios and manage existing scenarios: 

[image: ]

Here is an overview of the commands in this dialog box:

The Add button will display the Add Scenario dialog box. Here, you can name and configure the new scenario. 
The Delete button will remove the currently selected scenario is the Scenario Manager. 
The Edit button will allow you change the configuration of a selected scenario, while the Merge button allows you to import scenarios from other worksheets. 
The Summary button will generate a report summarizing the changes that the current scenario will cause to the worksheet data.
The Comment area allows you to make comments about the currently selected scenario. 
The Changing Cells text box will display the reference cells for the currently selected scenario and give you the option to change them.



[bookmark: _Toc51249634]Activity 3-2
Creating a Scenario

You are working with a worksheet that contains income and expense data for a chain of stores in your company. You would like to create a scenario that will show you the results of a projected increase in income for some stores, and a projected decrease in rent for other stores.

	11. 
	To begin, open Activity 3-2 from your Exercise Files folder: 

[image: ]

	
	

	
	First, you need to create a scenario with the current data that you can return to as a baseline. To display the Scenario Manager dialog, click Data → What-If Analysis → Scenario Manager:

[image: ]

	
	

	
	In the Scenario Manager dialog, you will see that no scenarios exist for this worksheet. Click Add to add a new scenario:

[image: ]

	
	

	
	Type “Baseline Data” in the “Scenario name” box. Then, use the Tab key to move your cursor to the “Changing cells” text box:

[image: ]

	
	

	
	Adjust the position of the Edit Scenario dialog box so that it does not overlap the data on the current worksheet. Next, click on cell C2 in the current worksheet to select it. Hold down the Ctrl key on your keyboard and click on cells C3, C4, E2, E3, and E4 so that they are also selected. These cells will be entered as absolute cell references in the “Changing cells” text box:

[image: ]

	 
	

	
	Next, type “Original Data” on a new line in the Comment text area. Click OK:

[image: ]

	 
	

	
	In the Scenario Values box, do not enter any new values. (Remember, this will be a scenario containing the current original data.) Click OK:

[image: ]

	 
	

	
	The Scenario Manager will now contain the scenario you just created for the original data. The next step is to create a scenario with the future income and rent projections. To do this, click Add:

[image: ]

	
	In the Add Scenario dialog box, type “Projected Income and Rent” into the “Scenario name” box. Check that the changing cells are C2, C3, C4, E2, E3, and E4. (They should be entered by default based on the first scenario.) Type “More Income, Lower Rent” in the Comment box on a new line and then click OK:

[image: ]

	
	In the Scenario Values dialog box, enter 125000 for the value of cell C2, 275000 for the value of C3, and 100000 for the value of C4. (These are the projected increases in income.) Next enter 6000 (a lower rent) for cells E2, E3, and E4 (you may need to scroll down). When you are ready, click OK to create the scenario:

[image: ]

	
	

	
	Now both of the scenarios that you created will be listed in the Scenario Manager. Click the Close button:

[image: ]

	
	

	
	Click on cell I10 in the worksheet to select it. Click Formulas → AutoSum to enter the sum of the profit figures from column I:

[image: ]

	
	

	
	Press Enter to commit the total. The current total profit will be $837,000:

[image: ]

	
	

	
	Next, click Data → What-If Analysis → Scenario Manager:

[image: ]

	
	

	
	In the Scenario Manager, click to select the “Projected Income and Rent” scenario from the list and click Show:

[image: ]

	
	

	
	Take note of how the data changes with the selected scenario now applied:

[image: ]

	
	Click the Close button to close the Scenario Manager:

[image: ]

	
	Save your work as Activity 3-2 Complete and then close Microsoft Excel.




[bookmark: _Toc51249635]TOPIC C: Perform a What-If Analysis

Building scenarios is only one way to perform a what-if analysis of your data in Excel. You can also use the Goal Seek feature to set a formula to a value (goal) that you would like to attain, and then specify one of the cells that the formula references as a cell that Excel should adjust in order to reach the goal. In addition, the Solver feature helps you solve complex problems. Over the course of this topic, you will learn about these tools.

Topic Objectives
In this topic, you will learn:
About add-in types
About the Goal Seek feature
About the Solver tool

[bookmark: _Toc51249636]Add-In Types
There are some interesting data analysis tools provided as add-ins for Excel, such as the Analysis ToolPak and the Solver. In a general sense, add-ins can be described as small software modules or files that extend the functionality of the larger Office applications. 

The important thing to know is that these add-ins are not enabled in Excel when it is installed, as they often provide more obscure or mathematically advanced functionality than is required in a typical business environment. You must enable them manually from within Excel.
The first step in enabling add-Ins is to navigate to the add-in management section of the Excel Options dialog box. To start, click File → Options: 

[image: ]


When the Excel Options window opens, click the Add-Ins category: 

[image: ]

Excel provides a list of all add-ins installed on your computer and their current status. This list is broken down into the following sections: 
Active Application Add-ins
Inactive Application Add-ins
Document Related Add-ins
Disabled Application Add-ins

If you click the Manage drop-down menu near the bottom of the window, you will see the following options:

[image: ]

Here you can see two types of add-ins at the top of the list: COM Add-ins and Excel Add-ins. COM stands for component object model, a Microsoft technology that helps software components (like Microsoft Office programs) to communicate. For example, a form of COM technology is used to allow Word documents to link to data in Excel spreadsheets. Often a single COM add-in will be available for a number of Office applications.

For the purposes of this topic, we are interested in the add-ins designed specifically for Excel. To view and manage these add-ins, select Excel Add-ins from the Manage combo box and click Go:

[image: ]

After clicking Go, the Add-Ins dialog will appear and show a list of the available Excel add-ins: 

[image: ]

If an add-in is enabled, it will have a checkmark next to its name in the list. In the image above, no Excel add-ins are enabled yet. To see a brief description of an add-in, select it in the list and then look at the bottom of the dialog. In the example above, the Analysis ToolPak add-in is selected and its description appears at the bottom.


To enable a particular add-in, click to place a checkmark in the appropriate checkbox and click OK. Here the Solver add-in is about to be enabled:

[image: ]

If you see a dialog stating that the add-in you are enabling is not currently installed on your computer, simply click the Yes button to install it. (You may also need to close and re-open Excel.) 

[bookmark: _Toc51249637]Goal Seek Feature
Goal Seek is a useful what-if analysis tool built into Excel. It is used to find the values in a specified cell that will lead to a specified goal value in another cell. In other words, you can set a formula to a value (goal) that you would like to attain, and then specify one of the cells that the formula references as a cell that Excel should adjust in order to reach the goal. 



Take the following worksheet as an example:

[image: ]

In the Formula Bar, you can see that Total Profit formula is the Total Income (B4) minus the Total Cost (B7). It should be noted that cells B4 and B7 themselves contain formulas. The formula in cell B4 is =B2*B3 (Units Sold multiplied by Price per Unit). The formula in cell B7 is =(B5*B2)+B6 (Materials per Unit multiplied by Units Sold) plus the labor to make the units. 

The following image shows the worksheet with some sample data:

[image: ]

Clearly, at current production levels the company is losing profit. How would you figure out how many units to manufacture to break even or make a profit? One solution is to use Goal Seek to find a breakeven point based on changes to a cell that is referenced (directly or indirectly) by the profit formula in cell B8.



To begin, we will select cell B8 (the cell with the profit formula). Then, we will invoke the Goal Seek dialog by choosing Data → What-If Analysis → Goal Seek:

[image: ]

When the Goal Seek dialog box appears, B8 is already entered in the “Set cell” box because that is the cell that we selected just prior to invoking Goal Seek:

[image: ]

In the “To value” box, we will enter 0 (since a profit of 0 is the breakeven point). In the “By changing cell” field, we will enter B2 (the number of units required). When everything is set up, the Goal Seek dialog looks like the following image:

[image: ]



When you click OK, Goal Seek will find a value for cell B2 (units sold) that will make the profit formula (B8) equal to 0 (breakeven): 

[image: ]

The Goal Seek Status dialog reports that a solution has been found, and you can see the value 300 in cell B2. This means that if all other variables remain unchanged, you must sell 300 units to break even. At this point, you can click Cancel to restore the original worksheet values, or click OK to enter Goal Seek’s solution values into the worksheet.

[bookmark: _Toc51249638]The Solver Tool
Solver is used to set a specified cell to a certain value which will then have the effect of changing other cells associated with the cell in question to meet the new value. For example, suppose that you want to increase the profits of the company by 5%. By setting this option to the current profit, plus 5%, other areas such as sales, employee costs, and material costs will change accordingly to fit the new value. 

Note that in order to use Solver, you need to enable the related add-in. See the first concept in this topic for more information.

The Solver Parameters Dialog Box
To begin using Solver, open the Solver Parameters dialog box by clicking Data → Solver: 

[image: ]


The Solver Parameters dialog box will open:

[image: ]

At the top of this dialog box, the Set Objective field allows you to set the objective cell where you want the target result to be displayed. The To radio buttons are used to set a desired maximum, minimum, or fixed value in the object cell. The By Changing Variable Cells text box allows you to enter the cell references of variable cells. These are the cells that will change to meet the value in the objective cell. 

Next, the “Subject to the Constraints” list box will list any constraints that exist. Clicking the Add button will allow you to add a new constraint, while the Change button will display the Change Constraint dialog box. There, you can adjust the selected constraint accordingly. The Delete button will delete a selected constraint, while the Load/Save button will load or save a problem model. Clicking the Options button will display an advanced feature set and clicking the Solve button will attempt to solve the problem you outlined in this dialog box.

[bookmark: _Toc51249639]Activity 3-3
Using Solver to Perform a What-If Analysis

You would like to figure out how much more income Store 3 needs to earn in order for the total company profit to reach $1,000,000. Additionally, on another worksheet in the provided workbook, you need to figure what the ideal number of widgets is to make in order to maximize revenue. 

	12. 
	To begin, open Activity 3-3 from your Exercise Files folder:

[image: ]

As well, ensure that the Solver add-in is enabled.

	
	

	
	Select cell I10 (the profit total) and then click Data → What-If Analysis → Goal Seek:

[image: ]


	
	

	
	When the Goal Seek dialog appears, ensure that I10 appears in the “Set cell” field. In the “To value” box, type 1,000,000: 

[image: ]

(This is the daily profit we would like to make.)

	
	

	
	Next, in the “By changing cell” box, enter the cell that will be changed to meet the profit goal of 1000000. Since we want to find out how much more income Store 3 needs to earn to reach this goal, type “C4” into this text box:

[image: ]

	
	

	
	Click OK to find out how much more income Store 3 needs to earn so that the company profit will reach $1,000,000:

[image: ]

	
	

	
	When Goal Seek finds a solution, the values will be entered into the worksheet and the Goal Seek Status dialog box will be displayed: 

[image: ]

In this case, you can see that the income in cell C4 has changed to 266,000. 

	 
	

	
	If you click Cancel, the worksheet will revert to the original values. If you click OK, the worksheet will retain the solution values. For this example, click OK: 

[image: ]

	 
	

	
	Next, you need to use Solver. Ensure that the Solver add-in is enabled and then switch to Sheet2: 

[image: ]

	
	

	
	Click Data → Solver: 

[image: ]

	 
	

	
	First, set the objective cell to D9 (sum of revenues). Note that the Max radio button is also selected, meaning the maximum possible value will be calculated: 

[image: ]

	 
	

	
	Now enter “B7, C7” in the By Changing Variable Cells box: 

[image: ]

This tells Solver to modify the number of units made to achieve maximum profit.

	 
	

	
	Next, you will add the constraints. Click the Add button: 

[image: ]

	
	

	
	The first constraint will involve the material processing hours. F3 must be less than or equal to (<=) B12, so enter the appropriate constraints. Click Add:

[image: ]

	
	

	
	The Add Constraint dialog box will still be open. The second constraint that you need to add involves labor costs. Labor hours (G3) must be less than or equal to the constraints (B13), so enter this information as you see below and click OK:

[image: ]

	
	

	
	Back in the Solver Parameters dialog box, click Solve to continue:

[image: ]

	
	

	
	When the Solver Results dialog appears, click each of the three report types to select them and then click the Outline Reports checkbox. Click OK to continue: 

[image: ]

	
	

	
	Look carefully at the worksheet. Solver has determined that 2.9 Value Models and 3.6 Premium Models can be determined given the time constraints. Realistically, this means that 2 Value Models and 3 Premium Models can be completed in the given time:

[image: ]

	
	

	
	Excel also generated three reports in the workbook. Browse through these tabs:

[image: ]

	
	

	
	Save your work as Activity 3-3 Complete and then close Microsoft Excel.





[bookmark: _Toc51249640]TOPIC D: Perform a Statistical Analysis with the Analysis ToolPak

Just like the Solver tool, the Analysis ToolPak is an add-in that is included with Microsoft Excel that needs to be activated before it can be used. This add-in gives you access to a wide range of statistical tools that are intended to analyze your data and get a better picture of trends or outliers within it. During this topic you will learn about the Analysis ToolPak add-in and how to use it. 

Topic Objectives
In this topic, you will learn:
About the Analysis ToolPak
About the Data Analysis dialog box

[bookmark: _Toc51249641]Analysis ToolPak
Once the Analysis ToolPak has been enabled using the commands in the Add-Ins category of the Excel Options dialog box, you can launch it by clicking Data → Data Analysis: 

[image: ]

The Analysis ToolPak add-in provides an assortment of tools for analyzing scientific, statistical, or engineering related data. A comprehensive exploration of the use of these tools is beyond the scope of this manual. 



[bookmark: _Toc51249642]The Data Analysis Dialog Box
If you click the Data Analysis button on the Data tab, the Data Analysis dialog box will be displayed with a scrollable list of tools: 

[image: ]

The tools available in the list are intended for quite specific and advanced data analysis techniques. To start one of the tools, click to select the tool in the list and then click OK:

[image: ]

[bookmark: _Toc51249643]Activity 3-4
Performing a Data Analysis with the Analysis ToolPak

You would like to view some detailed statistics about the sales data from all of the stores in your region.

	13. 
	To begin, open Activity 3-4 from your Exercise Files folder: 

[image: ]

	
	

	
	To start, let’s ensure that the Analysis ToolPak is enabled. Click File → Options: 

[image: ]

	
	

	
	In the Excel Options dialog box, click the Add-Ins category: 

[image: ]

	
	

	
	With the Add-Ins category now displayed, ensure that the Excel Add-ins option is selected within the Manage drop-down menu. Click Go: 

[image: ]

	
	

	
	In the Add-Ins dialog box, ensure that the Analysis ToolPak check box is checked and then click OK: 

[image: ]

	 
	

	
	Back in the primary Excel window, click Data → Data Analysis:

[image: ]

	 
	

	
	In the Data Analysis dialog box, click to select the Descriptive Statistics tool and then click OK: 

[image: ]

	 
	

	
	The Descriptive Statistics dialog box will now be displayed. With the Input Range text box selected, use your cursor to select the C1:G9 range on the current worksheet: 

[image: ]

	 
	

	
	With the input range now set, check the “Labels in First Row” box: 

[image: ]

This will ensure that the column header will be entered as labels for each column of statistics.

	
	

	
	Next, click the Output Range radio button: 

[image: ]

	
	

	
	Within the Output Range text box, type C12: 

[image: ]

	
	

	
	Finally, check the “Summary statistics” box:

[image: ]

	
	

	
	Click OK to complete the analysis and display the results: 

[image: ]

	
	

	
	Detailed statistics about the input range that you previously selected will now be displayed below the existing data (starting with cell C12): 

[image: ]

	
	Save your work as Activity 3-4 Complete and then close Microsoft Excel.





[bookmark: _Toc51249644]Summary
Over the course of this lesson you learned about the many tools in Excel that you can use to analyze your data. You should now be comfortable creating Sparklines to illustrate your data, as well as creating scenarios to predict the consequences of changes to your data. You should now know about a what-if analysis and how to conduct it in Excel using the various tools that are available. Additionally, you should now be able to perform data analysis using the Analysis ToolPak.
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Lesson 4:
Working with Multiple Workbooks



Lesson Objectives

In this lesson you will learn how to:
Consolidate data
Link cells in different workbooks
Merge workbooks


[bookmark: _Toc51249646]
TOPIC A: Consolidate Data

When working with Excel, you may find that you need to reference data in multiple separate workbooks. Normally this would be a difficult task, but with Excel’s consolidation features, you can summarize data from multiple worksheets into one worksheet. Over the course of this topic, you will learn how to consolidate data from different worksheets into one condensed summary.

Topic Objectives
In this topic, you will learn:
About data consolidation 
About the Consolidate dialog box
About consolidation functions

[bookmark: _Toc51249647]Data Consolidation
When you consolidate workbooks, you are combining, condensing, and summarizing data from multiple sources into one destination. For example, a large company may have sales or profit data broken down into several different geographical locations and stored in different workbooks. Each workbook would have the same layout and structure (template), but the data in each will be different. With Excel, you can consolidate the different workbooks, summarizing and totaling the data in one place to get a unified view of your information.

To initiate the data consolidation process, click Data → Consolidate: 

[image: ]

Track Changes
When working with multiple workbooks, it is generally a good idea to keep track of any changes made to your data (like data consolidation). The Track Changes feature will log any changes so that you can accept or reject them. 


[bookmark: _Toc51249648]The Consolidate Dialog Box
Upon clicking Data → Consolidate, the Consolidate dialog box will be displayed: 

[image: ]

Here is an overview of the commands in the top part of this dialog:
The Function drop-down menu contains a variety of functions that you can use to combine data. 
The Reference box is where you enter the ranges of data to be consolidated. You can enter the ranges manually or by selecting them from the different workbooks with your mouse or keyboard. (The latter method is recommended as it is much easier.) 
Once a range is entered, click Add to add it to the “All references” box. This list will contain all the workbook cell references that are to be consolidated. 

At the bottom of the dialog, you will notice the section “Use labels in,” with two checkboxes below it:

[image: ]

You can check these boxes to consolidate sheets based solely on row labels or column labels. That means that data in columns or rows that have the same labels will be consolidated even if the labels are under different column letters or row numbers in the source workbooks. (This is why consolidation is easier when all the worksheets involved have the same labels and design layout.) For this example, the checkboxes are empty so the consolidation will be based on the actual cell locations.

If you check the “Create links to source data” box, the information in the destination workbook will be updated if the content in the contributing source workbook is changed. 

[bookmark: _Toc51249649]Consolidation Functions
The Function menu in the Consolidation dialog box contains a variety of functions that you can use to combine data. Below you can see a brief list of all the functions that are available: 

	Sum
	Adds all the values in the list.

	Count
	Provides a count of how many cells have data.

	Average
	Shows the mean value in the list.

	Max
	Gives the highest number in the list.

	Min
	Gives the lowest number in the list.

	Product
	Multiplies all of the numbers in the list together.

	Count Numbers
	Counts the number of cells that have values that meet a specified criteria.

	StdDev
	Provides the standard deviation of the list, if the list is a sample of a larger population of data.

	StdDevp
	Provides the standard deviation of the list, if the list includes the entire population of data.

	Var
	Gives the variance of the list, if the list is the sample of a larger population of data.

	Varp
	Will give the variance of the list, if the list includes the entire population of data.






[bookmark: _Toc51249650]Activity 4-1
Consolidating Data

To streamline some of your working processes, you would like to have data from three different workbooks consolidated into one location. 

	14. 
	To begin, open Activity 4-1A, Activity 4-1B, Activity 4-1C, and Activity 4-1D from your Exercise Files folder. As Sheet1 in the Activity 4-1D workbook will be the destination for the consolidated data, ensure that it is currently open and displayed:

[image: ]

Maximize all workbook windows if necessary.

	
	

	
	In the Activity 4-1D workbook, ensure that cell A1 is selected. This is where the consolidated data will be placed: 

[image: ]

	
	

	
	In the Activity 4-1D workbook, click Data → Consolidate: 

[image: ]

	
	

	
	The Consolidate dialog box will now be displayed. Open Sheet1 in the Activity 4-1A workbook and select cells B2:B35: 

[image: ]

	
	

	
	Back in the Consolidate dialog box, click Add: 

[image: ]

	 
	

	
	Now, open Sheet3 in the Activity 4-1B workbook and select cells B2:B35:

[image: ]

	 
	

	
	Back in the Consolidate dialog box, click Add: 

[image: ]

	 
	

	
	Now, open Sheet2 in the Activity 4-1C workbook and select cells B2:B35:

[image: ]

	 
	

	
	Back in the Consolidate dialog box, click Add: 

[image: ]

	 
	

	
	Click the Function drop-down menu and click Average: 

[image: ]

	
	

	
	Click OK: 

[image: ]

	
	

	
	The average for each product cost across the three worksheets will now be listed:

[image: ]

	
	

	
	Save your work as Activity 4-1 Complete and then close Microsoft Excel without saving any changes to the other workbooks.





[bookmark: _Toc51249651]TOPIC B: Link Cells in Different Workbooks

In Excel, you not only have the ability to link to worksheet cells within the current workbook; you can also link to worksheet cells within entirely separate workbooks. In this topic you will learn about external references and how to create them.

Topic Objectives
In this topic, you will learn:
About external references

[bookmark: _Toc51249652]External References
External references (sometimes referred to as links) refer to the contents of a cell or cells within the worksheet of another workbook. The primary benefit of linking to cells in other workbooks is to save time. 

While external references share much of the same syntax as typical cell references in Excel, there are some key differences. First, there are actually two different ways that you can create external references depending on if the referenced workbook is open. 

If the referenced workbook is open, you can include the workbook name in square brackets, followed by the worksheet name, an exclamation point, and then the cell reference: 

[image: ]

If the referenced workbook is, or will be, closed when this external reference is used or created, you need to format the external cell reference differently. In such cases, the external reference needs to include the entire file path to the workbook in question, followed by the workbook name in square brackets, the worksheet name, an exclamation point, and finally the cell reference: 

[image: ]

(Note that the file path, workbook name, and worksheet name need to be enclosed in single quotation marks when creating this external reference type.) 




[bookmark: _Toc51249653]Activity 4-2
Linking Cells in Different Workbooks

The workbook that you are working with (Activity 4-2A) separately summarizes data from another workbook (Activity 4-2B). In the first workbook (Activity 4-2A) you would like to display a count of the number of entries within that other workbook (Activity 4-2B), without having to copy those entries manually.

	15. 
	To begin, open Activity 4-2A from your Exercise Files folder:

[image: ]

	
	

	
	Ensure that cell C6 is selected in the current worksheet and then click inside the Formula Bar. Type “=COUNT(“:

[image: ]

	
	

	
	With the source workbook open, you don’t need to include the file path. With that in mind, type ‘[Activity 4-2B.xlsx]Sheet1’ into the Formula Bar (including the quotation marks): 

[image: ]

(Single quotations appear around the workbook name and the worksheet name due to the space in the file name.)

	
	

	
	Now type “!A2:A35)” into the Formula Bar to complete the function and reference: 

[image: ]

	
	

	
	Press Enter on your keyboard. The Update Values dialog box will now be displayed. Use the controls in this dialog box to locate Activity 4-2B within your Exercise Files folder. Click to select that file and then click OK: 

[image: ]

	 
	

	
	The value calculated using the external reference data will now be displayed within cell C6: 

[image: ]

	 
	

	
	Save your work as Activity 4-2 Complete and then close Microsoft Excel.



[bookmark: _Toc51249654]Summary
Over the course of this lesson, you learned how to work with multiple workbooks in a variety of different ways. You should now be comfortable consolidating data using the tools in Excel. Additionally, you should now be able to link to cells in different workbooks and use the Compare and Merge Workbooks feature.



Lesson 5:
Exporting Excel Data



Lesson Objectives

In this lesson you will learn how to:
Export Excel data
Import a delimited text file
Integrate Excel data with the web



[bookmark: _Toc51249656]
TOPIC A: Export Excel Data

While Microsoft Excel is a very popular application, not everyone may have access to it. If you are in a situation where you need to send Excel data to someone and you are unsure if they have access to Microsoft Excel, you can export the data into a more universal format. Over the course of this topic, you will learn how to export Excel data into different file formats, as well as how to share workbooks with other users.

Topic Objectives
In this topic, you will learn:
About exporting Excel data

[bookmark: _Toc51249657]The Export Process
Exporting from Microsoft Excel allows you to send your Excel data from one application to another. For example, you can export Excel data from workbook to plain-text format so that it can be opened in any text editor. 

There are lots of file types that you can export Excel data into. Below we have outlined the more common options.

	XML
	Extensible Markup Language (XML) is used for many web-based applications. 

	HTML
	Hypertext Markup Language (HTML) files can be viewed in a web browser and are often found on the Internet.

	TXT
	This option allows you to save your data as a tab-delimited text file. This type of file can be opened by many different editors; however, keep in mind that only the active worksheet in a workbook can be exported into this format.

	CSV
	This file type stands for Comma-Separated Values. It is frequently used to move tabular data between applications. 

	PDF
	Created by Adobe, the Portable Document Format (PDF) is a commonly used document format type. This format is great for quick viewing or printing of data, but does not allow for editing. 

	XPS
	The XML Paper Specification (XPS) file format is similar to PDF in that it is used for viewing and printing documents. It is fully supported by most Microsoft applications and operating systems.






[bookmark: _Toc51249658]Activity 5-1
Exporting Excel Data

Data relating to your company’s inventory needs to be sent to a logistics firm that your company has contracted work out to. In order for them to work with the data, they require it to be sent in the CSV format.

	16. 
	To begin, open Activity 5-1 from your Exercise Files folder: 

[image: ]

	
	

	
	To save the current workbook using the Comma Separated Values (CSV) file type, click File → Export: 

[image: ]

	
	

	
	Click Change File Type: 

[image: ]

	
	

	
	Inside the Other File Types section of the Change File Type pane, click to select “CSV (Comma delimited):” 

[image: ]

	
	

	
	Click the Save As command: 

[image: ]

	 
	

	
	Browse to your desktop. Type “Activity 5-1 Complete” into the “File name” text box and click Save: 

[image: ]

	 
	

	
	A warning message will be displayed that indicates you will lose some functionality if you save your data in this format. Click Yes to continue: 

[image: ]

	 
	

	
	A copy of the current workbook has been saved using the CSV file type. Close Microsoft Excel without saving any changes.

	
	

	
	Browse to your desktop and open the newly saved CSV file using Microsoft Excel to view how it appears in this new format: 

[image: ]

As you can see, much of the formatting has been stripped out, but the data is still intact.

	 
	

	
	Close Microsoft Excel.





[bookmark: _Toc51249659]TOPIC B: Import a Delimited Text File

While you are able to export Excel data into a variety of formats, you can also import them into Excel as well. Over the course of this topic you will learn about the data importing process. We will focus on how to import delimited text files, as they are commonly used to transfer tabular data between applications. 

Topic Objectives
In this topic, you will learn:
About importing data into Excel
About the Get External Data group on the Data tab
About delimited text files
About the various methods of importing text files

[bookmark: _Toc51249660]The Import Process
The process of opening data in one application that was saved in another application is called importing. When working with Excel in particular, you have the option to import all sorts of different file types. Commonly, however, text files (with the .txt extension) are used to transfer data between applications. 

When importing a text file into Excel, you have the option to import all of it or only a portion. When the process is complete, the imported data will look like data that was directly entered into Excel. 





[bookmark: _Toc51249661]The Get External Data Group
The Get External Data group offers commands to access data from outside of Excel. These sources include Microsoft Office Access databases, web pages, a variety of text-based data files, and external databases. You can also manage existing external data sources: 

[image: ]

[bookmark: _Toc51249662]Delimited Text Files
When data is saved as delimited text, the text is entered with one row equaling one line of text. Additionally, these types of text files are special in that they are also delimited (separated) by tab spaces. This type of text is capable of being read by many different programs on nearly any computer platform. This characteristic makes the data very portable, meaning the raw data can be used just about anywhere.

[bookmark: _Toc51249663]Methods of Importing Text Files
Text files can be imported into Excel in one of two ways. The first is to open the file directly in Excel using the File → Open command. Or, you can import it as a data range using a wizard by clicking Data → From Text. 

While opening the text file directly doesn’t require you to link to the text file, the data won’t be refreshed if the text file is updated. That is the primary benefit of importing it as a range using the wizard. 



[bookmark: _Toc51249664]Activity 5-2
Importing a Delimited Text File

You have received a text file containing data that you need for an upcoming project. In this activity, you will import this delimited text file into Excel.

	17. 
	To begin, open Activity 5-2A using Microsoft Excel:

[image: ]

	
	

	
	Click Data → From Text/CSV: 

[image: ]

	
	

	
	The Import Text File dialog box will now be displayed. Navigate to your Exercise Files folder and click to select Activity 5-2B. Click Import: 

[image: ]

	
	

	
	The Text Import Wizard will now be displayed. On the first screen of this wizard, ensure that the Delimited drop down arrow is set to tab. Click Load: 

[image: ]

	 
	

	
	The data will now have been imported into the current worksheet: 

[image: ]

	 
	

	
	Save your work as Activity 5-2 Complete and then close Microsoft Excel.



[bookmark: _Toc51249665]Summary
Over the course of this lesson, you learned about the many different ways that you can export data from Excel. You should now be comfortable exporting your workbook into a variety of different formats and sharing them with other users. Additionally, you should now be able to import data from a text file into a workbook. You should also be comfortable publishing data to a web page and using web queries.




[bookmark: _Toc142298747][bookmark: _Toc142298995][bookmark: _Toc142299119][bookmark: _Toc362859123][bookmark: _Toc7596769][bookmark: _Toc51249666][bookmark: _Toc497656834]Lesson 6: 
Using Pivot-Tables

Lesson Objectives
In this lesson you will learn how to:
Insert PivotTables
Work with PivotTable data
Sort and filter PivotTable data

[bookmark: _Toc142298748][bookmark: _Toc142298996][bookmark: _Toc142299120][bookmark: _Toc362859124][bookmark: _Toc7596770][bookmark: _Toc51249667]TOPIC A: Inserting PivotTables
An important function of any spreadsheet program is to help you derive meaning from your data. An Excel PivotTable is a great tool for doing this, as it can help you get different perspectives as you analyze the relationships between the columns and rows of your data. In this section, you will learn what a PivotTable is and how to create one. You will also learn how to specify and rearrange PivotTable data. 


Topic Objectives
In this section, you will learn:
What a PivotTable is
How to create and use a PivotTable
About the PivotTable Fields task pane

[bookmark: _Toc362859125]

[bookmark: _Toc7596771][bookmark: _Toc51249668]What is a PivotTable?
A PivotTable is a powerful tool for exploring, summarizing, and analyzing information. A PivotTable helps you organize and manipulate the raw data in your spreadsheet to provide insight into patterns or relationships that might not be obvious at first glance. PivotTables also give you the power to summarize your data and view it in a different context, without changing the original content or structure of the data in the worksheet. 
With a PivotTable, you can conveniently drag and drop columns of your data to different areas of the table to examine relationships or trends that may not be obvious in a traditional Excel table. 
Rather than build several regular tables to explore how columns from an Excel worksheet relate to each other (or to see the data summarized in different ways), you can use one PivotTable to do the same thing. With a PivotTable, you can alter the table design without cutting, copying, pasting, or adjusting formulas and cell references. In short, PivotTables enable you to organize your data in meaningful ways, without doing a lot of tedious work. You could say that a PivotTable is like several data tables rolled into one.
Ideally, the source data for a PivotTable should be structured like a traditional Excel table or database. The source data should have unique column headings distinguishing the data, and there should be no empty columns or rows within the data.
[bookmark: _Toc142297253][bookmark: _Toc142297501][bookmark: _Toc142298750][bookmark: _Toc142298998][bookmark: _Toc142299122][bookmark: _Toc362859126]

[bookmark: _Toc7596772][bookmark: _Toc51249669]Creating a PivotTable
To create a PivotTable, select the range of data on which you want to base the table, and then click “Insert → PivotTable:”

[image: ]


The Create PivotTable dialog box will open:
[image: ]
Here, you can specify the data range for the PivotTable and choose to locate your PivotTable in an existing worksheet or a new worksheet. Once you are ready, click “OK” to create your PivotTable. Here, we have added our PivotTable to a new worksheet:

[image: ]


Now, we can add information to it by placing checks in the boxes next to the fields in the PivotTable Fields pane. As you do this, the PivotTable itself will be populated with the corresponding data:

[image: ]

[bookmark: _Toc497656838][bookmark: _Toc362859128]

[bookmark: _Toc7596773][bookmark: _Toc51249670]The PivotTable Fields Task Pane
When you insert a PivotTable into your workbook, the PivotTable Fields task pane will automatically be displayed on the right side of the Excel window: 
[image: ]
Let’s review each area. 
1. The top portion of this pane lists all of the fields from the dataset. To add or remove a field from the PivotTable, toggle the corresponding checkbox. Alternatively, to give you more control over field placement on the PivotTable, you can click and drag these fields to the PivotTable itself. 
2. Adding fields to the Filters area will include those field values as filter criteria. 
3. The Columns area will create columns out of unique field entries. 
4. Similarly, the Rows area will create rows out of unique field entries. 
5. Finally, fields that are dragged to the Values area will have calculations performed on them or their values summarized. 
6. All fields in these four areas will include a pull-down arrow that contains commands to move the field to another area of the task pane (or remove it entirely).
7. Click the “X” to hide the task pane.
Remember that any changes you make in the PivotTable Field List pane will be applied dynamically. Additionally, due to the flexible nature of PivotTables, you can add or remove fields to or from this task pane at any time. 
 
[bookmark: _Toc7596774][bookmark: _Toc51249671]Working with PivotTable Data
As mentioned previously, the easiest way to add data to the PivotTable is to place checkmarks next to the desired fields in the PivotTable Fields task pane. You can just as easily remove the fields from the table by clearing the checkmarks. 

The order in which you click to place your checkmarks is very important, as this will also be the order of placement for the fields in the PivotTable. In this example, the Rows section contains the Full Name field followed by the Region field:
[image: ]


Watch what happens when we drag the Region field above the Full Name field:
[image: ]
You can see that the names are now organized by region.

Watch what happens when we add the Sub-Region field below the Region field:
[image: ]
You can see that this has created yet another level of organization.


As a final note, you can access move commands from each field’s drop-down menu. Note that there is also an option here to remove the field from the PivotTable entirely:

[image: ]


[bookmark: _Toc7596775][bookmark: _Toc51249672]Activity 6-1: Inserting PivotTables
In this activity, you will create a PivotTable and experiment with its data.
	18. 
	To begin, open Activity 6-1. Open the workbook in Editing View.

	19. 
	The Financial Data worksheet should be active. Ensure that any cell in the table is active, and then click “Insert → PivotTable:”
[image: ]

	20. 
	The Create PivotTable dialog box will open. The Table/Range field should say Table1, and the New Worksheet radio button should be selected. (If either of these settings are not correct, change them now.) Click “OK:”
[image: ]

	21. 
	A new worksheet will be created with the PivotTable:
[image: ]

	22. 
	In the PivotTable Fields pane, check the City, State, and Net Profit fields. Observe the results:
[image: ]

	23. 
	In the Rows area, drag the State field above the City field:
[image: ]

	24. 
	Review the results:
[image: ]

	25. 
	Let’s see the summarized values broken down a bit further. Drag the Office Type field to the Columns area:
[image: ]

	26. 
	Review the results:
[image: ]

	27. 
	Close the Excel browser tab to complete this activity.


[bookmark: _Toc142298755][bookmark: _Toc142299003][bookmark: _Toc142299127][bookmark: _Toc362859133]
[bookmark: _Toc7596776][bookmark: _Toc51249673]TOPIC B: Working with PivotTable Data
Now that you know how to create a PivotTable and pivot data, it is time to learn about some of the other options that Excel provides for manipulating this data. In this section, you will learn about expanding and collapsing data, refreshing the data source, renaming fields, summarizing values, and changing value display.


Topic Objectives
In this section, you will learn how to:
Expand and collapse data
Refresh data
Rename fields
Summarize values
Change value display

[bookmark: _Toc362859134]

[bookmark: _Toc7596777][bookmark: _Toc51249674]Expanding and Collapsing Data
You can view more or less PivotTable data by expanding or collapsing it. A minus sign means you can collapse the data down:
[image: ]
While a plus sign means you can expand it:
[image: ]
In the first picture, we can see the two sub-regions of Asia and all the details. In the second picture, this data has been collapsed, so we can just see the top level of the data: Asia.



Remember that these levels are defined by the fields’ positions in the Rows section of the PivotTable Fields task pane:
[image: ]



[bookmark: _Toc362859138][bookmark: _Toc7596778][bookmark: _Toc51249675]Refreshing Data
If your source data has changed, but the PivotTable is not reflecting those changes, you can trigger a refresh by right-clicking the PivotTable and clicking “Refresh:”
[image: ]



[bookmark: _Toc7596779][bookmark: _Toc51249676]Renaming Fields 
Fields in the Values area of the PivotTable Fields task pane will have the calculation type added to their field name in the PivotTable display:
[image: ]

However, if we try to change this text, we will receive an error:
[image: ]


Instead, click the drop-down arrow next to the field in the PivotTable Fields task pane and click “Value Field Settings:”
[image: ]
The Value Field Settings dialog box will open. Enter the new name and click “OK:”
[image: ]


The change will now be applied in both the PivotTable and the task pane:
[image: ]
[bookmark: _Toc142297263][bookmark: _Toc142297511][bookmark: _Toc142298760][bookmark: _Toc142299008][bookmark: _Toc142299132][bookmark: _Toc362859140]


[bookmark: _Toc7596780][bookmark: _Toc51249677]Summarizing Values
You can also use the Value Field Settings dialog box for a few other purposes. For example, right now our PivotTable is showing the sum of all the sales made in Q1:
[image: ]
Let’s say we want to see the average of all sales instead. To start, we will click the drop-down arrow next to the field in the Values area of the PivotTable Fields task pane and click “Value Field Settings:”
[image: ]
The Value Field Settings dialog box will open to the Summarize Value by Tab. Choose the new calculation and click “OK:”
[image: C:\Users\Kimberly\AppData\Local\Temp\SNAGHTML43a8a275.PNG]
The new calculation will be performed. Notice that the column header has changed, too:
[image: ]


[bookmark: _Toc7596781][bookmark: _Toc51249678]Changing Value Display
The Value Field Settings dialog box has another tab: Show Values As.
[image: ]
These options allow you to perform advanced functions on the selected field, such as showing running totals or percentages. Simply set your options and click “OK” to apply the change.

[bookmark: _Toc7596782][bookmark: _Toc51249679]Activity 6-2: Working with PivotTable Data

[bookmark: _Toc142297264][bookmark: _Toc142297512][bookmark: _Toc142298761][bookmark: _Toc142299009][bookmark: _Toc142299133]In this activity, you will customize the financial data PivotTable you created in the last activity.
	28. 
	To begin, open Activity 6-2. Open the workbook in Editing View.

	29. 
	Click inside the PivotTable to show the PivotTable Fields task pane:
[image: ]
(If the task pane is already displayed, skip this step.)

	30. 
	We want to focus on the average profit by branch type and state. Click the minus sign beside each state abbreviation to collapse the data:
[image: ]

	31. 
	Now, click the drop-down arrow next to the “Sum of Net Profit” field in the Values area of the PivotTable Fields task pane:
[image: ]

	32. 
	Click “Value Field Settings:”
[image: ]

	33. 
	The Value Field Settings dialog box will open to the Summarize Value By tab. Click the Average function from the list:
[image: ]

	34. 
	Then, click the Custom Name field. Change the word “Sum” to “Average” and remove the word “of:”
[image: ]

	35. 
	Click “OK” to apply the changes:
[image: ]

	36. 
	Review the results:
[image: ]
(Notice that Excel has re-added the word “of” since it is a required convention.)

	37. 
	Close the Excel browser tab to complete this activity.



[bookmark: _Toc142298762][bookmark: _Toc142299010][bookmark: _Toc142299134][bookmark: _Toc362859142]

[bookmark: _Toc7596783][bookmark: _Toc51249680]TOPIC C: Sorting and Filtering PivotTable Data 
The final topic we will explore is how to sort and filter PivotTable data. If you have completed the lessons on sorting and filtering worksheet and table data, you will notice that these tasks are almost exactly the same with PivotTables, although there are some additional options available. 

Topic Objectives
In this section, you will learn how to:
Sort PivotTable data
Use the Filters pane
Use label and value filters
Clear filters 


[bookmark: _Toc7596784][bookmark: _Toc51249681][bookmark: _Toc362859136]Sorting Data
To sort PivotTable data, click the Row Labels or Column Labels drop-down arrow (depending on what you want to sort), choose the field you want to sort by, and choose the desired sort type:
[image: ]
In addition to the Sort Ascending and Sort Descending options we have seen previously (which will sort the data in those fields), the Sort By Value command opens the following dialog box:
[image: ]
These additional options will sort the numerical data in the PivotTable rather than the row or column headers. 



[bookmark: _Toc7596785][bookmark: _Toc51249682]Using the Filters Pane
You can use the Filters area of the PivotTable Fields pane to filter the PivotTable data. For this example, let’s filter by region:

[image: ]

Now, we will see a Region menu at the top of the PivotTable. Let’s click the drop-down arrow to get started:
[image: ]


The Filter dialog box will open. Here, we can check the region(s) we want to view and click “OK:”
[image: ]


Here are the results:
[image: ]

Notice that the Region filter menu shows that the data is being filtered. We can click this filter icon to re-open the Filter dialog box and modify our settings.


[bookmark: _Toc7596786][bookmark: _Toc51249683][bookmark: _Toc142297260][bookmark: _Toc142297508][bookmark: _Toc142298757][bookmark: _Toc142299005][bookmark: _Toc142299129]Using Label and Value Filters
You can also access filtering options from the Row Labels and Column Labels drop-down menus:
[image: ]
The Filter command will open the dialog box we just looked at, while the Label Filters and Value Filters menus work in the same way as the filtering options discussed in Lesson 2-E:
	[image: ]
	[image: ]



Remember, clicking each of these commands will open the Custom Filter dialog box, pre-populated with the selected operator. You can then enter the criteria required. Here is an example:
[image: ]

(Notice that from this dialog box you can change the field being filtered and the operator.)

[bookmark: _Toc7596787][bookmark: _Toc51249684]Clearing Filters 
There are two ways to clear a filter. If you have applied it from the Row Labels or Column Labels menu, you can also clear it from there:
[image: ]

If you have applied the filter from the PivotTable Fields task pane, click the drop-down arrow and click “Remove Field:”
[image: ]


[bookmark: _Toc7596788][bookmark: _Toc51249685]Activity 6-3: Sorting and Filtering PivotTable Data
In this activity, you will sort and filter your financial data PivotTable.
	38. 
	To begin, open Activity 6-3.  Open the workbook in Editing View.

	39. 
	Click inside the PivotTable to show the PivotTable Fields task pane:
[image: ]
(If the task pane is already displayed, you can skip this step.)

	40. 
	First, let’s move the Office Type field from column display to a filter. To do this, we will drag and drop the field from the Columns area to the Filters area in the PivotTable Fields task pane:
[image: ]

	41. 
	Now let’s use this filter. Click the drop-down arrow in cell B2:
[image: ]

	42. 
	The Filter dialog box will open. Uncheck the Co-Owned and Franchise values (leaving only Corporate) and click “OK:”
[image: ]
This means that only rows with Corporate as the Office Type will be shown in the PivotTable.

	43. 
	The filter will be applied:
[image: ]

	44. 
	Next, we want to sort the states by their average profit. Click the Row Labels drop-down menu:
[image: ]

	45. 
	Choose State (as this is the field we want to sort) and click “Sort By Value:”
[image: ]

	46. 
	Ensure “Average of Net Profit” is selected for the value. Choose the “Largest to Smallest” radio button. Click “OK” to apply the sort:
[image: ]

	47. 
	Review the results. Then, take a moment to think about the different ways you have viewed this data:
[image: ]

	48. 
	Close the Excel browser tab to complete this activity.




[bookmark: _Toc7596789][bookmark: _Toc51249686]Summary
This lesson was all about PivotTables. You should now feel comfortable inserting, modifying, and using PivotTables. You should also be able to sort and filter PivotTable data.




Lesson 7:
Advanced Data Management Concepts


Lesson Objectives

In this lesson you will learn how to:
Import and export XML data
Create Excel forms


[bookmark: _Toc51249688]
TOPIC A: Import and Export XML Data

XML (Extensible Markup Language) is a commonly used programming language that is frequently used to describe data. As such, you may find yourself needing to import and/or export XML data to and from Excel. Over the course of this topic, you will learn about these tasks.

Topic Objectives
In this topic, you will learn:
About XML, including its structure and components
About XML schemas and maps
About the XML Source task pane
How to import and export XML data

[bookmark: _Toc51249689]XML
XML shares a lot of similarities with HTML (Hypertext Markup Language). Despite the similarities in structure, however, the two languages were created with entirely separate goals. XML was designed to transport and store data, with a focus on what the data is. HTML was designed to only display data; it has a focus on how that data looks. 

Another major difference between XML and HTML is that in HTML there are a defined set of tags, meaning that there are set words that a browser interprets as a command. For example, a line in HTML can look like this: <H1>Title Page</H1>.

The browser sees <H1> and </H1> as a command to display the words encapsulated by these tags to a certain specification. Anytime that you need to display text at that specification you need to use the <H1> tags. 



XML is very different when it comes to tags. The tags are completely defined by the author of a XML document. Here is an example of a XML file:

[image: ]

Notice that the tags appear using the same conventions of HTML, with each tag closing with </ >, but it is very different from anything that HTML offers. The tags <company> and <employee>, for example, are the invention of the XML document’s author. It is easy to tell that there are two people named Bob and Jill, each of whom is an employee of a larger company. 

XML’s power lies in its ability to communicate with any platform while delivering its original content. In the above example, no matter what platform we use, we will always know that Bob and Jill are employees working at a company.




[bookmark: _Toc51249690]XML Components
XML includes a few standard file components. The opening tag starts with a less-than symbol (<), followed by the tag name and the greater-than symbol (>).Here is an example: <company>.

The closing tag starts with the less-than symbol (<), followed by the forward slash (/), the tag name, and the greater-than symbol (>). Here is an example: </company>.

Element content refers to anything that appears between two opening and closing tags. In the following example, “Bob” would be considered element content: <name>Bob</name>.

An empty element is unique in that it does not have any content and only acts as markers for where something else is to be placed. Empty elements start with a less-than symbol (<), followed by the tag name, a space, a forward slash, and the greater-than symbol (>). Here is an example: <company />.

The root element is the primary element in an XML file into which all other files are nested. All XML files need to include a single root element that encloses all of the content in the document. For example, <company>… </company> would be considered the root element in the following XML file: 

[image: ]

Finally, an attribute in XML describes elements or provides additional information about them. The attribute values must be enclosed in either single or double quotation marks, like this: <employee name=”Jeff”>.

Note that there is no hard and fast rule between using attributes or elements to describe data. For example <employee name=”Jeff”> is the same as <employee><name>Jeff</name></employee>. That being said, elements are typically more commonly used in XML than attributes.

[bookmark: _Toc51249691]XML Schemas
Using the .xsd file extension, XML schema files are used to define the rules and structure for an associated XML file. Additionally, XML schema files must include the data type and what attributes are allowed in an XML file. An XML schema can be used with multiple XML files.

[bookmark: _Toc51249692]XML Maps
XML maps are created by Excel so that it can adequately format a workbook to fit the criteria set out in an XML schema. This process allows Excel data to be imported as an XML file that meets the requirements of the associated XML schema. 

[bookmark: _Toc51249693]The XML Source Task Pane
To work with XML maps, you will use the XML Source task pane. This task pane includes a variety of different options that allow you to pick existing XML maps for your data, customize XML tags, and more.

To view this task pane, click Developer → Source:

[image: ]

(Remember that the Developer tab must be enabled from the Excel Options dialog.) 


Once you click this command, the XML Source pane will be displayed:

[image: ]


The “XML Maps in this workbook” drop-down list allows you to see and choose from any XML maps that exist within the current workbook: 

[image: ]

Lower in this task pane, the Options drop-down button will provide you with a variety of options that can be used to manage your data. This include toggling preview options, as well as toggling help text:

[image: ]

Finally, the XML Maps button will display the XML Maps dialog box: 

[image: ]

This dialog box allows you to manage XML maps in a variety of different ways. 

Delete an XML Map
To delete an XML map that appears in the workbook, open the XML Maps dialog box and then click to select the map that you would like to delete. Next, click the Delete button: 

[image: ]

A warning dialog box will now be displayed. This asks you to confirm your choice and delete the selected XML map. Click OK to complete the process:

[image: ]

The XML Group
On the Developer tab (hidden by default), you will find the XML group: 

[image: ]

This group contains a variety of commands that allow you to use and customize XML files in Excel. Additionally, the Source button toggles the XML Source task pane on or off.

Change the Location of XML Mapped Elements
To change the location of XML mapped elements that appear within a worksheet, the process is not unlike moving other Excel elements. For example, suppose that you would like to change the location of the mapped XML mapped element from A1 to D1: 

[image: ]

To do this, click to select the element and then click and drag it to cell D1: 

[image: ]

Release your mouse button and the mapped element will appear in its new location: 

[image: ]

[bookmark: _Toc51249694]Import and Export XML Data
Import XML Data
To start importing XML data, open the workbook that you would like to import the data into and then click Developer → Import: 

[image: ]



The Import XML dialog box will now be displayed. Using its controls, browse to the location where the XML file that you would like to import is stored. Click to select the file in question and then click Import: 

[image: ]

Depending upon the file selected, a dialog may be displayed that indicates the XML file does not refer to a schema. If this is the case, click OK to continue and let Excel build one based upon the source data: 

[image: ]

The Import Data dialog will now be displayed. Here, you can choose where in the current worksheet you would like the imported data to be placed. You can also choose to have it placed in a new worksheet. After making your choice, click OK to continue:

[image: ]

The selected XML data will then have been imported into the location you specified. Note that you can view the data source schema in the XML Source task pane by clicking Developer → Source: 

[image: ]

Import XML as External Data
To start importing XML as external data, first open the workbook that you would like to import the data into. Then, click Data → From Other Sources → From XML Data Import: 

[image: ]

The Select Data Source dialog box will open. Browse to the location where the XML file is stored and click to select it. Click Open: 

[image: ]

Depending upon the file selected, a dialog may be displayed that indicates the XML file does not refer to a schema. If this is the case, click OK to continue and let Excel build a schema based upon the source data: 

[image: ]



The Import Data dialog will now be displayed. Here, you can choose where in the current worksheet that you would like the imported data to be placed. You can also choose to have it placed on a new worksheet. After making your choice, click OK to continue:

[image: ]

The selected XML data will then have been imported as external data into the location you specified. Note that you can view the schema in the XML Source task pane by clicking Developer → Source: 

[image: ]

Export XML as External Data
To export XML as external data, open the Excel workbook that contains the data that you would like to export. Then, click Developer → Export: 

[image: ]



The Export XML dialog box will open. Using its controls, find the location on your computer where you want the data to be exported to. Type the name of the file to be exported and then click Export: 

[image: ]



[bookmark: _Toc51249695]Activity 7-1
Importing and Exporting XML Data

You would like to import some XML data into Excel, modify it, and then export the updated data into a new XML file.

	49. 
	To begin, open Activity 7-1 from your Exercise Files: 

[image: ]

As well, ensure that the Developer tab is displayed on the ribbon.
If not displayed, click, File → Options → Customize Ribbon
On the right, select Developer and then OK.

	
	

	
	Click Developer → Import: 

[image: ]

	
	

	
	Use the controls in the Import XML dialog box to browse to the Exercise Files folder on your desktop. Click to select Activity 7-1A and then click Import: 

[image: ]

	
	

	
	A dialog box will be displayed that indicates the XML source does not refer to a schema. Allow Excel to create its own based upon the XML file by clicking OK: 

[image: ]

	
	

	
	The Import Data dialog box will now be shown so that you can choose where you want this data to be placed within the current workbook. Leave the default settings unchanged and click OK:

[image: ]

	 
	

	
	The XML data will now have been imported into the current worksheet: 

[image: ]

	 
	

	
	Click to select cell A1. Replace the contents with “799” and press Enter: 

[image: ]

	 
	

	
	Export this data as an XML file by clicking Developer → Export:

[image: ]

	 
	

	
	Type “Activity 7-1A Complete” into the “File name” text box and click Export: 

[image: ]

	 
	

	
	Save the changes that were made to your current Excel workbook as Activity 7-1 Complete. Close Microsoft Excel.






[bookmark: _Toc420237611][bookmark: _Toc51249696]TOPIC B: Create Excel Forms

As a workbook grows and becomes more complex, entering new data can become a chore. To make data entry and other tasks for larger workbooks easier and more user-friendly, Excel offers the ability to create forms. Over the course of this topic, you will learn all about Excel forms, including how they are used and how to create them.

Topic Objectives
In this topic, you will learn:
What a form is
About the types of controls in a form
How to create Excel forms

[bookmark: _Toc420237612][bookmark: _Toc51249697]What is a Form?
In the context of Excel, a form is an interface element of a workbook that is used to collect data or execute an action. Typically, forms are used in complex workbooks that would otherwise be too complicated to update manually. They can also be used to improve the form’s usability. Controls in relation to forms include objects that allow users to enter or edit data, as well as perform an action or select data. 

[bookmark: _Toc420237613][bookmark: _Toc51249698]Types of Controls
There are a variety of different controls that you can add to an Excel form. The Button control allows users to initiate an action by clicking on it: 

[image: ]

The Combo Box control allows users to either type an entry or select an option from a list that is displayed when the drop-down arrow is clicked: 

[image: ]

The Check Box control allows users to check or clear the box by clicking on it:

[image: ]

You can also create Option buttons (also known as radio buttons), which offer the user one choice out of a group.

The Spin button allows users to choose a value using the up or down arrow buttons, or to type a value into the associated field: 

[image: ]

The List Box control allows users to choose one option from a list:

[image: ]

The Group box is used to group related controls (such as check boxes or radio buttons) into a single group: 

[image: ]

The Label control will display text that is used to label components of the form, such as buttons: 

[image: ]

Finally, the Scroll Bar control allows users to scroll through a range of values: 

[image: ]

[bookmark: _Toc420237614]

[bookmark: _Toc51249699]Create Excel Forms
Insert a Form Control into an Excel Worksheet
To begin constructing a form for data entry, you first need to insert form controls. To do this, you must first add the Developer tab to the ribbon. With the Developer tab enabled, click Developer → Insert → [control]: 

[image: C:\Users\Kimberly\AppData\Local\Temp\SNAGHTML43cc9a48.PNG]

Then, click anywhere on the current worksheet to place it there using the default dimensions: 

[image: ][image: ]

Instructor Tip: Depending on the control that you select, a dialog may be displayed that asks you to associate the control with a macro.
Alternatively, you can click and drag on the worksheet and then release your mouse button to choose a custom dimension for the new control: 

[image: ]

Change the Properties of a Control 
Once a control has been added to a worksheet, you can change its properties. These properties are used to customize how the control appears and how parts of it function. 

To begin, right-click on the control in question and click Format Control: 

[image: ]



This action will display the Format Control dialog box: 

[image: ]

This dialog box includes a variety of different tabs that control everything from the color and size of the control to its alternative text and behavior. The options that you see here will depend on the type of control that you are modifying. (In this example, we also see font controls since we are modifying a button.)

Change the Properties of a Worksheet that Contains a Form
In order to change the properties of a worksheet that contains a form, first ensure that a blank cell is selected on the worksheet. Next, click Developer → Properties: 

[image: ]

The Properties pane will now be displayed. This pane will list a wide variety of different settings that can be applied to the current worksheet: 

[image: ]


[bookmark: _Toc420237615][bookmark: _Toc51249700]Activity 7-2
Creating Excel Forms

You would like to insert a button that will link up with an existing macro so that when the button is clicked, it will delete the currently selected range of cells. 

	50. 
	To begin, open Activity 7-2 from your Exercise Files folder: 

[image: ]

(If prompted, enable macros.)

	
	

	
	Ensure that the Developer tab is enabled. Then, click Developer → Insert → Button: 

[image: C:\Users\Kimberly\AppData\Local\Temp\SNAGHTML43d27ed4.PNG]

	
	

	
	Click anywhere on the worksheet to place your button there using its default dimensions. This action will display the Assign Macro dialog box: 

[image: ]

	
	

	
	Click to select the Delete macro and then click OK: 

[image: ]

	
	

	
	The button will now appear in the location where you clicked and will now be linked to the Delete macro: 

[image: ]

	 
	

	
	Right-click on the new button and click Format Control: 

[image: ]

	 
	

	
	The Format Control dialog box will now be displayed. Click the Bold font style and then click the OK button: 

[image: ]

	 
	

	
	The Bold text effect will now be applied to the text in the button. Double-click on the button to edit the text. Remove the default text and replace it with “DELETE:”

[image: ]

	 
	

	
	Test out this new button by selecting cell E2. Click the Delete button: 

[image: ]

	 
	

	
	The contents of the selected cell will now have been deleted from the worksheet and the existing data will be moved up:

[image: ]

	
	

	
	Save your work as Activity 7-2 Complete using the Excel Macro-Enabled Workbook file type. Close Microsoft Excel.



[bookmark: _Toc51249701]Summary
During this lesson you learned about XML, its components, and how they work with Microsoft Excel. You should now be comfortable importing and exporting basic XML data files and completing basic tasks using the XML Source task pane. You should also be comfortable creating a basic form in Excel.





[bookmark: _Toc51249702]Course Summary
Congratulations on completing the third part of Microsoft Excel training. During this course, you learned how to:
Automate worksheet functionality
Audit worksheets
Analyze and present data
Work with multiple workbooks
Export Excel data
Import and export XML data

You should now feel comfortable using macros and conditional formatting to automate worksheet functionality. You now know how to audit worksheets using the Trace Cells feature and data list outlines, as well as by troubleshooting invalid data. Additionally, you should feel comfortable analyzing data by creating Sparklines, scenarios, and more. You can now work with multiple workbooks, as well as export Excel data into a variety of different formats. 


[bookmark: _Toc51249703]Appendices
[bookmark: _Toc409684437][bookmark: _Toc51249704][bookmark: _Toc404332856][bookmark: _Toc408389116]Keyboard Shortcut Quick Reference Sheet

	File Management
	Open a new workbook
	Ctrl + N

	
	Save a file
	Ctrl + S

	
	Open a file
	Ctrl + O

	
	Print worksheet
	Ctrl + P

	
	Close Microsoft Excel
	Alt + F4

	Worksheet Management
	Switch between worksheet tabs (left to right)
	Ctrl + Page Up

	
	Switch between worksheet tabs (right to left)
	Ctrl + Page Down

	
	Insert cells
	Ctrl + Shift + +

	
	Delete cells
	Ctrl + -

	
	Hide the selected rows
	Ctrl + 9

	
	Hide the selected columns
	Ctrl + 0

	
	Select all items in current worksheet
	Ctrl + A

	
	Toggle between displaying values/formulas
	Ctrl + `

	Open Dialogs
	Open Find and Replace dialog
	Ctrl + F

	
	Open Go To dialog
	Ctrl + G

	
	Open Format Cells dialog to last used tab
	Ctrl + 1

	
	Open Data Validation dialog
	Alt + D + L

	
	Open Excel Options dialog box
	Alt + F + T




	Text Formatting and Editing Tools
	Copy text
	Ctrl + C

	
	Cut text
	Ctrl + X

	
	Paste text
	Ctrl + V

	
	Undo last action
	Ctrl + Z

	
	Redo last action
	Ctrl + Y

	
	Apply border to selected cells
	Ctrl + Shift + &

	
	Remove border from selected cells
	Ctrl + Shift + _

	
	Apply italic formatting
	Ctrl + I

	
	Apply bold formatting
	Ctrl + B

	
	Apply underlining
	Ctrl + U

	
	Check spelling 
	F7

	Auditing Tools
	View precedent cells
	Alt + M + P

	
	View dependent cells
	Alt + M + D

	
	Remove arrows
	Alt + M + A + A

	
	Evaluate formula
	Alt + M + V

	
	Recalculate current sheet
	Shift + F9

	
	Recalculate entire workbook
	F9

	Macros
	Open the Macro dialog
	Alt + F8

	
	Open the Visual Basic Editor
	Alt + F11

	
	Close the Visual Basic Editor
	Alt + F4

	
	Run a Visual Basic program
	F5




[bookmark: _Toc51249705]Glossary

absolute reference
A type of reference that will not change even if it is moved or copied to another location. 
add-in
Small components that can be added to Excel to add features and functionality.
array
Any grouping of two or more adjacent cells.
arguments
Data used by functions to complete calculations.
AutoFill
A feature that is used to automatically fill sequential data into a range of cells.
Anova
Short for Analysis Of Variance. Used to examine if the averages of samples are different in a significant way.
cell
The intersection of a row and column on a worksheet.
charts
Visual representations of numeric data in a dataset.
conditional formatting
A formatting type that will highlight cells whose data satisfies certain criteria.
consolidation
The process of combining, condensing, and summarizing data from multiple sources into one destination.
correlation 
Indicates if data sets trend or change with each other.
delimited text
Data that is entered with one row equaling one line of text.
dependent cells
Cells that are affected by the contents of another cell.
exporting
The process of sending data from one application to another.
external reference
A link to the contents of one or more cells within the worksheet of another workbook.
filtering
Removing data from view based upon set criteria.
form 
An interface element of a workbook that is used to collect data or execute an action.
Format Painter
A tool that is used to copy formatting from one selection of text to another.
formula 
A mathematical relationship expressed through symbols.
Formula Bar
A part of the Excel interface that displays the cell name, as well as values and formulas in the selected cell.
function
A preconfigured formula that is used for a specific purpose.
HTML
A programming language that describes how to display data.
importing
The process of opening data in one application that was saved in another application.
logical operators
A type of operator that is used to compare values and determine if those values meet specified criteria.
macros
Small programs that are created to complete a specific task or set of tasks.
outline
A feature in Excel that allows you to organize datasets in a worksheet into hierarchical groups.
precedent cells
Cells within a worksheet that provide data for a formula.
range names
Meaningful names that can be added to cell ranges so that they can be easily referred to and understood later.
relative reference
A cell reference that will change relative to its positioning in a worksheet.
scenario
A set of cell values that are saved and substituted into your worksheet at your convenience.
Sparklines
Small graphs contained within a single cell that are used to summarize data and display trends.


table
A dataset that is comprised of rows and columns, but is treated as one object (unlike regular data ranges).
tracer arrows
Colored arrows used to indicate the direction of the data flow to and from cells and formulas.
workspace
Saved set of Excel files.
XML
A commonly used programming language that is frequently used to describe data. Stands for Extensible Markup Language.

[bookmark: _Toc404332859][bookmark: _Toc408389119][bookmark: _Toc51249706]
Index
	
A
Add-Ins
Managing	130
What are?	127
Analysis ToolPak	127
Installing	150
What is?	145
C
Conditional Formatting
Applying	46, 55
Clearing	54
Creating custom rule	52, 57
Managing rules	50
Overview of available formats	46
What is?	45
Consolidation
Adding references	164
Available functions	160
Launching tool	158, 163
Modifying function	166
Overview of Consolidate dialog box	159
Setting options	160
What is?	158
CSV	176, 177, 178, 179, 181
D
Data Analysis Tools
Anova tool	146
Descriptive Statistics tool	151
Viewing list of	146, 151
Data Validation
Checking for invalid data	86
Creating rule	62, 66
Example of	72
Setting error alert	64, 70
Setting input message	64, 69
What is?	62
Document Inspector
Launching	18
Removing items with	20
Setting options	19
What is?	17
E
Error Checking
Running tool	84, 88
Tracing errors	84, 88
Types of Excel formula errors	85
What is?	83
Evaluate Formula Command
Running tool	92, 96
Stepping through formula with	92, 97
Excel Options Dialog Box
Add-Ins category	129, 149
Customize Ribbon category	35
Opening	35, 128
Trust Center category	35
Exporting Data
As XML	241, 246
Process of	175
Supported file types	175
With Change File Type command	179
External References
Creating	171
Syntax	168
Updating values	172
What are?	168
F
File Properties
Dialog overview	13
Modifying	14, 24
Viewing	12, 22
Form
Adding control to	250, 254
Assigning macro to control	255
Changing worksheet properties	252
Control types	247
Modifying control	251, 256
Using controls	258
What is?	247
G
Goal Seek
Opening dialog	133, 136
Setting parameters	133, 137
Viewing solution	134, 138
What is?	131
H
HTML	175, 230, 231, 263
I
Importing Data
As XML	237, 239, 243
Process of	182
With Get External Data group	183
With Open command	183
With wizard	183, 184
M
Macro
Assigning to form control	255
Editing with Visual Basic for Applications	32, 43
Naming conventions	31
Recording	30, 38
Running	42
Security settings	35
Storage location	31
Supported file formats	31
What is?	29
Metadata	12
Microsoft Office Word	130
O
Outline
Adding subtotals to	100
Applying to group	100, 103
Group on Data tab	100
Hiding and showing data within	99, 103, 105
Removing from group	100
What is?	99
P
PDF	176
PivotTable
Adding/removing fields	193
What is?	188
S
Scenarios
Creating	115, 118, 121
Scenario Manager	115, 117
Showing	125
What are?	114
Solver	127
Adding constraints	140
Generating reports	143
Launching	134, 139
Parameters dialog box	135, 139
Setting changing cells	140
Setting objective	139
What is?	134
Sparklines
Creating	111, 112
Design contextual tab	108
Types of	108
What are?	107
T
Trace Cells
And error checking	84, 88
Arrow types	77
Clearing arrows	80
Feature set	76
Tracing dependent cells	78, 81
Tracing precedent cells	77, 80
Track Changes	159
Trust Center	35, 36
V
Visual Basic Editor	See Visual Basic for Applications
Visual Basic for Applications	29, 32
Editing macro with	43
Interface overview	32
Trusting access to the project object model	37
What is?	32
W
Watch Window
Adding watch to	92, 94
Closing	92, 96
Enabling	91, 94
Modifying values	92
Using	95
What-If Analysis	117
Goal Seek	131
Scenarios	114
Solver	134
Types of	115
X
XML	175, 229, 235, 238, 259, 264
Attributes	232
Exporting file	241, 246
File components	232
Group on Developer tab	236
Importing file	237, 239, 243
Maps	233, 235
Root element	232
Sample file	231
Schema files	233
Source task pane	233, 239, 241
Tags	231
vs. HTML	230
What is?	230
XPS	176

































Ballarat Computer Training
[image: ][image: ][image: ]







www.unlocksuccess.com.au/ballarat-computer-training.html


[image: ]


© 2005-2016 Velsoft Training Materials, Inc. All rights reserved. Used with permission by Unlock Success Pty Ltd.
image3.jpeg
unlock
SUCCEeSS




image88.png
Data Validation

Settings  Input Message  Error Alert

Validation crteria
Allow:
Whole number
Data:
between <
Minimum:
1
Nagmum:
10

‘Apply these changes to all other cells with the same settings

oK Cancel

Clear Al





image89.png
Data Validation

Settings | Input Message  Error Alert

Validation crteria'




image90.png
Data Validation

Settings  Input Message  Error Alert

Show input message when cellis selected

When cellis selected, show this input message:
Ttie:

Review Rating|

Input message:

Clear Al oK

Cancel





image91.png
Data Validation

Settings  Input Message  Error Alert

Show input message when cellis selected

When cellis selected, show this input message:
Ttle:
Review Rating
Input message:

Please enter a number between 1 and 10/

Clear Al oK

Cancel





image92.png
Data Validation

Settings  Input Message  Error Alert

‘Show input message when cell selected




image93.png
Data Validation [

Seftings  Input Message  Error Alert

Show error alert after invalid data is entered

When user enters invalid data, show this error alert:
style: Ttie:

stop | [Employes Review Rating]

Error message:

Clear Al oK Cancel





image94.png
Data Validation [

Seftings  Input Message  Error Alert

Show error alert after invalid data is entered

When user enters invalid data, show this error alert:
style: Ttle:
stop | [Employee Review Rating

Error message:

Only numbers between 1and 10
will be accepted]

Clear Al oK Cancel





image95.png
Data Validation [

Seftings  Input Message  Error Alert

Show error alert after invalid data is entered

When user enters invalid data, show this error alert:
style: Ttle:
stop | [Employee Review Rating
Error message:

Only numbers between 1 and 10
will be accepted.

Clear Al oK i Cancel





image96.png
A B c

Employee # Review Rating (1-10)

1

2| 58697

3| asers

4| seasa o 1

ol 46775 Review Rating

6 334 Plesse enter a

7| oase7 number between 1
and 10

8| 33983

9| 30701

10| oams




image97.png
2718

—
Please enter a
number between 1
and 10.





image4.emf

image98.png
2718

—
Please enter a
number between 1
and 10.





image99.png
Employee Review Rating x

Retry Cancel Help





image100.png
Employee Review Rating

X

Retry

Cancel d

Help





image101.png
Insert  Pagelayout  Formulas  Data

Bre e T des

Clipboard r. Font Alignment

oMt -

e N e we

10]





image102.png
=SUM(AL:A10)

£

D1





image103.png
s Book! - Excel

I Fomuias View  © Tell me what you want to do
. DefineName ~ | [BoTiacepfecedents] [ Show Formulas
A 3 BB Q@ & o e
Insert  AutoSum Recently Financial Logical Text Date& Lookup& Math&  More Name. N 3 9

Function v Usedv - - = Time~ Reference~ Trig~ Functions~ Manager 5 Create from Selection I3 Remove Arrows ~ (&) Evaluate Formula

Function Library Defined Names Formula Auditing




image104.png
s Book! - Excel

I Fomuias View  © Tell me what you want to do
. @DefineName ~ | BoTrace Precedents 5 Show Formulas
kX [ o] =) 2 ¢
B Tiace Dependents] Yo Error Checking -
Insert AutoSum Recently Financial Logical Text Date& Lookup & Math@& More | Name

Functon - Used> - - = Time- Referencer Tig~ Functions~ Manager [l Cratefiom Selecion I RemoWiArows - () Evluste Formua

Function Library Defined Names Formula Auditing




image105.png
Activity 2-1 - Excel = o

T o e e e = e @ T e John Smith £ Share
ﬁg;z' T BERErY WinpTex General - £ [ Normal Bad Good | i é::'j‘“m Ay O
P pamer BT U e DA Wegaco + | § <% o 5 o fomas el (oo | [T | e oeee s OU sons s
Cipboara 5 Font 5 Aignment 5 mmber  w syes cets cating ~
AL M fe | Weekly Sales & Bonus Payout v
A 8 | c | o 3 3 s W ' | 3 L M N o 3 a R s
1 Week\|y Sales & Bonus Payout Weekly Bonus Amount
2] B 500.00
3|
4| Week  First Name Last Name D WeeklySales  Weekly Goal  Bonus.
5| 1 Jackie ‘Williamson Jackie_Williamson $  16,785.14 $  15,000.00 $500.00
6| 1 lucs Bressan Lucas_Bressan $ 1468750 $ 1500000 $ -
7| 1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
8| 1 emy Harrison Jerry_Harrison $  21,68347 $  15000.00 $500.00
9| 1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $500.00
10| 1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
1 lsa McCain Lisa_McCain $ 568900 $ 1500000 $ -
12| 1 Steven Stone Steven_Stone $ 1234687 $ 1500000 $ -
13| 1 Devon Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
4] 1 George Jackson George Jackson  $  9,87445 $ 1500000 $ -
15|
16|
il
18
19
20
21
2|
2|
24|
2|
26|
27|
2|
2
30|
31| B
2 -
Sheetl | Sheet2 | Sheets | & E| D)
Ready. iz2) 100%





image106.png
A B c 2} E F S
Weekly Sales & Bonus Payout
Last Name D WeeklySales  Weekly Goal _ Bonus.
‘Williamson Jackie_Williamson $ 1678514 $ 1500000 [ $5p.00 |
Bressan Lucas Bressan S 1468750 S 1500000 S -
Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
Harrison Jerry_Harrison $  21,68347 $  15000.00 $500.00
Thompson Leah_Thompson  $ 2547845 $  15,000.00 $500.00
Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
McCain Lisa_McCain S 568900 $ 1500000 5 -
Stone. Steven_Stone. $ 1234687 $ 1500000 $ -
Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
Jackson George Jackson  $  9,87445 $ 1500000 $ -





image107.png
s Activity 2-1 - Excel

el Formuias View  Q Tell mewhat you want t
@ Define Name - o Trace Precsdents | [ Show Formulas
ko X ] = @ =] =
. E ﬂ E’ ﬂigTra(eDepJﬂ\\Jent: i Error Checking ~
Insert  AutoSum Recently Financial Logical Text Date& Lookup®& Math& More  Name

Function v Usedv - - = Time~ Reference~ Trig~ Functions~ Manager 5 Create from Selection I3 Remove Arrows ~ (&) Evaluate Formula

Function Library Defined Names Formula Auditing




image108.png
A B c 2} E F S H !
Weekly Sales & Bonus Payout Weekly Bonus Amount
B 500,00
Week First Name Last Name D Weeklysales  Weekly Goal __ Bont
1 Jackie ‘Williamson Jackie_Williamson  $ e—36;785-14—$-+—15,000:00-[ $300.00 |
1 Luas Bressan Lucas Bressan  $ 1468750 S 1500000 S -
1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
1 ey Harrison Jerry_Harrison $  21,68347 $  15000.00 $500.00
1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $500.00
1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
1 usa McCain Lisa_McCain S 568900 $ 1500000 5 -
1 Steven Stone. Steven_Stone. $ 1234687 $ 1500000 $ -
1 Devon Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
1 George Jackson George Jackson  $  9,87445 $ 1500000 $ -





image109.png
s Activity 2-1 - Excel

I Fomuias View  © Tell me what you want
. @DefineName ~ | BoTrace Precedents 5 Show Formulas
kX [ o] =) # ¢
< Trace Dependents 8 Error Checking -
Insert AutoSum Recently Financial Logical Text Date& Lookup & Math@& More | Name

Function v Usedv - - = Time~ Reference~ Trig~ Functions~ Manager 5 Create from Selection B Remove Afrows - | () Evaluate Formula

T Defined Names [ p—————




image110.png
A B c 2} E F G !
Weekly Sales & Bonus Payout Weekly Bonus Amount
Week First Name Last Name D WeeklySales  Weekly Goal  Bonus.
1 Jackie ‘Williamson Jackie_Williamson $  16,785.14 $  15,000.00 $500.00
1 Lucas Bressan Lucas_Bressan $ 1468750 $ 1500000 $ -
1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
1 ey Harrison Jerry_Harrison $  21,68347 $  15000.00 $500.00
1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $500.00
1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
1 Usa McCain Lisa_McCain $ 568900 $ 1500000 $ -
1 Steven Stone. Steven_Stone. $ 1234687 $ 1500000 $ -
1 Devon Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
1 George Jackson George Jackson  $  9,87445 $ 1500000 $ -




image111.png
s Activity 2-1 - Excel

I Fomuias View  © Tell me what you want
. @DefineName ~ | BoTrace Precedents 5 Show Formulas
kX [ o] =) 2 ¢
B Tiace Dependents] Yo Ervor Checking -
Insert AutoSum Recently Financial Logical Text Date& Lookup & Math@& More | Name

Functon - Used> - - = Time- Referencer Tig~ Functions~ Manager [l Cratefiom Selecion I Remad Arows - () Evluste Formula

Function Library Defined Names Formula Auditing




image112.png
A B c D

Weekly Sales & Bonus Payout

Last Name D Weeklysales  Weekly Goal
‘Williamson Jackie_Williamson $  16,785.14 $  15,000.00
Bressan Lucas_Bressan $ 1468750 $ 1500000
Prestwick Stanley_Prestwick $  13478.96 $ 1500000
Harrison Jerry_Harrison $  21,68947 $  15,000.00
Thompson Leah_Thompson  $ 2547845 $  15,000.00
Fletcher Robyn_Fletcher  $ 7,600.00 $  15,000.00
McCain Lisa_McCain $ 568900 $ 1500000
Stone. Steven_Stone. $  12,346.87 $  15,000.00
Lawrence Devon_Lawrence ' $  11,687.00 §  15,000.00
Jackson George Jackson 9,87445 $  15,000.00

‘Weekly Bonus Amount





image113.png
s Book! - Excel

Home Inset  Pagelayout SRRl Deta  Review  View @ Tellmewhatyouwanttodo
) & Define Name - Lo Trace Precedents B Show Formulas
A 3 A B e @ & oo MEHEEREE_ &
Insert  AutoSum Recently Financial Logical Text Date& Lookup®& Math& More  Name = pendents 9Ty w
Function ~ Usedr - - = Time~ Reference~ Trig~ Functions~ Manager L5 Createfrom Selection 1% Remove Arrows ~ ¥4 Error Checking, ow

Fundtion Library Defined Names For|





image114.png
D2

o e w N

Item1
Item 2
Item3
Itema
Items

- £ | B2 =
8 c ) 3 3 G
Units Sold  Price Sales Cost Per Item Overhead Profit
200 [Oho[snavez| e= 25 =—tosnAME?
36 65 234 3 0 126
25 199.99 499975 120 100 1899.75
780 299 23322 18 60 8682
23 600 13800 300 120 670




image115.png
Error Checking

Errorin cell D2
2

Invalid Name Error

The formula contains unrecognized tex.

Opions.

Hielp on this error

‘Show Calculation Steps.
Ignore Error

Editin Formula Bar

Brevious. Next





image116.png
Insert  Pagelayout  Formulas  Data  Review

Q Tell me what you want to

Activity 2-2 - xcel

= o

JohnSmith ), Share

ﬁg;z' T BERErY WinpTex General - £ [ Normal Bad Good | i é::'j‘“m Ay O
P pamer BT U e DA Wegaco + | § <% o 5 o fomas el (oo | [T | e oeee s OU sons s
Cipboara 5 Font 5 Aignment 5 mmber  w styes cets ating
AL M fe | Weekly Sales & Bonus Payout
A 8 | c | o 3 3 s W ' | 3 M o 3 a R s
1 Week\|y Sales & Bonus Payout Weekly Bonus Amount
P I—T
3|
4| Week  First Name Last Name D WeeklySales  Weekly Goal  Bonus.
5| 1 Jackie ‘williamson Jackie_Williamson | $  16,785.14 | §  15,000.00 /#NAME?
6| 1 lucs Bressan Lucas_Bressan $ 1468750 $ 1500000 $ -
7| 1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
8| 1 emy Harrison Jerry_Harrison $  21,68347 $ 1500000 $523.78
9| 1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $523.78
10| 1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
1 lsa McCain Lisa_McCain $ 568900 $ 1500000 $ -
12| 1 Steven Stone Steven_Stone $ 1234687 $ 1500000 $ -
13| 1 Devon Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
4] 1 George Jackson George Jackson  $  9,87445 $ 1500000 $ -
15|
16|
il
18
19
20
21
2|
2|
24|
2|
26|
27|
2|
2
30|
31
2
Sheetl | Sheet2 | Sheets | & [ Dl
] 100

Ready





image117.png
(= = Activity 2-2 - Excel

Fle  Home et Pagelsyout Formulss View  © Tell me what you want to do

p D@ DD D} D FDEISWQUEHE: Feglcmemm

N v L,
Do gk 5 BB E

From From FromOther  Bisting  New Refresh z| Sott  Fiter Tetto Flash Remove | Data  Consolidate
Access Web Tet Sources~  Connections | Query~ L Recent Sources - e VoAdvanced | Columns Fil  Duplicates Validation

Get External Data Get & Transform Connections Sort & Fier

DS





image118.png
A B c 2} E F G !
Weekﬂy Sales & Bonus Payout Weekly Bonus Amount
Last Name D WeeklySales  Weekly Goal  Bonus.
‘williamson Jackie_Williamson | $  16,785.14 | §  15,000.00 /#NAME?
Bressan Lucas Bressan  $ 1468750 S 1500000 $ -
Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
Harrison Jerry_Harrison $  21,68347 $ 1500000 $523.78
Thompson Leah_Thompson  $ 2547845 $  15,000.00 $523.78
Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
McCain Lisa_McCain S 568900 $ 1500000 5 -
Stone. Steven_Stone. $ 1234687 $ 1500000 $ -
Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
Jackson George Jackson  $  9,87445 $ 1500000 $ -





image119.png
A B c D

Weekly Sales & Bonus Payout

Last Name D WeeklySales  Weekly Goal  Bonus.
‘williamson Jackie_Williamson | $  16,785.14 | §  15,000.00 /#NAME?
Bressan Lucas Bressan  $ 1468750 S 1500000 $ -
Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
Harrison Jerry_Harrison $  21,68347 $ 1500000 $523.00
Thompson Leah_Thompson  $ 2547845 $  15,000.00 $523.00
Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
McCain Lisa_McCain S 568900 $ 1500000 5 -
Stone. Steven_Stone. $ 1234687 $ 1500000 $ -
Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
Jackson George Jackson  $  9,87445 $ 1500000 $ -

‘Weekly Bonus Amount





image120.png
(= = Activity 2-2 - Excel

Fle  Home nset  Pageluyou [[EEEDERl Dt Review  View  Q Tellmewhstyouwsnttodo
) ) Define Name - %o Trace Precedents 7 Show Formulas
kX ] ] @ =] Z 3
<2 Trace Dependents ¥4 Error Checking =
Insert AutoSum Recently Finsncial Logical Text Date& Lookup& Math& More  Name
Function ~ Usedv - - = Time~ Reference~ Trig~ Functions~ Manager L5 Create from Selection I3 Remove Arrows - ¥4 Error Checking.

Fundtion Library Defined Names Forl 4





image121.png
Error Checking

Errorin cell G5
FIES> 5., 0)

Invalid Name Error

The formula contains unrecognized tex.

Opions.

Hielp on this error

‘Show Calculation Steps.
Ignore Error

Editin Formula Bar

Brevious. Next





image122.png
Error Checking

Errorin cell G5
FIES> 5., 0)

Invalid Name Error

The formula contains unrecognized tex.

Opions.

Hielp on this error

‘Show Calculation Steps.

Ignore Error

Editin FormulaBar |

Brevious. Next





image123.png
A B c 2} E F S H !
Weekly Sales & Bonus Payout Weekly Bonus Amount
523
Week First Name Last Name D . _WeeklySales _Weekly Goal _Bonus
1 Jackie ‘Williamson Jackie_Williamson | $  16,785.14 | §
1 Luas Bressan Lucas Bressan | 1468750 §
1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $
1 ey Harrison Jerry_Harrison $ 2168947 $ X X
1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $523.00 Error Checking ?
1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ - ervor i cel G5
1 usa McCain Lisa_McCain S 568900 $ 1500000 5 - e Resume
1 Steven Stone Steven_Stone. $ 1234687 $ 1500000 $ - -
1 Devon Lawrence Devon lawrence | $ 1168700 $ 1500000 $ - Il Name Eror
1 George Jackson George Jackson 9,87445 $ 1500000 $ - U N s e





image124.png
ES s

Fle  Home Inset  Pageloyout (Y

Y BB = @

Insert  AutoSum Recently Financial Logical Text Date Lookup& Math& More
Funcon - Usedv - ~ -~ Time- Reference~ Trig~ Functions~

Fundtion Library

PMT - X v & | =FEs





image125.png
Error Checking

Errorin cell G5
FIES> 5., 0)

Invalid Name Error

The formula contains unrecognized tex.

Resume.





image126.png
Microsoft Excel

X

A meenor ek compiete forne e et

=





image127.png
oo s w

Item1
Item 2
Item3
Itema.
Items

B
Units Sold
400
356
23
780
22

c D
price  sales
$ 499 S 1,996.00
$ 650 $ 2,314.00
$199.99 $ 4,999.75
$ 299 $ 233220
$600.00  $13,800.00

CostPeritem Overhead

PADATARS

E

250
3.00
120.00
1.80
300.00

F

$ 2000
$ 3000
$ 100.00
$ 60.00
$ 120.00

G
Profit

$ 976.00

$1,216.00

$1,899.75

$ 868.20

$6,780.00




image128.png
ES B Book! - Excel

Fle  Home et Pagelwout [JEEE View  © Tell me what you want to do

D> [ B @ S Doenetiame - B Tace Precedents BshowFormules | =]

2% Trace Dependents ¥4 Error Checking ~
Insert  AutoSum Recently Financial Logical Text Datef Lookup& Math& More  Name Watch
Function < Usedv - - - Time~ Reference~ Trig~ Functions~ Manager L5 Createfrom Selection I3 Remove Arrows ~ (&) Evaluate Formula Wm&aw

Function Library Defined Names Formula Auditing





image129.png
Watch Window

25 Add Watch..

Book ‘Sheet

Name

cell

Value

Formula





image130.png
Add Watch [

Select the cell that you would like to watch the value of:

—sheetiscsd





image131.png
Watch Window
23 Add Watch...
Book  Shest  Name | Cel  Value Formula

Bookl.... Sheett =3 597600 =D2B2E2-F2)





image132.png
ES B Book! - Excel

T Formuiss View  © Tell me what you want to do
. @DefineName ~ | BoTrace Precedents 5 Show Formulas
kX [ o] =) # ¢
< Trace Dependents Y9 Error Checking -
Insert AutoSum Recently Financial Logical Text Date& Lookup & Math@& More | Name

Funcion - Used~ < = = Time- Reference~ Tig~ Functions~ Manager & Crestefrom Selection | I Remove Arows ~ () Evallse Formula

T e e




image133.png
Evaluate Formula ?

Reference: Exaluation:
Sheet1!$AS1 1-z@anz

To show the result of the underlined expression, dick Evaluate. The most recent result
appears ialicized.

e Close





image134.png
Insert  Pagelayout  Formulas  Data  Review

Q Tell me what you want to

= o

JohnSmith ), Share

ﬁg;z' T BERErY WinpTex General - £ [ Normal Bad Good | i é::'j‘“m Ay O
P pamer BT U e DA Wegaco + | § <% o 5 o fomas el (oo | [T | e oeee s OU sons s
Cipboara 5 Font 5 Aignment 5 mmber  w syes cets cating
AL M fe | Weekly Sales & Bonus Payout
A 8 | c | o 3 3 s W ' | 3 M o 3 a R s
1 Week\|y Sales & Bonus Payout Weekly Bonus Amount
P T
3|
4| Week  First Name Last Name D WeeklySales  Weekly Goal  Bonus.
5| 1 Jackie ‘Williamson Jackie_Williamson $  16,785.14 $  15,000.00 $525.00
6| 1 lucs Bressan Lucas_Bressan $ 1468750 $ 1500000 $ -
7| 1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
8| 1 emy Harrison Jerry_Harrison $  21,68347 $ 1500000 $525.00
9| 1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $525.00
10| 1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
1 lsa McCain Lisa_McCain $ 568900 $ 1500000 $ -
12| 1 Steven Stone Steven_Stone $ 1234687 $ 1500000 $ -
13| 1 Devon Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
4] 1 George Jackson George Jackson  $  9,87445 $ 1500000 $ -
15|
16|
il
18
19
20
21
2|
2|
24|
2|
26|
27|
2|
2
30|
31
2
Sheetl | Sheet2 | Sheets | & [ Dl
] 100

Ready





image135.png
A B c D

Weekly Sales & Bonus Payout

Last Name D WeeklySales _ Weekly Goal _ Bonus
‘williamson Jackie_Williamson | $ 16,7854 $  15000.00 | $525.00
Bressan Lucas Bressan  $  14,687.50 $ 1500000 |'$
Prestwick Stanley_Prestwick $ 1347896 $ 1500000 | $
Harrison Jery Hamison  $ 2168947 $ 1500000 | $525.00
Thompson Leah Thompson  § 2547845 $  15,000.00 | $525.00
Fletcher Robyn Fletcher  $  7,60000 $ 15,000.00 | $
Mecain Lisa_McCain $ 568900 $ 1500000 |$
Stone. Steven_Stone. $  12,346.87 $  15,000.00 | §
Lawrence Devon_Lawrence $  11,687.00 $  15,000.00 [ $
Jackson George Jackson | $ 987445 $ 1500000 | $

]

‘Weekly Bonus Amount

525




image136.png
85 o .

Fle  Home et Pagelwout [JEEE View  © Tell me what you want to do

D> [ B @ S Doenetiame - B Tace Precedents BshowFormules | =]

2% Trace Dependents 4 Error Checking ~
Insert  AutoSum Recently Financial Logical Text Date& Lookup®& Math& More  Name Watch

Function ~ Usedr - - = Time~ Reference~ Trig~ Functions~ Manager L5 Create from Selection 1% Remove Arrows ~ Window

Function Library Defined Names Formula Auditing





image137.png
Watch Window

2 Add yiatch..

Book " Sheet

Name

cell

Value

Formula





image138.png
Add Watch [

Select the cell that you would like to watch the value of:
=Sheet11sGS5:56514





image139.png
Watch Window

25 Add Watch,

Book Sheet  Name  Cell Value Formula ~

Activity... Sheet! G5 $525.00 =IF(ES>F5,12, 0)

Activity... Sheet! G6 s- =IF(E6>F6,12, 0)

Adtivity... Sheet! 67 s- IF(E7>F7,12, 0)
Sheett 23 $525.00 =IFEFBR 0

Activiy.
s





image140.png
ES

File

Home.

insert  PageLayout LR Dute

AZRERBRLOE R B =

Insert  AutoSum Recently Financial Logical Text Date Lookup& Math& More

Review  View

Q Tell me what you want to do

) Define Name

“ft Use in Formula
Name

FioTrace Precedents

=% Trace Dependents

Activity 2-3 - Bxcel

5 Show Formlas

Ertor Checking

Fungton o e e Refwencer Tig~ Functions~ | Manager (5 Create from Selecton | 12 Remove Arrows ~ () Evaluste Formula | wingows
Fundion Ubrary Defined Names Formuia Auditing
PMT e x v £ =525%1.05
A | 8 | c | o 3 3 s I i | 3
1 |Weekly Sales & Bonus Payout Weekly Bonus Amount
2| 25+1.05.
3]
4| Week  First Name Last Name D WeeklySales  Weekly Goal  Bonus.
5| 1 Jackie ‘Williamson Jackie_Williamson $  16,785.14 $ 15000.00 $525.00
6] 1 Lucas Bressan Lucas_Bressan $ 1468750 $ 1500000 $ -

e s e

— T

— T




image141.png
Watch Window \oes
2, Add Watch

Book  Sheet  Name  Cell Value Formula ~
Activity... Sheetl G5 $551.25 =IF(ES>F5,12, 0)
Activity... Sheetl G6. s- =IF(E6>F6,12, 0)
Activity... Sheetl 67 s- IF(E7>F7,12, 0)
Advity.. Sheett = $551.25 =IFEFBR 0

<





image142.png
Watch Window

“h

2 Add Watch

Book Sheet  Name  Cell Value Formula ~

Activity... Sheet! G5 $551.25 =IF(ES>FS,12, 0)

Activity... Sheet! G6 s- =IF(E6>F6,12, 0)

Adtivity... Sheet! 67 s- IF(E7>F7,12, 0)
sneett @ s

Activiy.
s

-IFESFE 0 |,





image143.png
85 o .

Fle  Home Inset Pagelayos [JENERN Do Review  View  Q Tellmewhstyouwanttodo

fx z I IE I I I Iﬂ Im IH 9 flu:fmeName - g::Tva:er(edems L@Sthmmmax ’_‘
7 Use in Formula 2% Trace Dependents Y4 Error Checking ~
Insert AutoSum Recently Financial Logical Text Date& Lookup & Math@& More | Name Watch
Function  ~  Usedw - = Time- Reference~ Trig~ Functions~ Manager £ Create from Selection 3. Remove Arrows - ((5) Evaluate Formula - Window
Fundion Ubrary Defined Names Formuia Audting
G5 - o | =IF(ES>F5,12,0)
A | 8 | c | o | 3 | F  owewm u | ' Lo |«
1 |Weekly Sales & Bonus Payout Weekly Bonus Amount
2| T
3|
4| week FirstName Last Name D Weeklysales  Weekly Goal
5| 1 Jackie ‘Williamson Jackie_Williamson $  16,785.14 $  15,000.00
6] 1 Lucas Bressan Lucas_Bressan $ 1468750 $ 1500000
7| 1 Stanley Prestwick Stanley_Prestwick $  13478.96 $ 1500000
8| 1 emy Harrison Jerry_Harrison $  21,68947 $  15,000.00
9| 1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00
10| 1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $  15,000.00
1 1 Lsa McCain Lisa_McCain $ 568900 $ 1500000
2] 1 steven Stone Steven_Stone S 12,38687 $ 1500000
3] 1 Devon Lawrence Devon_Lawrence ' $  11,687.00 §  15,000.00
14 1 George Jackson George Jackson 9,87445 $  15,000.00





image144.png
Evaluate Formula

Reference:
Sheet115685

Exaluation:

IFES> F5,2,0)

To show the result of the underlined expression, dick Evaluate. The most recent result

appears ialicized.

fuate [ Stepin.

Close





image145.png
Evaluate Formula

Reference:
Sheet115685

Evaluation:

1F(16765.14E5.2, 0

To show the result of the underlined expression, dick Evaluate. The most recent result

appears ialicized.

e

Stepin.

Close





image146.png
Evaluate Formula [

Reference: Evaluation:
Sheet115685 535125

To show the result of the underlined expression, dick Evaluate. The most recent result

appears ialicized.

Restart





image147.png
CICIEICINIE

ﬂ«

A B < D 3 F G
Unitssold  Price  sales  CostPeritem Overhead Profit

Item1 400 $ 499 S 1,99%6.00 $ 250 $ 2000 $ 976.00

Item2 356 $ 650 $ 231400 $ 3.00 $ 30.00 $1,216.00

Item3 25 $199.99 $ 4999.75 $  120.00 $100.00 $1,899.75

Itema 780 $ 299 $ 23322 $ 180 $ 60.00 $ 868.20

Item5 23 $600.00 $13,800.00 $  300.00 $120.00 $6,780.00




image148.png
Lo s w N -

Item1
Item 2
Item3
Itema.
Items

Units Sold
400
356
23
780
22

Profit
$ 976.00
$1,216.00
$1,899.75
$ 868.20
$6,780.00




image149.png
H ©- = Book! - Excel = o

Home mset Pagelayout Formulas View  © Tell me what you want to do JohnSmith £, Share
= [ show Queries 2] Connections | 4 ~XE R % B B g

kB B BIwee T E& ) 8 &

From From Fiom FromOther _ Exsting | New Refresh 2y ot iter Tetto Fash Remove Data  Consolidate Manage | Whatf Forecast | Group Ungroup Subtotal

Access Web Tex Sources Comnections Query< L RecentSources a1~ Vo Advanced  Columns Fil  Duplicates Valdation - DataModel Analysis~ Sheet | - -

Get External Data Get & Transform Connections Sort & Filter Data Tools Forecast Outline o A




image150.png
ES s

Book! - Excel

Home Insert Formulas View

Q Tell me what you want to do

S ”=e (2] Connections | 5 =

Bisting | New Refresh
Connections | Query - [(> Recent Sources -

Get & Transform

Page Layout

D FEI [ Show Queries

@l Lo

From From From From Other
Access Web Text Sources~
Get External Data

= B

Remove
Y Advanced

Connections Sort & Fier

$ B

Data  Consolidate

Columns Fill - Duplicates Validation *

DataTools

Manage
Data Model

What-If Forec;
Analysis ~ Sheet

Forecast

S o E
i
Group Ungroup Subtc

a8

Auto Outline [y




image151.png
ES B Book! - Excel

Home Inset  Pagelsyout Formulss View  © Tell me what you want to do

— Show Queries L] Connections SN 3rE e S
BEH L B B R : 25 5 B 2 |
From From Fiom From Other _ Bisting  New Refresh 2y ot iter Tetto Fash Remove Data  Consolidate Manage | Whatf Forecast | Group Ungtoup|Subtota
Access Web Tex Sources Comnections Query< L RecentSources a1~ Vo Advanced  Columns Fil  Duplicates Valdation - DataModel Anabysis~ Shest = - .+
Get Btemal Data Get Tanstorm Connections sort & Fier DataTools Forecst % Ungroup

ClearOutine [




image152.png
85 o .

Home.

@l Lo

From From From From Other
Web Tet Sources
Get External Data

Insert  Pagelayout  Formulas

D FEI [ Show Queries

From Table:
Bisting | New 8

Connections  Query - L5 Recent Sources

Get & Transform

View

”;9 [=] Connections

Refresh

3| sot

Connections

Book! - Excel

Q Tell me what you want to do

L)
B=
Filter =i
. advanced | Gotumns
o

5

Flash

Fill

=
Remewe ova Comsaldt
DuprsVldnion~

Manage
Data Model

=2 =)
2 sha

John Smith

?

w
Analysis -

at-if Forec
Sheet
Forecast

(—r
(el

Group Ungroup Subtota

Outline 5




image153.png
Activity 2-4 - Excel = o

=i Bmloprs o Bs e @ T s S Q) Sharc
ﬁ E‘E z:‘ . Calibr BERRr Y 52 Wiap Text General B ’_:) Normal Bad Good S gﬂﬂ i é:““i““‘"‘ Ay p
P S rompin | ® 1 U MegeCenter = § - % » |5 $§ | Condonal Formtuc [Newtral o] et Delte Format| . B Frds
Clipboard 5 Font 5 Aignment 5 Number 5 styles celts Editing ~
=) - £ v
A 8 | < | o | 3 F s H ] K L M N o 3 a R s i
1 [sku UnitPrice  Quantity  TotalValue Location
2] 1574 299 s 14.95 Warehouse A
3] 2358 399.99 s 1999.95 Warehouse B
4 1478 049 1587 777.63 Warehouse B
5] 2358 399.99 54 21599.45 Warehouse A
5| 147 12999 214 27817.86 Warehouse B
7] 1358 499 s 22455 Warehouse A
s | 1574 299 65 194.35 Warehouse C
o 5167 a5 s 1912.5 Warehouse A
10| 2358 399.99 89 35599.11 Warehouse C
1] 1547 134.58 5 1076.64 Warehouse A
12| 235 569.99 55 31349.45 Warehouse B
13 1567 147.59 ES 5165.65 Warehouse A
14 1459 1699 89 1512.11 Warehouse B
1) 1478 049 854 418.45 Warehouse A
16 147 12999 a7 61745.25 Warehouse A
17 a7 899 89 800.11 Warehouse A
18] 350 750 2 18750 Warehouse A
19 1547 134.58 2 269.16 Warehouse B
20| 1478 049 4876 2389.24 Warehouse B
21 2358 399.99 54 21599.45 Warehouse A
2| 147 12999 145 18848.55 Warehouse B
2] 1358 499 s 22455 Warehouse A
2] 1574 299 65 194.35 Warehouse C
2| 5167 a5 s 1912.5 Warehouse A
2| 2358 399.99 %0 35999.1 Warehouse C
27 1547 134.58 5 1076.64 Warehouse A
2 235 569.99 55 31349.45 Warehouse B
20| 1567 147.59 ES 5165.65 Warehouse A
30| 1459 1699 89 1512.11 Warehouse B |
31| 1478 049 7 428.26 Warehouse A
2| 147 12999 an 61225.29 Warehouse A
ES s 8399 89 800,11 Warehouse A -
Sheetl | Sheet2 | Sheets | Sheets | @ [ 1 Dl
Reaty 89 ] 1005





image154.png
sku

B

4 c

1574
2358
1478
2358

147
1358
1574
5167
2358

235
1567
1459
1478
147
a7l

Unit Price
299
3299.99
049
3299.99
129.99
499
299
25
3299.99
134.58
569.99
147.59
16.99
049
129.99

299

uan

28l

Blzlalal.lzlslalzlE

5
3.3

D E
TotalValue  Location

14.95 Warehouse A

1999.95 Warehouse B

777.63 Warehouse B

21599.46 Warehouse A

27817.86 Warehouse B

22455 Warehouse A

194.35 Warehouse C

1912.5 Warehouse A

35599.11 Warehouse C

1076.64 Warehouse A

31349.45 Warehouse B

5165.65 Warehouse A

1512.11 Warehouse B

418.46 Warehouse A

61745.25 Warehouse A

200.11 Warehouce A




image155.png
s Activity 2-4 - Excel

Home Inset  Pagelsyout Formulss View  © Tell me what you want to do

[\é} DD D} B Egi:::::ze ”;egtmmedmn: = BR =

From From From FromOther  Bisting  New Refresh 7| Sot ke U Textto Remove  Data  Consolidate Manage | Whatf Forec
Access Web Tet Sources~  Connections | Query~ L Recent Sources - Vo Advanced | Columns Duplicates Valcation - DataModel  Analysis - Sheet

Get External Data Get & Transform Connections Sort & Fier DataTools Forecast &5 Grouy

€rg E
(el

Group Ungroup Subtc





image156.png
sku

Unit Price
299
3299.99
049
3299.99
129.99
499
299
225
3299.99
134.58
569.99
147.59
16.99

Quantity

gl8lule

slalal.izlzlalelE

.

D 3
[Total Value  Location
14.95 Warehouse A
1999.95 Warehouse B
777.63 Warehouse B
21599.46 Warehouse A
27817.86 Warehouse B
22455 Warehouse A
194.35 Warehouse C
1912.5 Warehouse A
35599.11 Warehouse C
1076.64 Warehouse A
31349.45 Warehouse B
5165.65 Warehouse A
1512.11 Warehouse B





image157.png




image5.png
Protect Workbook

Control what types of changes people can make to this workbook.

Book! - Excel

Properties -
e
See more document
properties
I




image158.png
sku

Unit Price
299
3299.99
049
3299.99
129.99
499
299
225
3299.99
134.58
569.99
147.59
16.99

Quantity

gl8lule

B
13

lglelol.lzlalals

&

D 3
[Total Value  Location

14.95 Warehouse A

1999.95 Warehouse B

777.63 Warehouse B

21599.46 Warehouse A

27817.86 Warehouse B

22455 Warehouse A

194.35 Warehouse C

1912.5 Warehouse A

35599.11 Warehouse C

1076.64 Warehouse A

31349.45 Warehouse B

5165.65 Warehouse A

1512.11 Warehouse B





image159.png
+

D 3

sku

otal Value  Location
14.95 Warehouse A
1999.95 Warehouse B
777.63 Warehouse B
21599.46 Warehouse A
27817.86 Warehouse B
22455 Warehouse A
194.35 Warehouse C
1912.5 Warehouse A
35599.11 Warehouse C
1076.64 Warehouse A
31349.45 Warehouse B
5165.65 Warehouse A
1512.11 Warehouse B





image160.png




image161.png
sku

otal Value  Location
14.95 Warehouse A
1999.95 Warehouse B
777.63 Warehouse B
21599.46 Warehouse A
27817.86 Warehouse B
22455 Warehouse A
194.35 Warehouse C
1912.5 Warehouse A
35599.11 Warehouse C
1076.64 Warehouse A
31349.45 Warehouse B
5165.65 Warehouse A
1512.11 Warehouse B




image162.png
Store#
121
131
141

TOTAL:

B
Annual Gross
$2,027,520.00
$1,089,089.00
$1,304,109.00
$4,420,718.00





image163.png




image164.png




image165.png




image166.png




image167.png
Sparkine Tool Book! - Excel

Home Inset  Pagelayout  Formulas  Data  Review Tell me what

2 Sparkine Color -

o [ High point First Point .

Low Paint Last Point \/\/ V\/\ \/\/\ \/\/\ ‘\/\f - B Marker Color - Ungroup

Edt | Line Column Win/ - & s oo

Deta- Loss L] Negative Points (] Markers © & Clear -
Sparkline e Show Style Group




image6.png
Book! Properties

General  Summary  Statitics Contents  Custom





image168.png
= o

Table Activity 3-1 - Bxcel

I John Smith £, Share

Pagelojout  Fornuss  Data  Review  View  Design  Q Tellmewhatyouwantto

X cut . = 4| 3 Autosum ~ A,
Calibr BRI S8 Wrap Text General - Wl ~ccenta Accents ‘Accent6 gt v
i > Bl e iy P

BB Copy -
Conditional Format as | Comma commalo] | Currency || nsert Delete Fornat Sort& Find &
Table + - - - &l e Select-

Editing “

Merge&uCenter = | $ ~ % | 8

Formatting ~

Clipboard r. Font & Alignment r. Number & Styles cells

Warehouse A 1635 $ 1621
Warehouse B 1952 $ 12503
Warehouse C. 150 s 40298
Distribution:| 1

Sheetl | sheetz | sheets | @ i [ 1D





image169.png
| warehouse A|
| warehouse B
| warehouse ¢

Distribution:

o e w N o





image170.png
Table Tools Activity

PageLayout Fornulss  Data View  Desgn  Q Tell mewhatyouwanttodo

5 Al T
. Store n 12 i . | WA
PivotTable Recommended Pictures Online Shapes SmartArt Screenshot ) vy Add-ins - Bing People Recommended PivotChart 30 Line Column Win/

s P+ : Mo G | o @ e s | g K Lo
Tabies strations pns s = ==~




image171.png
Create Sparklines 70X

Choose the data that you want

Data Range: |B284

Choose where you want the sparklines to be placed

Location Range: | B3|

oy | o





image172.png




image173.png
N e W N





image174.png
Table Tools Activity

PageLayout Fornulss  Data View  Desgn  Q Tell mewhatyouwanttodo

I - T
ol | B i 50 o ,

Tables lilustrations Add-ins Charts & Tours Sparklines




image175.png
Create Sparklines 70X

Choose the data that you want

Data Range: |C2:C4

Choose where you want the sparklines to be placed

Location Range: | C3|

N





image176.png
R





image177.png
H ©- = arkdin Book! - Excel

Fle  Home et Pagelsyout Formulss View  Desgn  Q Tell mewhatyouwanttodo

= [ Show Queries [ Connections = EB $ B
BHD D B &S o
Access Web Tet Sources~ Connections Query~ O Recent Sources | - Yo Advanced | Columns Fill Duplicates Validation - DataModel Analysis® Sheet -

seek., 1%





image7.png
Book1 Properties

Generl | summary  Statistics Contents | Custom

g o

Type:  Microsoft Excel Workshest
Location: C:\Users\abowiDesktop
Sze: .02 (6,168 bytes)

MSD0S name: BOOKI~1XLS
Created Wednesday, January 27, 2016 3:03:53 PM
Wednesday, January 27, 2016 3:03:53 PM
Wednesday, January 27, 2016 3:03:53 PM

Attrbutes: | |Readonly | Hidden
Archive System





image178.png
Scenario Manager

Scenarios:

DEEE
B
No Scenarios defined. Choose Add to add scenarios.
Merge..

SITeD)
Changing cells:
Comment:

G Close





image179.png
Activity 3-2 - Excel = o

PageLayout Fornulss  Data JohnSmith ), Share

iy o Catbr K&

B2 Copy ~
Paste
" Formatpaimer (BT U Er O A

Clipboard r. Font & Alignment r. Number & Styles cells Editing “

=3 i AutoSum ~
B¢ Wrap et General - L# | Nomal Bad Good L E i éwv ‘Z\Y /O
MergetsCener | § - % » |54 45| Condonl Fornats| Neural  [Catwtion | [ETCRIIN] & e Dl Format g Sont Fndse

Formatting - Table~ - Fiter~ Select +

Al ~ | fe | 1stQuarter v

Sheetl | sheetz | sheets | @ i [ 1Dl

Ready





image180.png
(= = Activity 3-2 - Excel

Fle  Home et Pagelsyout Formulss View  © Tell me what you want to do

= [ Show Queries [ Connections | 4 = EB $ B
BHD D B &S o
Access Web Tet Sources~ Connections Query~ O Recent Sources | - Yo Advanced | Columns Fill Duplicates Validation - DataModel Analysis® Sheet -

seek. I3





image181.png
Scenario Manager x
Scenarios:
i

o Scenarios defined. Choose Add to add scenarios.

Merge...

Sl
Changing cells:
Comment:

S0 Close





image182.png
Add Scenario

Scenario name:

Baseline Data

Changing cels:
a1
Ctri=dlick cels to select non-adjacent changing cells
Comment:

Created by John Smith on 2/1/2016

Protection

Prevent changes

O Hige

oK

Cancel





image183.png
© - s

Home Inset  Pagelsyout Formulss View  © Tell me what you want

= [ show Queries [=] Connections Y WK Clear e =c] Ea E =l
ba
G & B B Ty | 08 [E 8 =8
Fom Fom FromOther  Eisting | New Refresh 70 Sot  Fiter Tetto Flash Remove Data  Consolidate Relationships
Access Web Text Sources~  Connections | Query~ L Recent Sources | - [3 Edit Links o Advanced | Columns Fil - Dupliates Valdation [
Get External Data Get & Transtorm Connedtions Sort & Fier Data Tools
E4 M fo 1st Quarter
] K | L | M | N | 0o | P
Add Scenario 7 x

Scenario name:

saseine Data
& Cot ek el T seled moradiacent ramging i

1] e

1 Created by John Smith on 2/1/2016

1]

16

” Potection

18]

1]

2

21] oK Cancel





image184.png
Add Scenario

Scenario name:
Baseline Data

Changing cells:
SC52,5C53,5CS4,SES2,SES3,SES4

Ctclick cell to select non-adjacent changing cels.
Comment:

Created by John Smith on 2/1/2016
Original Data <=

Protection

Prevent changes

O Hige





image185.png
Scenario Values. [

Enter values for each of the changing cels.

x scs2 [ 02000
z scs3 [250000
ES scs4 99000
& sEs2 [ 10000
£ sEs3 [ 10000

Add oK |\ Cancel





image186.png
Scenario Manager
Scenarios:
S Add.
Delete.
.
Merge,
Changing cels: [SC52,5CS3,5CS4,SES2,5E53,5E54
Comment: [ Created by John Smith on 2/1/2016

Original Data





image187.png
Add Scenario

Scenario name:

Projected Income and Rent

Changing cells:
QG EREBE

Ctclick cell to select non-adjacent changing cels.
Comment:

Created by John Smith on 2/1/2016
More Income, Lower Rent <=

Protection

Prevent changes

O Hige

BN

Cancel





image8.png
Book! Properties

General  Summary  Statitics Contents  Custom

Tite:

Subject

Author: | John Smith

Manager:

Company:

Category:

Keywords:

Comments:

Hyperink
base:

Template;

[ save Thumbnails for AllExcel Documents





image188.png
Scenario Values. [

Enter values for each of the changing cels.

o scs2 [125000
2z scs3 (275000
E scsa [100000
& ses2 (6000
E ses3 [o0d

Add o ][ cancel





image189.png
Scenario Manager

Scenarios:

Baseline Data Add..
cted Income and Rent

Delete

..

Merge..

Summary.
Changing cells: [SCS2,5CS3,5C54,SES2,SES3,SES4
Comment: Created by John Smith on 2/1/2016

More Income, Lower Rent

Show, Close





image190.png
ES s

Fle  Home Inset Pagelayost [ENERN Dvte  Review  Viw  Q Tellmewhtyouwantt

Fx % B EEAE R B B S5 S
Insert AuSSum Recently Financia Logical Text Date& Lookup & Math@& More | Name
Fundion |+ Usede o 1T Time: Reaence~ Tig~ Funcions- Manager ] Crestefrom Seecion
Fundion Ubrary Defined Names

) - %

A 5 c o 3 3 s H )
1
2 $40,000.00 $62,000.00
3 Store 2 250000 40000 10000 5000 25000 $40,000.00 $210,000.00
4 Store3 99000 40000 10000 5000 25000/ $40,000.00 $59,000.00
s Store 4 30000 40000 10000 5000 25000 $40,000.00 $300,000.00
6 Stores 12000 40000 10000 5000 25000 S40,000.00 $84,000.00
7 Store s 56000 40000 5000 2000 15000/ $22,000.00 $33,000.00
s Store 7 4000 40000 5000 2000 15000/ $22,000.00 $23,000.00
9 Store s 87000 40000 5000 2000 15000 $22,000.00 6500000
10 —





image191.png




image192.png
(= = Activity 3-2 - Excel

Fle  Home et Pagelsyout Formulss View  © Tell me what you want to do

= [ Show Queries (2] Connections 5 T

kB B BIwee T E&

From From Fom FomOther  xisting  New Refresh 2| sor e U Tetto Flsh Remove  Data  Consolidste Mansge  Whatdf Forecast  Group |

Access Web Text Sources~ Connections Query~ Lo RecentSources - Vo Advanced  Columns  Fil - Duplicates Vlidation - DstaModel  Analysis™ Sheet -
Get External Data Get & Tanstorm Connections Sort & Fitr Data Tools Scenario Manage:

Sek.





image193.png
Scenario Manager

Scenarios:

Baseline Data Add..
cted Income and Rent

Delete

..

Merge..

Summary.
Changing cells: [SCS2,5CS3,5C54,SES2,SES3,SES4
Comment: Created by John Smith on 2/1/2016

More Income, Lower Rent

§nm%‘ Close





image194.png
store1
Store2
Store3.
Stored.
stores.
Store 6
store7
stores

275000|
100000|

124000

10000
10000





image195.png
Scenario Manager

Scenarios:

Baseline Data Add..
cted Income and Rent

Delete

..

Merge..

Summary.
Changing cells: [SCS2,5CS3,5C54,SES2,SES3,SES4
Comment: Created by John Smith on 2/1/2016

More Income, Lower Rent

Show, Close





image196.png
Info.

Open
Save

SaveAs

Print
Share
Export
Publish

Close

Account

Options.

3

Feedback




image197.png
Excel Options 70X
General ;
View and manage Microsoft Office Add-ins.

Formules

Proofing Add-ins

Save [omes o Tt J4
| Active Applcation Add-

Languge PPl

" No Active Application Add-ins
Advanced
- Inactive Application Add-

Customize Ribben Analysis ToolPak G\ fficel6\Library\Analysis\ANALYS32.XLL

Quick Access Toolbar | Analysis ToolPak - VBA CA\.16\Librery\Analysis\ATPVBAEN XLAM
Date (XML) Ci\.icrosolft Shared\Smert Tag\MOFLDLL
Euro Currency Tools rary\EUROTOOLXLAM
Inquire CA\.fice\root\Officel6\DCF\NativeShim.dil

st Center Microsoft Actions Pane 3
Microsoft Power Map for Excel CA\. Bxcel Add-in\EXCELPLUGINSHELLDLL  COM Ad-in
Microsoft Power Pivot for Excel CA\.Add-in\PowerPivotExcelClientAddin.dil
Microsoft Power View for Excel CA\.. Add-im\AdHocReportingExcelClient.dil
Solver Add-in CA\.ffice16\Library\SOLVER\SOLVER XLAM

Document Related Add-ins
No Document Related Add-ins

Analysis ToolPak

Microsoft Corporation
No compat
C:\Program Files (+86)\Microsoft Office\root\Office16\Library\Analysis\ANALYS32XLL

Provides data analysis tools for statistical and engineering analysis

Manage: | Excel Add-ins [ s





image9.png
Book1 Properties

General  Summary  Statsts  Contents  Custom

Created:  Friday, June 5, 2015 2:17:20 PM

Modfied:  Wednesday, January 27, 2016 3:08:53 PM
Accessed:  Wednesday, January 27, 2016 3:08:53 PM
printed:

Lastsavedby:
Revision number;
Total editng tme:.





image198.png
Manage:

Excel Add-ins

COM Add-ins
Actions

XML Expansion Packs
Disabled ftems

Cancel





image199.png
Excel Addkins

s





image200.png
Add-ins

Add-ins available:

Analysis ToolPak - VBA
[ euro currency Tools
O solver Add-in

oK

Cancel

Automation.

‘Analysis ToolPak:

Provides data analysis tools for statistical and.

engineering analysis





image201.png
Add-ins [

Add-ins available:

| Analysis ToolPak oK |
] Analysis ToolPak - VBA L
Cancel
Browse.

Automation.

Solver Add-in

Tool for optimization and equation solving





image202.png
sum 2 x v f | =sas]

531.00

A 5 c
1 Budget

2 Units sold %

3 Price Per Uni 5.00

4 480.00

s a7s

5 75.00

7

2





image203.png
0 @ N o b w

A B
Budget

Units Sold %

Price Per Unit $ 5.00

Total Income $ 480.00

Materials Per Unit $ 475

Labor $ 75.00

Total Cost $ 531.00

Total Profit $ (51.00)




image204.png
ES

File

Home.

Insert

Page Layout

Formulas

View

Q Tell me what you

antto do

Book! - Excel

7= [ Show Queries & Connections ) A o BE =X B =5 @ [E
sy [3 & S From Table [} P Vorewy | 22 =0 o2 2
Fom From Fom FromOther  Bisting | New Reresh 70 S Fite Tetto Fah Remove | Data  Consoldate Relationships Manage | |\Whatdf|Forecsst | Group |
Access Web Tex Sources~ Comnections Query~ L RecentSources —ap. [Jedilnes & VoAdvanced | Columns Fill - Duplicates Validation - DataModel Analysis® Sheet =~
Get el Data GeteTanstom Connections sortier Data Toas Scenario Manager,
B8 - fe | =B4-B7 Exlie
Data Table.
A [ < > e 3 & " s L M N o 3 a —— .
1 Budget
2 Units Sold 96
3 Price Per Unit $ 5.00
4 Total Income $ 480.00
5 | Materials Per Unit $ 4.75
6 Labor $ 75.00
7 Total Cost_$ 531.00
8 Total Profi
o





image205.png
Goal Seek

set cell:
To yalue:

By changing cel:

oK





image206.png
A c 2}
Goal Seck x
Setcell: 58 =
To alue: o

“Total Cost =
By changing cell: | 5852| 3

Total Profit]

oK

Cancel





image207.png
© @ N e W N

A B 2} E
Budget
Units Sold 300
Price Per Unit $ 5.00 Goal Seck Status *
TotalIncome $ 1,500.00 Goal Seeking with Cell B3
Materials Per Unit a7 found a solution.
Labor 75.00 Targetvaiue: 0
Total Cost 5 1,500.00 Currentalue: -
Total Profit| $ oK Cancel





image10.png
Book! Properties

General Summary  Statistics  Contents  Custom

Doaument
contents: =
Sheett





image208.png
85 o .

Book! - Excel

Home Inset  Pagelsyout Formulss View  © Tell me what you want to do

= o

JohnSmith ), Share

&= [show Queries [=] Connections a0

Bl B B Bgr- 5

Fom From From FromOther  Bisting  New Refresh 7l Sot  Fiter _ Tetto

Access Web Tet Sources~  Connections | Query~ L Recent Sources - Vo Advanced | Columns
Get External Data Get & Tansform @D Sort & Filter

=

Remove  Data  Consolidate
Duplicates Validation =
Data Tools

Manage
Data Model

?

What-If Forec;
Analysis ~ Sheet

Forecast

(—r 2 Solver

- &
Group Ungroup Subtotal

Outline 5 Anahyze | A




image209.png
Solver Parameters

Set Objective: sast

= © max [¢]

O Value of:

By Changing Variable Cels:

Subject to the Constraints:

Make Unconstrained Variables Non-Negative.

SelectaSoling | GRG Nonlinear
Method:

Solving Method

Add

Change

Delete

Reset All

Loag/save

Options

Select the GRG Nonlinear engine for Solver Problems that are smooth nonlinear. Select the LP
Simplex engine for inear Solver Problems, and select the Evolutionary engine for Solver

problems that are non-smooth.

Help

Solve.

Close





image210.png
= = o

Insert  Pagelayout  Formulas  Data JohnSmith £, Share

Heu Calibr S A A = General - Normal Bad Good = A = 3
B : = B 2ty D

e o e BT boa- MegetCorter = § < % 1 5 $1 Condorl Formtas| Newral  [Coleuaton | [T 1| et Dete Formt 1y Sots Fnaa

Formatting - Table~ - Fiter~ Select +
Clipboard r. Font & Alignment r. Number & Styles cells Editing “

Al ~ | fe | 1stQuarter v

Sheetl | sheetz | sheets | @ i [ 1Dl





image211.png
Home Inset  Pagelsyout Formulss View  © Tell me what you want to do

p [‘%} [E E\o D FDDShanuene: H‘eglcmemm » ) Ea v/ EQ

From Table:
From From From FromOther  Bisting  New 8 Refresh 7| Sot ke U Textto Remove  Data  Consolidate Manage  Whatf Forec
Access Web Tet Sources~  Connections | Query~ L Recent Sources - Vo Advanced | Columns Duplicates Valcation - DataModel Anabsis® Sheet -
Get External Data Get & Transform Connections Sort & Fier DataTools Scenario

Goal Seel





image212.png
Goal Seek

Set cell:
To yalue:

By changing cel:

1o

oK





image213.png
Goal Seek [

Set cell: 1o

To yalue: 1000000

By changing celt: [

oK Cancel





image214.png
Goal Seek 2 X

Setcelt: 1o
To value: 1000000

By changing cell: |4

E cancel





image215.png
Goal Seek Status.
‘Goal Seeking with Cel 10
found a solution.

Target value: 1000000
Current value: $1,000,000.00

oK

Cancel





image216.png
Goal Seek Status. [
‘Goal Seeking with Cel 10
found a solution.

Target value: 1000000
Current value: $1,000,000.00

R [ ana





image217.png
S | s e 0

neC





image11.png
Book1 Properties 70X
General Summary _ Statisics  Contents  Custom
Neme: add
Chedied by ~
Cient Dekete
Date completed
Department
Destnation
Dipostion v
Type: Text 5
Value: Link to content
Propertes: | pame Value Type





image218.png
(= s ] o

Home Inset  Pagelajout  Formuas View  Q Tell mewhstyou want to do JohnSmith £, Share

= [FShow Queries [ Connections | » Lo =] Ea v/ N g 4 2, Solver
BLE D B B2 |k @ E B 7 q & X
Access Web Tet Sources~ Connections Query~ O Recent Sources | - Yo Advanced | Columns Fill Duplicates Validation - DataModel Analysis~ Sheet - -

Get External Data Get & Transform Connections Sort & Filter Data Tools Forecast Outline 5 Anahyze | A




image219.png
Solver Parameters

Set Objectve: od

To: @ max O min O Value of: o




image220.png
Solver Parameters

Set Objective:

To: @ max Owmin

By Changing Variable Cels:

3

O value Of: o

67,1l

Subect to the Constraints:

Change




image221.png
Solver Parameters

Set Objective: 09
T @max O min O yalue o: o
By Changing Variable Cells:
87,c1
Subjectto the Constraints:
b |
Change
Detete
Reset Al
Loag/save

[ Make Unconstrained Variables Non-Negative





image222.png
Add Constraint

Cell Reference:
B

Constraint:
v b2

Gancel

»





image223.png
‘Add Constraint X

Cell Reference: Constraint:
5] MIEE]

o] s =





image224.png
Solver Parameters

Set Objective: 559

= © max [¢] O Value of:

By Changing Variable Cels:
sB7,5C8

Subject to the Constraints:

SFS3 <= 853
553 <= SBT3

Make Unconstrained Variables Non-Negative.

SelectaSoling | GRG Nonlinear
Method:

Solving Method

Add

Change

Delete

Reset All

Loag/save

Options

Select the GRG Nonlinear engine for Solver Problems that are smooth nonlinear. Select the LP
Simplex engine for inear Solver Problems, and select the Evolutionary engine for Solver

problems that are non-smooth.

Help

TN

Close





image225.png
Solver Results X

Solver found a solution. All Constraints and optimality
conditions are satisfied Reorts.

@ KeepSolver Solution

O Bestore Originz! Values.

[ Return to Solver Parameters Dialog

loutline Reports.

= ==

Reports

Creates the type of report that you specify, and places each report on 3 separate sheet in the.
workbook.





image226.png
A B c 2} F G H
[value Model Premium Model | _ToTAL

Material processing (hours) 50 70 Processing hours Labor hours Shipping and Duties

Labor (hours) 100 250 400 200§ 858.18

Marketing (price) B 50.00

shipping (price) $ 10000 $ 110.00

Duties (price) 20.00 30.00

Units made 2.909030912 _ 3.636363634 | 6.5454545

Price $ 50000 $ 750.00

Revenue $ 145455 (S 2,727.27 | $4,181.82

CONSTRAINTS

Material processing 400

Labor hours 1200





image227.png
= o

Activity 3-3 Complete - Bxcel

oplop  Gmom B Beo @ T JohnSmith . Share
ﬁg;z' T i AN WinpTex General - £ [ Normal Bad Good | i é::'j‘“m Ay O
P pamer BT U e DA Wegaco + | § <% o 5 o fomas el (oo | [T | e oeee s OU sons s
Clipboard 5 Font 5 Aignment 5 Number styles cells Editing ~
A1 -] £ | Worksheet: [Activity 3-3.xisx]sheet2 v
112] 4fa] 8 | c | o | e | F |G| W | v | s | kK | L | M | N | O | P | @ | R | s T u v | w | X
[Wrksheet: [Activity 3-3.xisx]sheet2
Result: Solver found a solution. All Constraints and optimality conditions are sati
Solver Engine
+ 7 |solver Options
+ 1
12 | Objective Cell (Max)
13| cell Name Original Value _Final Value
14 $DS9 Revenue TOTAL $ 125000 $ 418182
15
16
17 | Variable Cells
18| cell Name Original Value _Final Value _Integer
19| $BS7 Units made Value Model 1 2.309090912 Contin
20| $C$7 Units made Premium Model 13636363634 Contin
21
2|
23 | Constraints
24| cell Name Cellvalue __Formula__Status_lack
25| $7$3 Labor (hours) Processing hours 400 SF$3<=$BS12 Binding 0
26| $653 Labor (hours) Labor hours 1200 $6$3<=$8513 Binding __0
27|
28]
2|
£
31
22|
el
24|
el
36|
27|
£l
39 |
il -
| ‘sheeti | AnswerReport1 | Sensitivity Report 1 Limits Report 1 | Sheet2 | Sheets | @ E| 1 Dl
Ready [ 100%





image12.png
Account

Feedback

Options.

nfo

Expense Budget

Desktop

B Protect Workbook
»

Control what types of changes people can make to this workbook.

Inspect Workbook
Before publishing this fil, be aware that it contains:
Document properties, author's name and absolute path
Footers
@ Inspect Document
Checkthe workbook for hidden properties
or personal information. N
[& Check Accessibilty

Check the workbook for content that people
with disabiliies might find difficult o read,

Check Compatibiity

Check for features not supported by earlier
versions of Excel

ities find difficult to read

il Browser View Options
L@ Pick what users can see when this workbook is viewed on the Web.
Browser View

Options




image228.png
s Book! - Excel

Home Inset  Pagelsyout Formulss View  © Tell me what you want to do

=

o

JohnSmith ), Share

= [ Show Queries (2] Connections 5 S =
sl [+ O BgTos [ = 5 B8
From From Fom FomOther  xisting  New Refresh 2| sor e U Tetto Flssh Remove
Access Web Text Sources~ Connections Query~ Lo RecentSources - Vo Advanced  Columns  Fil

Get External Data Get & Transform Connections Sort & Filter

$ B

Data  Consolidate

Duplicates Validation =

Data Tools

Manage
Data Model

?

What-If Forec;
Analysis ~ Sheet

Forecast

(—r
(el

Group Ungroup Subtotal

Outline 5

= Data Analysis




image229.png
Data Analysis
Analysis Tools.

‘Anova: Single Factor
‘Anova: Two-Factor With Replication
Anova: Two-Factor Without Replication
Correlation

Covariance
Desaiptive Stat
Exponential Smoothing

F-Test Two-Sample for Variances
Fourier Analysis

Histogram

ok

Cancel

Help





image230.png
Data Analysis
Analysis Tools.

‘Anova: Single Factor
‘Anova: Two-Factor With Replication

oo wetaco o Repicatin

Covariance

Desciptive Statistics
Exponential Smoothing

F-Test Two-Sample for Variances
Fourier Analysis

Histogram

ok

Cancel

Help





image231.png
Insert

Formulas

Data

Activity

= o

B2 Copy ~

Page Layout

£

MUY WY
N

Font &

15t Quarter

Merge & Center ~

Genersl
$-%

Number

Conditional Format as

Formatting ~

g

Table~

Normal Bad Good Neutal

Calculation Check Cell Explanatory .. [InpuE ]2
sttes

M | N | 0O | P | a R | s

&=

Insert Delete Format

cells

i

John Smith £, Share
> Autosum - A

bad
@Fi-

Sort& Find &
L Clear Fier~ Select~

diting -

v | w | x | v

Sheetl

Sheet2

Sheet3 |

®





image232.png
Info.

Open

Save

SaveAs

Print

Share

Export

Publish

Close

Account

Options.

Feedback




image233.png
Lenguage
Advanced

Customize Ribbon

Quick Access Toolbar

Trust Center

E‘:.malopﬁonslmwmﬁnqwiﬁ[x(el

User Interface options

Show Mini Toolbar on selection ©
Show Quick Analysis options on selection
Enable Live Preview ©

ScreenTip style: | Show feature descriptions in ScreenTips

When creating new workbooks

Use this as the default font: | Body Font

Font size: g

Default view for new sheets: | Normal View a

Include this many sheets: [ 1 :

Personalize your copy of Microsoft Office.

User name: liohn Smith
] Always use these values regardess of sign n to Office.
Office Background: | Clouds -

Office Theme: Colorful_~

Start up options

Choose the extensions you want Excel to open by default:

‘Show the Start screen when this application starts

Default Programs...

Tell me if Microsoft Excel isn't the default program for viewing and editing spreadsheets.





image234.png
Manage: [ Excel Add-ins - Go.. ﬂ





image235.png
[ euro currency Tools
O solver Add-in

‘Analysis ToolPak:

=

Cancel
Browse.

Automation.

Provides data analysis tools for statistical and.

engineering analysis





image236.png
& Activity =l =

Home Inset  Pagelajout  Formuas View  Q Tell mewhstyou want to do JohnSmith £, Share
= [ Show Queries [ Connections 4 A = Ea 7 E‘ (—r & = Data Analysis

BHD D B &S # E E e

From From Fom FomOther  xisting  New Refresh 2| sor e U Tetto Flsh Remove  Data  Consolidste Mansge  What-ff Forecast  Group Ungroup Subtotsl

Access Web Text Sources~ Connections Query~ Lo RecentSources - Vo Advanced  Columns  Fil - Duplicates Vlidation - DstaModel  Analysis~ Sheet  ~ -

Get External Data Get & Transform Connections Sort & Filter Data Tools Forecast Outline 5 Analysis ~




image237.png
Data Analysis
Analysis Tools.

‘Anova: Single Factor
‘Anova: Two-Factor With Replication
Anova: Two-Factor Without Replication
Correlation

Covariance
Desaiptive Stat
Exponential Smoothing

F-Test Two-Sample for Variances
Fourier Analysis

Histogram

ok

Cancel

Help





image13.png
Microsoft Excel X

o Before you use Document Inspector.

Make sure you save your changes because the Document Inspector might remove data that can't be restored later. Do you want to save your file now?

==





image238.png
Descriptive Statistics

nput =

Input Range: scszsess

Grouped By: © Cotumns =
O gows Help

[ Labels in First Row

Output aptions
O Qutput Range:
@© New Worksheet Ply:
O New Workbook

[ summary statistics

[] Confidence Level for Mean: | 55
[ kth Largest: 1
O kth Smallest: 1

%





image239.png
Descriptive Statistics ?

input =
Input Range: scs2:56s9
Cancel
Grouped By: @® Columns
O Rows Help
%lﬂblli in First Row

Output options.
O Qutput Range:

© New Worksheet Ply:
O New Workbook

[ summary statistics

[ Confidence Level for Mean: 95 | %
[ kth Largest: 1

O kth Smallest: 1





image240.png
Descriptive Statistics ?

nput =

Input Range: scs2:56s9

Grouped By: @® Columns Kcaner]
O Rows Help

[ abels in first row

O New Workbook

[ summary statistics

[ Confidence Level for Mean: 95 | %
[ kth Largest: 1

O kth Smallest: 1





image241.png
Descriptive Statistics ?

nput =

Input Range: scszsese

Grouped By: © Cotumns =
O gows Help

[ abels in first row

Output options.
@® Qutput Range: ci2
O New Worksheet Ply:
O New Workbook

[ summary statistics

[ Confidence Level for Mean: 95 | %
[ kth Largest: 1

O kth Smallest: 1





image242.png
Descriptive Statistics

Input
Input Range: scsz:s6s9
Grouped By: @® Columns

O Rows
[ abels in first row

Output options.
@® Qutput Range: a

Summary statistics
S s
O ktn Largest: 1
O kth Smallest: 1

ok

Cancel

Help





image243.png
Descriptive Statistics

Input
Input Range: scsz:s6s9
Grouped By: @® Columns

O Rows
[ abels in first row

Output options.
@® Qutput Range: 12
O New Worksheet Ply:
O New Workbook

fStmmary statistics

[ Confidence Level for Mean: 55
[ kth Largest: 1

O kth Smallest: 1

ok

Cancel

Help





image244.png
1
2
3
4
s
6
7
B
B

10
1
12
13
14
15
16
17
18
19
20
21
22
2
2
2
2

27

A B

C D 3

F G

H |

J K L

1stQuarter location Income Inventory Rent supplles Weges TowalExpemses profit

Store1 102000 40000 10000 5000 25000 $40,000.00 $62,000.00

store2 250000 40000 10000 5000 25000 $40,000.00 $210,000.00

store3 99000 40000 10000 5000 25000 $40,000.00 $59,000.00

storea 340000 40000 10000 5000 25000 $40,000.00 $300,000.00

stores 124000 40000 10000 5000 25000 $40,000.00 $84,000.00

Store6 56000 40000 5000 2000 15000 $22,000.00 $34,000.00

store7 45000 40000 5000 2000 15000 $22,000.00 $23,000.00

Stores £7000 40000 5000 2000 15000 $22,000.00 $65,000.00

TOTAL $266,000.00 $837,000.00

Column1 Column2 Column3 Columns Columns

Mean 137875 Mean 40000 Mean 8125 Mean 3875 Mean 21250)
Standard Error36433.62 Standard ¢ OStandardi  914.9063184 Standard Err 548.9438 Standard f 1829.813|
Median 100500 Median 40000 Median 10000 Median 5000 Median | 25000
Mode #N/A Mode 40000 Mode 10000 Mode. 5000 Mode 25000)
Standard Devi103049.8 Standard t OStandard|  2587.745848 Standard De 1552.648 Standard | 5175.492|
sample Variar 1.06€+10 Sample V2 OsampleV:  6696428.571 Sample Vari 2410714 Sample Vi 26785714
Kurtosis 1050471 Kurtosis | #DIV/0! Kurtosis -2.24 Kurtosis 224 Kurtosis | -2.24|
Skewness  1.406077 Skewness #DIV/0! ‘Skewness  -0.644061189 Skewness | -0.64406 Skewness -0.64406)
Range 295000 Range 0 Range 5000 Range 3000 Range 10000
Minimum 45000 Minimum 40000 Minimum 5000 Minimum 2000 Minimum 15000
Maximum 340000 Maximum 40000 Maximum 10000 Maximum 5000 Maximum 25000
sum 1103000 sum 320000 Sum 65000 Sum 31000 sum 170000
count 8 count 8 count 8 count 8 count 8|





image14.png
Document Inspector

To check the document for the selected content, click Inspect,

Comments!
Inspects the document for comments.

'Document Properties and Personal Information
Inspects for hidden metadata or personal information saved with the document.

Data Model
Inspects Data Mode for embedded data that may not be visible on the sheets.

Content Add-ins

Inspects for Content add-ins saved in the document body.

Task Pane Add-ins
Inspects for Task Pane add-ins saved in the document.

PivotTables, PivotCharts, Cube Formulas, Sicers, and Timelines.

Inspects for PivotTables, PivotCharts, cube formulas, slcers, and timelines, which may
include data that's not visible on the sheets.

Embedded Documents

Inspects for embedded documents, which may include information that's not visible in





image245.png
s Book! - Excel

Home Insert  Pagelayout  Formulas T O o e o e

= [ Show Queries [ Connections | 4 = EB v w

BB L B B # E i
Access Web Tet Sources~ Connections Query~ O Recent Sources | - Yo Advanced | Columns Fill Duplicates Validation - Data Model

Get External Data Get & Transform Connections Sort & Filter Data Tools




image246.png
Consolidate

Eundtion:

Sum. <

Reference:

Al references:

Use labels in

O1op row
Oeft column [ Create links to source data

oK Close





image247.png
Use labels in

O1op row
Oeft column [ Create links to source data




image248.png
* Activity 4-1D - Bxcel = o

Inset  Pagelayout  Fommulss  Data  Review Q Tell me what you want t JohnSmith £, Share

iy o Catbr “[n B Wrap Tt General - £ [ Normal Bad Good ewsl || &= [ff) Zawosm - A O

B3 Copy - [ Fin-

Merge & Center - § - % » %3 g5 Conditional Formatas | Calculation Check Cell Explanatory _ | Insert Delete Format & i~ Sort & Find &

Fiter~ Select +

Formatting - Table~ -
& Number & Styles cells Editing “

Clipboard r. Font

Al ~ | £ v

Sheetl ® i [0 D]





image249.png
AL

NMEIEE





image250.png
s Activity 4-1D - Bxcel

Home Inset  Pagelajout  Formuas View
= [ Show Queries (2] Connections 5 S = 7 w

kB B BIwee T e 5 B B

From From Fom FomOther  xisting  New Refresh 2| sor e U Tetto Flsh Remove  Data  Consolidste Mansge

Access Web Text Sources~ Connections Query~ Lo RecentSources - Vo Advanced  Columns Fil - Duplicates Vlidaton - Dsta Model

Get External Data Get & Transform Connections Sort & Filter Data Tools




image251.png
=i Gpolomrs s B T e e e S Q) Sharc
BR Copy ~ = 8 = Fill
Pate L ePainter Tu-|E-|&-A (e $ Ftamhtmna\ Formatas| Heading 1 Heading 2 Heading 3 Heading 4 | v Sort & Find &
ormatting - Table < Fifter~ Select
Clipboard 5 Font Alignment Styes celts Editing
B2 - E
A 8B | ¢ | © e F 6 | M | 1 | 4 |k | v | M | N | o P | a | s | 7 | u | v | ow |
3| o8 1 B S 1999.95 Warehouse 8
4| 1w is 1587 § 77763 Warehouse Consolidate 7%
5| 38 s s $ 21,599.45 Warehouse A [e——
6| 147 s 214 $ 27,817.86 Warehouse B [sum B
7] 18 s 5 S 22455 Warehouse A P
Bl IS o § L0 UREIIIG “[Activity 4-1AxisxSheet11SB5258535 Browse.
o s s 45 S 191250 WarehouseA [P
0| s s ) $ 35,599.11 Warehouse C =
| 147 s s S 1,076.64 Warehouse A &
2| 25 s 55 $ 31,3945 Warehouse 8 Detete
3 167 s 35 S 516565 Warehouse A Use labels in
e sy s 8 S 151211 WarehouseB Dltop row
5| 1 s 854 $ 41845 Warehouse A Oltettcotumn [ Create links to source data
6 147 i$ ars $ 61,745.25 Warehouse A
w7 a1 s 89 S 800.11 Warehouse A oK Cose
8] a4 ls 2 S 18,750.00 Warehouse A
1o 147 s 2 S 26315 Warehouse®
0] wm is 4876 S 23892 WarehouseB
21 28 1% s $ 21,599.45 Warehouse A
2| a7 is 15 S 18,848.55 Warehouse B
23| 158 s a5 S 22455 Warehouse A
2| 1m is 65 S 1935 WarehouseC
25| sie7 1s s S 191250 Warehouse A
2] 28 is %0 S 35,999.10 Warehouse C
27| 157 s s S 1,076.64 Warehouse A
28 235 s 55 $ 31,349.45 Warehouse B
29 157 s 35 S 516565 Warehouse A
0] s 1s 8 S 151211 WarehouseB
31| 1 s s S 42825 Warehouse A
2| 17 s an $ 61,225.29 Warehouse A
3 e s 89 S 80011 Warehouse A
PIETR 2 S 18,750.00 Warehouse A
3| 17 s 2 S 26515 Warehouse® |
Ed
Sheet! ® [ o}
Point 8 i) m - +





image252.png
Consolidate

Eundtion:
Sum.

Reference:

[Actvity 4-1Axisx]Sheet1 15BS2:5BS35

Al references:

Use labels in
O1op row
[ Left column

[ create links to source data

oK

Close





image253.png
Insert Pagelayout Formulas JohnSmith ), Share

BR Copy ~ = 8 = Fill
pate B I U |E |0 A P - | 6 Conditionsl Format as| Heading 1 Heading2  Heading3 Heading 4 nset Deete Format | [ Sot& Find&
ormat Painter Formatting - Table: & Clear Fifter~ Select
Clipboard 5 Font Alignment Styes celts Editing ~

B2 - £ | sku

SKU_[<|Unitprice |-|Quantity [-|Totalvalue [-|location (| F | & | H | | 0 | k | v | m | N[ o | p | @ | R | s [ T | u | v
4] 178 s 0491 1587 5 777.63 WarehouseB
5| 2358 1S 39999 54 $  21,599.46 Warehouse A
6| 147 1S 19990 214§ 2781786 WarehouseB Consolidate 7 X n
7] 18 1S a9 a5 S 22455 Warehouse A rancton:
8| 1. s 299) & $ 1935 WarehouseC foe -
9 5167 1% 4250 45 $  1,912.50 Warehouse A
10| 2358 S 399.99 89 $  35599.11 Warehouse C Ecteenee]
11| 1347 1s  13ass s § 107660 Warehouse A “[Activity 418 xisxSheet3 1SB5 258535 Browse.
2] 235 1S 56999 55 $  31,349.45 WarehouseB Allcterences
Bl 1o 18 1ense - S 516565 Warshouse A \Users\abowi\Desktop\MOS5003_Excel 2016.3_ExercseFiles add
14] 1459 is 16.99 89 $  1,512.11 WarehouseB Delete.
5| 1478 1S oas| s S 4185 WarehouseA T
6] 147 1S 12999 ars $ 61,7455 Warehouse A Cltep row
@ ds sl w5 snu weehousea A R ——.
18 34 1S 75000 2 S 1875000 Warehouse A
19 1587 s 13458 2 S 269.16 Warehouse8 o dose
20| 1478 1S 049! 487 S 238924 WarehouseB
21| 2358 |s 3399 54 $  21,599.46 Warehouse A
2| 147 S 1999} 15 S 1884855 WarehouseB
23] 18 s 49 a5 S 22455 Warehouse A
24| 15 s 299 65 S 19435 WarehouseC
25| s167 S 4250} 45 S 191250 warehouseA
2| 2358 s 39999 %0 S 3539910 Warehouse C
27| 147 s 13458 s S 107664 Warehouse A
28| 235 1S 56999 55 $  31,349.45 WarehouseB
20| 1567 1s 14759 35 S 516565 Warehouse A
30| 1459 s 16.99 89 $ 151211 Warehouse B
31| 1478 'S 045 sm S 428.26 WarehouseA
32| 147 i 199 an $ 61,2529 Warehouse A
3| 47 is 89 89 S 80011 Warehouse A
34 3 1s 75000 2 S 1875000 Warehouse A
35| 147 s 2 S 2635 Warehoused |
36|
Bl o

Sheet3 ® [T I

Point 8 i) m - +





image254.png
Consolidate

Eundtion:
Sum. <
Reference:

[Actvity 4-1B xsxSheet3 1sBS2:5B535

Al references:

\Users\abawi\Desktop\MOSS003_Excel_2016.3_ExerciseFiles\Starting Files for Activites\Lesson

Use labels in

O1op row
Oeft column [ Create links to source data

oK

Close





image15.png
Document Inspector

Review the inspection results.

Comments
No items were found.

'Document Properties and Personal Information
The following document information was found:
*~Document properties

* Author

* Absolute path to the workbook

Data Model
No embedded data found in the Data Model,

Content Add-ins
We did not find any Content add-ins.

Task Pane Add-ins
We did not find any Task Pane add-ins.

PivotTables, PivotCharts, Cube Formulas, Sicers, and Timelines

No PivotTables, PivotCharts, cube formulas, sicers, or timelines were

found,

4. Note: Some changes cannot be undone,

Reinspect





image255.png
Insert  PageLayout  Formulas Q Tell me what you want John Smith
% cut IS ®- | ErWapTen General Note Output Warning Text £ ] | Zawesm - Ay O
B Copy = § ol
e Tu-|E-|o Merge & Center - | $ Conditional Formstas| Heading 1 Heading2  Heading3 Heading 4 nset Deete Format | [ Sot& Find&
ormatFanter Formatting - Table = Clear Filter = Select
Clipboara 5 Font Aignment stytes cels diting
B2 - f || Quantity
SKU_ [~ Unit price | Quantity ~|Total Value ~|location [+| F | 6 | H | |0 | kK | L | M | N | O | P | Q| Ls | T | u | v | w | x | ¥
4| um is 049 1587 B 77763 Warehouse 8
5| 2358 1 39999 54 $ 21,593.46 Warehouse A
6| 147 s 12999 214 S 27,817.85 WarehouseB
7 158 |s 499 5 s 22455 Warehouse A Consolidate rox
8| 157 is 299 65 s 194,35 Warehouse C Fundion:
9| 5167 !$ 42.50 45 $ 1,912.50 Warehouse A sum v
10| 2358 1 399.99 8 s 35,598.11 Warehouse C Reference:
11| 1547 18 13458 s s 1,076.64 Warehouse A IActvity 4-1C xssheet2 1585258535 Browse
2] 235 s 569.99 55 $ 31,349.45 Warehouse B Al references:
3] 1567 1 147.59 35 B 5,165.65 Warehouse A \Users\abawi\Desktop\MOS5003_Excel 2016 3 ExercseFiles\Starting Files for Adtvities\Lesson < add
@l oo 0% ) o s G Ui \Users\abcw Desktop\MOSSO003_Excel_2016.3_ExeriseFiles\Starting Fils or Actiies\Lesson -
15| 1478 | 049 854 B 418.46 Warehouse A Delete
6] 147 s 129.99 a75 $ 6174525 WarehouseA Use labels in
7| a7 s 899 89 s 80011 Warehouse A Ooprow
18 a4 1S 750.00 2 S 1875000 Warehouse A Dliettcotumn ] Create links to source data
19| 1547 !$ 13458 2 s 269.16 Warehouse 8
20| 147 is 049 4876 s 2,389.24 Warehouse B ok close
21| 2358 1$ 39999 54 $ 21,593.46 Warehouse A
2| 147 is 12999 145 S 18,34855 WarehouseB
23] 18 1s 499 a5 s 22855 Warehouse A
24| 157 s 299 65 s 194,35 Warehouse C
25| 5167 |s 4250 45 s 191250 Warehouse A
2 238 1s 399.99 %0 S 3599910 WarehouseC
27) 1547 1s 13458 ) s 1,076.64 Warehouse A
28| 35 }s 569.99 55 s 31,343.45 Warehouse B
20] 157 s 147.59 35 s 5,165.65 Warehouse A
30| 159 s 1699 ) s 151211 Warehouse 8
31| 147 1s 049 57 s 42826 Warehouse A
2| 17 !s 129.99 an $ 61,225.29 Warehouse A
3| a7 s 899 89 s 80011 Warehouse A
34| 3 is 750.00 2 S 1875000 Warehouse A
35| 1547 1§ 2 s 269.16 Warehouse B |
36|
37|
Sheet2 @ [
Point &3 ] M -





image256.png
Consolidate

Fundtion:
sum v
Reference:

“[Activity 4-1CxlsxSheet2 SBS2:5BS35|

Al references:

\Users\abawi\Desktop\MOSS003_Excel 20163 ExerciseFiles\Starting Files for Activiies\Lesson
\Users\abawi\Desktop\MOSS003_Excel_2016.3_ExerciseFiles\Starting Files for Activiies\Lesson <

Use labels in

O1op row
Oeft column [ Create links to source data

oK

Close





image257.png
Consolidate [

Eundtion:

sum B

[Sum
Count

Excel_2016_3_ExerciseFiles\Starting Files for Activties\Lessor

Product Excel 20163 ExerciseFiles\Starting Files for Activities\Lesson < add

|Count Numbers

staDev

staDevp.
Var
\Varp

T Top row

Oeft column [ Create links to source data

oK Close





image258.png
Consolidate

Eunction:
&

Reference:
\Users\abawi\Desktop\MOSS003_Excel_2016.3_ExercseFiles\Starting Files for Activiies\Lessor

Al references:
g add

Use labels in

O1op row
Oeft column [ Create links to source data

oc [ e





image259.png
(= s Activity 4-1D - Excel ] o

Fle  Home et Pagelsout Fomnulss View  Q Tell me what you want JohnSmith £, Share

BRH 3 B BE-T RE-@ Yio SO S e 8 6@ EE

From From From FromOther  Bisting  New Refresh z| Sott  Fiter Tetto Flash Remove Data  Consolidate Relationships Manage  What-f Forecast Group Ungroup Subtotal
Access Web Tex Sources Comnections Query~ L RecentSources . [ Edit Links & VoAdvanced | Columns Fill - Duplicates Validation - DataModel Analysis~ Sheet - -

Get External Data Get & Transform Connections Sort & Fitter Data Tools Forecast Outline & -~

= Show Detail
= Hide Detail

Al ~ | £ | 29 v

B | ¢ | © E F | 6 | H | ' | 3 | K | L | M N| O P | @ | R | s [ T | U | v | w | X | ¥ z | m

$399.99
$ 049

ol

2|

3

4 JEEEE)
5 [ $129.9 |
6fs 499
7|
8]
=

0

$ 4250
$399.99

11| $569.99
12| s1a7.59

14[s o049
15| $129.99

17 $750.00
18( $134.58
19[s o049
20| $399.99
21| $129.99

23|$ 299
24| $ 4250

26| $134.58
27| $569.99
22| 14759
29| $ 16.99
30($ 049

2[s s
33 $ 75000 =
34| $13458 -
Sheet1 ® G D)

Average: $180.92 Count:34  Sum: $6,15126 | [ [ -+ 100%





image260.png
Pagelayout  Formulas  Data  Review

Q Tell me what you want o do
() % cut Calbri B S Wrap Tert General B
B copy -
7% Format Painter Tu-[E-[O-A Merge& Center - $ ~ % 2 | %3 5%
Clipboard ) Font. ) Alignment G Number ]
Al e fo =SUM([Book2.xIsx]Sheet1!$A$1:5851)]
A | s c o 3 3 s H 3 L
3





image261.png
Insett  Pagelayout  Formulas  Data  Review Q Tell me what you want o do

ﬁ % cut Calior i & A 5 Wiap Text General B
o B3 Copy -
' FormatPainter | B 1 U [H |2~ A Merge&Center = § - % * B 83
Clipboard G Font G Alignment ] Number ]
AL - e || =SuM('C:\Users\abcwi\Desktop\[Book2.xIsx]Sheet1'1$AS1:5851)|
A | s c o 3 3 s H ' ] 3 L
1 3





image262.png
= o

s Table Activity 4-2A - Bxcel

JohnSmith ), Share

Insett  Pagelayout  Formulas  Data  Review  View | Design Q Tellmewhatyouwantt

iy o Catbr “[n B Wrap Tt General - 7 | Normal Bad Good ewsl || &= [ff) Zawosm - A O

R Copy ~ = [=Fin-

Merge & Center $ - 9% » <395 Conditional Formatas [calculation Check Cell Explanatory _ | Insert Delete Format & i~ Sort & Find &

Formatting - Table~ - Fiter~ Select +
cells Editing “

Clipboard r. Font & Alignment r. Number & Styles

c6 ~ | £

o
o
E
=
z
z
o
o
£
o
-
S
<
=

Warehouse A 1635 $ 1621
Warehouse B 1952 S 1,25203
‘Warehouse C. 154 S anss

2
3

4

5

5 Total Entry Count
7]

8l

2]

Sheetl ® i [0 D]

Ready





image263.png
Table

Design

Q Tell me what you want to d

Insert  Pagelayout  Formulas  Data View

don TR L s

Clipboard 5 Font Algnment
sum 2 X W fe || =COUNT( tmmm

A ] COUNT(value1, [value2], ..) E

Warehouse A
‘Warehouse B
‘Warehouse C

1635
1952
154

Total Entry Count

Wiap Text

Merge & Center

General

$

$ 1621
S 1,25203
$ 402.98

[=counT(





image264.png
Formulas  Data

ﬁ % cut n oA - EewnpTet
pase BB Copy -
T S omatpainter | B T U [ DA Merge & Center
Clipboard 5 Font Alignment
SUM - X« £ | =COUNT([Activity 4-28.xIsx]Sheet1] <
A 5

COUNT(valuel [velve2l,.) | | B | F

1
2 |Warehouse A 1635 $ 1621
3 |Warehouse B 1952 S 1,25203
4 |Warehouse C 154 S anss

5
5 Total Entry Count
7




image16.png
Activity 1-1 - Excel = o

T o e e e = e @ T e John Smith £ Share
I g;z' T BERErY WinpTex General - £ [ Normal Bad Good | i é::'j‘“m Ay O
P pamer BT U e DA Wegaco + | § <% o 5 o fomas el (oo | [T | e oeee s OU sons s
Cipboara 5 Font 5 Aignment 5 mmber  w syes cets cating ~
AL M fe | Weekly Sales & Bonus Payout v
A ] | c | D E F G H o ! () K L M N o P a R s T s
1 Week\|y Sales & Bonus Payout Weekly Bonus Amount
2] B 500.00
3|
4| Week  First Name Last Name D WeeklySales  Weekly Goal  Bonus.
5| 1 Jackie ‘Williamson Jackie_Williamson $  16,785.14 $  15,000.00 $500.00
6| 1 lucs Bressan Lucas_Bressan $ 1468750 $ 1500000 $ -
7| 1 Stanley Prestwick Stanley_Prestwick $  13,478.96 $ 1500000 $ -
8| 1 emy Harrison Jerry_Harrison $  21,68347 $  15000.00 $500.00
9| 1 Leah Thompson Leah_Thompson  $ 2547845 $  15,000.00 $500.00
10| 1 Robyn Fletcher Robyn_Fletcher  $ 7,600.00 $ 1500000 $ -
1 lsa McCain Lisa_McCain $ 568900 $ 1500000 $ -
12| 1 Steven Stone Steven_Stone $ 1234687 $ 1500000 $ -
13| 1 Devon Lawrence Devon_lawrence $  11,687.00 $  15000.00 $ -
4] 1 George Jackson George Jackson  $  9,87445 $ 1500000 $ -
15|
16|
il
18
19
20
21
2|
2|
24|
2|
26|
27|
2|
2
30|
31| B
2 -
Sheetl | Sheet2 | Sheets | & E| D)
Ready ]





image265.png
Insert  Pagelayout  Formulas  Data

dcut
B3 Copy -
Paste
' Format Painter ru
Cipboard ® Fon
- x v £
A 3
1
2 \Warehouse A 1635
3 Warehouse B 1952
4 \Warehouse C 154

Total Entry Count

n_-|A R
&- A Merge & Center
t Alignment
=COUNT('[Activity 4-28.xIsx]Sheet1’
c o 3 F
$ 1621
S 1,25203
$ 402.98





image266.png
31 Updiate Values: Activity 4-2B:sx

<« « 4 [ < Starting File for Activites » Lesson 4 o]0 [ SearchLessona
Organize = Newfolder E
P Nome Detemodiicd  Type Sie
Bvekop @Ay 1A STOIS619AM  Microsoft Bcel . BT
$ Dounionts+ EAciy 418 S/T/OIS619AM  Microsoft Bcel . Y
socomens + S/T/OIS619AM  Microsoft Bcel . 2@
P ) S/T/OIS619AM  Microsoft Bcel . sk
ures 8/17/20156:199AM  Microsoft Excel W. 51KB
B Micosoft el & Actvity 428 S/T7/2015619AM_ Microsoft bl Wer BT
S/T/2015619AM  Microsoft Bcel W. e
& OneDiive
S/T/OIS619AM  Microsoft Bcel . wKe
This e YWRISGI9AM  Microsof Bxcel . sike
) Acthity 43¢ S/T/OIS619AM  Microsoft Bcel . wKe
Local Disk (C:).
& Network
& Homegroup
Fiename: [Actvity 428 7] [BeeiFies





image267.png
o N o w

Warehouse A 1635 16211
‘Warehouse B 1952 1,252.03
‘Warehouse C 154 402.98





image268.png
& Activity 5-1 - Excel = o

Insert  Pagelayout  Formulas  Data  Review Q Tell me what you want t John Smith £, Share
ﬁ g;z:' . Calibr B General B ’_:) Linked Cell _ [Note Output WarningText |~ gﬂﬂ %( i é:““i““‘"‘ Ay p
poste ‘*Fozammm Bru- Merge&Center = $ ~ % » | %8 5% ém;::"n;\ Formats:| Heading 1 [Heading2 _| Heading3 Headinga (|| Imsrt Dokte Fomat | o[ St Fndes
AL - Fe || sku v
F Il G Il H Il Il J Il K Il L Il M Il N Il o Il P Il a Il R Il s Il T Il u Il v
- [50_] nitprice  Quantity TotalValus  Location |
2| 1:m s 299 s B 14.35 Warehouse A
3| 238§ 39999 s S 1,999.95 WarehouseB
4| a7 s 049 1587 S 777.63 WarehouseB
5 2358 S 399.99 54 $  21,599.46 Warehouse A
6| w7 s 199 1 $  27,817.86 Warehouse B
7] 18 s 4.99 a5 S 22455 Warehouse A
8| 17§ 299 65 $ 13435 WarehouseC
9 5167 S 42.50 as $  1,912.50 Warehouse A
10 2358 s 399.99 89 $  35,599.11 Warehouse C
n 1547 S 134.58 8 $  1,076.64 Warehouse A
12| 235§ 569.99 55 $  31,34945 Warehouse B
3 1567 8 14759 35 S 516565 Warehouse A
4] 189§ 1699 9 $ 151211 WarehouseB
5| w7 s 049 854 S 418.46 Warehouse A
16 147 S 12999 475 $  61,745.25 Warehouse A
7| e s 299 £ S 80011 Warehouse A
18| 34§ 75000 2 $ 1875000 Warehouse A
19 1547 5 13458 2 S 263.16 Warehouse B
20| 1478 $ 049 487 $  2,389.24 WarehouseB
21| 2358 S 399.99 54 $  21,599.46 Warehouse A
2| 147 s 12999 145 $  18,848.55 WarehouseB
23] 1358 $ 4.99 a5 S 22455 Warehouse A
24| 157§ 299 65 $ 13435 WarehouseC
25| 5167 $ 4250 a5 $  1,912.50 Warehouse A
26| 2358 8 39939 %0 $  35999.10 Warehouse C
27| 1547 $ 13458 5 S 1,076.64 Warehouse A
28| 235§ 56999 55 $  31,34945 Warehouse B
29| 1567 | $ 14759 35 S 516565 Warehouse A
20| 15  $ 169 9 $ 151211 WarehouseB
31 147 S 049 87 S 428.26 Warehouse A
32| 147 S 12999 471 $  61,225.29 Warehouse A
A 299 £ S 80011 Warehouse A B
34 354 s 750.00 25 18,750.00 Warehouse A e
Sheet3 ® [I ] Dl
Ready %3 ] 100%





image269.png
Info.

Open

Save

SaveAs

Print

Share

Export

Publish

Close




image270.png
Export

[ Create PDF/XPS Document

=} change File Type

Create a PDF/XPS Document

Preserves layout, formatting, fonts, and images
Content can't be easily changed

Free viewers are available on the web.

[

Create
PDF/XPS





image271.png
Account

Options.

Feedback

Export

[2) Create PDF/XPS Document

Hr Change File Type

Change File Type

Workbook File Types

E Workbook
Uses the Excel Spreadsheet format

@ OpenDocument Spreadsheet
Uses the OpenDocument Spreadsheet
format

Eg Macro-Enabled Workbook
i Macro enabled spreadshect
Other File Types

Text (Tab delimited)
= Tt format separated by tabs

E Formatted Text (Space delimited)
Tt format separated by spaces

Save As

Activity 5-1 - Bxcel

Excel 97-2003 Workbook
Uses the Excel 97-2003 Spreadsheet format

Template
Starting point for new spreadsheets

Binary Workbook
Optimized for fast loading and saving

CSV (Comma delimited)
Text format separated by commas

avessAnother Fle Tpe Y




image272.png
Account

Options.

Feedback

Export

[2] Create PDF/XPS Document

Hr Change File Type

Change File Type

Workbook File Types

Workbook
Uses the Excel Spreadsheet format

E OpenDocument Spreadsheet
| Uses the OpenDocument Spreadsheet
format

Eg Macro-Enabled Workbook
(T Macro enabled spreacisheet
Other File Types

Text (Tab delimited)
Text format separated by tabs

Formatted Tt (Space delimited)
Text format separated by spaces

7

Save As

Activity 5-1 - Bxcel

Excel 97-2003 Workbook
Uses the Excel 97-2003 Spreadsheet format

Template
Starting point for new spreadsheets

Binary Workbook
Optimized for fast loading and saving

CSV (Comma delimited)
Text format separated by commas

B Save as Another File Type




image273.png
[ save s
€ v E THEPC > Deskop

Organize v New folder

Name Date modified

v 5 Quick access
Moekop
& Downloads #
Documents #
Epiures 4

1] MOSS003 Buce 2016 3 Brercisfles  1/27/2016.230PM

> ) Microsoft el

> @ OneDiive

This PC

> i Local Disk (C)

v|®| | Search Desktop

Type Size

File folder

> e Network v
File name: [ Activity 5-1 Complete
Save as type: | CSV (Comma delimited)
Authors: John Smith Tags: Addatag Title: Add atitle
A Hide Folders Tools ~





image274.png
Microsoft Excel

X

o ‘Some features in your workbook might be lost if you save it s CSV [Comma delimited).

Do you want to keep using that format?

=3

No Help





image17.png
Info.

New

Open

SaveAs




image275.png
Activity 5-1 Complete - Bxcel

= o

bt Boplmmn G Gmn [ @ T JohnSmith | . Share

frde  fam [ S wiapTort Geners A B [voma Bad Good ewsl || &= i é:'j‘w A&y O
e BT U Ve = § <%+ | 1 Condtond Pt Ceckcai [ [ M A R

apbora & @ Atgrment 3 omm @ s can iing B
Al h i3 SKU M

Al s | c o e | f | & | n bk Lt M [ N | o | a|.=& Tl v v w x|y |z
1 [sxu___Juniterice quantity Total valuLocation
2] Bn s 5 $1495 warehouse A
3| 258 $9999 S wasspns Warehouse B
4| 47 $049 1587 $777.63 WarehouseB
5| 2358 $99.39 54 smspnss Warehouse A
6| 147 512993 214 sswssss Warehouse
7] s sass 45 $220.55 Warehouse A
8| 1m s 65 $190.35 Warehouse C
9| s1e7 s 45 smspnns Warehouse A
10| 2358 $39.39 89 ssspsss Warehouse C
1| 1547 $1:458 8 sy Warehouse A
2] 235 $ses39 55 ssspnss Warehouse B
13] 1567 $17.59 35 sspnss Warehouse A
14| sy siesn 89 ssspnss Warehouse B
15| 1478 $049 854 $41846 warehouse A
16| 147 $125.99 475 sassesss Warehouse A
) 8 $300.11 Warehouse A
18] 34 $750.00 25 ssspnss Warehouse A
19] 1547 $1:458 2 $269.16 Warehouse B
20| 1478 043 4876 sessess Warehouse B
21| 2358 539999 54 ssspnss Warehouse A
2| 147 s 145 wapaess Warehouse B
2 s sass 45 $220.55 Warehouse A
4| 1m s 65 $190.35 Warehouse C
25| 5167 sa2s0 45 smspnns Warehouse A
26| 2358 $99.99 90 ssspsss Warehouse C
27| 1507 13458 8 sy Warehouse A
28| 235 $69.99 55 ssspnss Warehouse B
29 1567 1759 35 sspnss Warehouse A
30| w9 s 89 ssspnss Warehouse B
31| 1478 $049 87 $428.05 WarehouseA
32| 147 51999 471 sesssess Warehouse A
3| a7 sess 8 $300.11 Warehouse A u
34| 350 $750.00 25 sssEEE Warehouse A =
Activity 5-1 Complete ® I o

Ready 23 El 100





image276.png
Home  Inset  Pagelayout  Formulas

P [‘é DD D} D FDEISWQUEHE: Feglcmemm

B From Tabie
o Gzn fom fomGh  Ezop || R Reresh

Access Web Tet Sources~  Connections | Query~ L Recent Sources -

Get External Data Get & Transform Connections.





image277.png
* Activity 5-2A - Bxcel = o

Inset  Pagelayout  Fommulss  Data  Review Q Tell me what you want t JohnSmith £, Share

iy o Catbr “[n B Wrap Tt General - £ [ Normal Bad Good ewsl || &= [ff) Zawosm - A O

B3 Copy - [ Fin-

Merge & Center - § - % » %3 g5 Conditional Formatas | Calculation Check Cell Explanatory _ | Insert Delete Format & i~ Sort & Find &

Fiter~ Select +

Formatting - Table~ -
& Number & Styles cells Editing “

Clipboard r. Font

Al ~ | £ v

Sheetl | Sheetz | sheets | @ i [ o)





image278.png
AutoSave

File  Home Inset  Pagelayout  Formulas  Data  Review  View C

% [‘% D@ g [‘é [‘E FS [T Queres & Connections

Get From From FromTable/ Recent ~ Existing | Refresh
Datav Text/CSV Web  Range Sources Connections | Allv

Get & Transform Data Queries & Connections





image279.png
[ Import Text File

Organize v New folder

s Quick access
1B Desktop
& Downloads
Documents
= Pictures

B Microsoft Bxcel

7 OneDiive

This PC

Local Disk (C)

& Network

+4& Homegroup

© v 4[]« Desktop > MOSS003 xcel 2016_3 rercisefles » Starting Files for Actvities » Lesson 5 [0 [ SeachLessons »
E=- m @
Name Datemodfied | Type Size
+ |l Actiiny 28 YTU21GI9AM  Text Document 2k8

»
»
»

File name: [Actity 528 7] [TectFies <

Tools

> Import QJ





image280.png
activity 5-2b.txt
File Origin Delimiter Data Type Detection
1252 Western European (Windows) < | | Tab Based on first 200 rows. - B
SKU  UnitPrice  Quantity  TotalValue Location
1574 299 s 145 Warehouse A A
] 5| 199995 Warehouse
1478 049 1587 77763 Warehouse 8
] 54| 2159946 Werehouse A
7 12998 214 2781786 Warehouse 8
1558 459 5 22455 Warehouse A
157 299 B 19435 Warchouse
s167 250 45| 191250 Werehouse A
] 59 3550911 WarehouseC
1547 13058 5 107664 WerehouseA
25 sesss 55| 31,38945 Werehouse 8
567 14759 35| 516565 WerehouseA
1459 1558 5 151211 Warehouse8
1478 049 5 418,45 Warchouse A
7 12998 475 6174525 Warehouse A
7 899 8 50011 Warehouse A
s 75000 25 1875000 Werehouse A
1547 13058 2 26916 Warchouse 8
1478 049 4876 238924 Werehouse 8
] 54| 2159946 Werehouse A
© The dota inthepreview has been truncoted due tosize it N
Loxa Trarstorm Data | | Cancel





image281.png
File

Home

Table Name:

activity 5.2
& Resize Table

Properties

AL

Insert  Pagelayout  Formulas  Data  Review  View
Summarae withPcttable =] [, Brorets
B Remove Duplicates =/ <
et | Export Rereh 8
& Convetto Range diewr | G Uik

Tools

£

External Table Data

Developer

I Header Row
Total Row

| Banded Rows

Help  Power Pivot

Fist Column
Last Column

Banded Columns

Table style Options

Table Design

I Filter Button

2| 157 299 s 14.95 Warehouse A
3| 238 3299.99 s 1999.95 Warehouse B
4| 147 049 1587 777.63 Warehouse B
5| 2358 3299.99 54 21599.46 Warehouse A
6| 147 12999 214 27817.86 Warehouse B
7| 1358 499 a5 22455 Warehouse A
8| 157 299 6 19435 Warehouse C
9| s167 425 a5 1912.5 Warehouse A
10| 2358 299.99 89 35599.11 Warehouse C
1] 1547 134.58 B 1076.64 Warehouse A
12| 235 569.99 55 31349.45 Warehouse B
13| 1567 147.59 ES) 5165.65 Warehouse A
14 1459 1699 £S) 151211 Warehouse B
15| 1478 049 854 418.46 Warehouse A
16| 147 12999 475 61745.25 Warehouse A
7| a7 899 89 800.11 Warehouse A
18] 354 750 F5 18750 Warehouse A
19] 1547 134.58 2 269.16 Warehouse B

20| 1478 049 4876 2389.24 Warehouse B

21| 2358 3299.99 54 21599.46 Warehouse A

2| 147 12999 145 18848.55 Warehouse B

23| 1358 499 a5 22455 Warehouse A

24| 157 299 6 19435 Warehouse C

25| s167 425 a5 1912.5 Warehouse A

2| 2358 299.99 %0 35999.1 Warehouse C

27| 1547 134.58 B 1076.64 Warehouse A

28| 235 569.99 55 31349.45 Warehouse B

29| 1567 147.59 ES) 5165.65 Warehouse A

30| 1459 1699 £S) 151211 Warehouse B

31 1478 049 87 428.26 Warehouse A

2| 147 12999 471 6122529 Warehouse A

3 47 899 89 800.11 Warehouse A

34 354 750 F5 18750 Warehouse A

35| 1547 134.58 2 269.16 Warehouse B,





image282.png
File  Home [Insert ] Data Review View Tell me what you want todo  Open in Excel
A BEHEHE|BD O dxOoEQl H ©
Function  Forms Teble [Puotialy Picure Shapes  Offce  Column Lne P Bar Awes Scatier Otner
i SO T T T e
Al
' A 8 c D 3 3 G H
1 B Region [ Sub-Regiorg Q =0 =0 T
2 |addaElwood  Africa Narobi 5443983 $431629  S450521  $433587
3 |agusteFesier  [Amenca T S420000  $a25269 Saz3ea1  $127,746)
4 |AletheaWinyard  Europe Lisbon S11498 S 0264 S429716  $261261
5 |AshJirousek America Toronto $368,612  $382,150  $264,538  $225,349
6 |Burton Wreath Asia Manila $170,905  $153945  $219,391  $238,136|
7 |Christopher Fieis  Europe Lisbon Sa734%  S:68%7  S487S15  $216623
8 |codyLuton Europe Moscow $218203  S277ase S477,055  $416420
9 |DebraGodman  Africa Narobi S418579  S171975  Sasspse  $318128
10 |DelaineyMont  Asia Manila S386315  S1sa77e  S162573  $387,770
11 |prake Becom Europe Moscow S:1113 S13202  Si73g04  $435803
12 [Eboneetouch  Asia Bangkok S224551  Sisgsl  s2sse  $20378
13 [Erica Busse Europe Moscow 69706 Sas1265 327855 $2%6231
14 |GainFreiberg  Europe Warsaw Samse:  Sasees salsds $3s046l
15 |GardyHowsley  America Toronto $420105  $314733  S4ss21e  $353656
16 |Haley Dartan Asia Bangkok $395150  $413350 165868 $234,643
17 |Hardy Eyclel Asia Manila Sas3688  S285903  S130577  $349059
18 |HerculesAmon  Europe Warsaw Sa0s311 sass  Sieaell  $323942
19 |joy Liddyard Asia Manila $144480  $340217  S103012  $1563950
20 |LuckyDelowch  America Toronto $363375  $4403%9  $394,639  S315954
21 [NealSolkars Europe Moscow S388254  S41893  S205,895  SAT0087
22 |Robert Balnaves _ Asia Manila 5255103 S13865  $441530  $143.461
23 [RochetteShelley  America Toronto 158576 $M5601 196293 $411245
24 |RodgerCampany  Asia Manila Sa67602  S:66613  SieszEs  $374323
el — e
Sheet1 @




image283.png
File Home Insert Data Review View Tell me what you want to do Open in Excel
Functons s ustratons | Ada-ns e Unis | Comments
< Full Name

A B c D E F G H J K
1 e [ERegion [gSub-RegionQ =0 =0 T =
2 |Adda Ellwood Africa Narobi $443983  $431,629  $450,521  $433,587
3 |agusteFessier  America Toronto 5429100 $425269  $373341
4 |aletheawinyard  Europe Lisbon $114980 $380264  $az9716 | CreatePivotTable
5 |AshJirousek America Toronto $368,612  $382,150  $264,538
6 |Burton Wreath Asia Manila $170,905  $153,945  $219,391 | Choose the data that you want to analyze
7 |Christopher Fleis  Europe. Lisbon $473,496  $286,857  $487919 | Selectatableorrange
8 |codyLuton Europe Moscow $218203  $277485 8477055 Table/Range:
9 |Debra Godman Africa Narobi $418579  $171,975  $448,654
10 [DelaineyMont  Asia Mania $386,315  $184778  $162573 | Choose where you want the PivotTable report to be placed
11 [Drake Becom Europe Moscow $341,113  $134202  $178,8%4 © New Worksheet
12 [ebonee Louch Asia Bangkok $228551  $115951  $289,162 Existing Worksheet
13 [Erica Busse Europe Moscow S169706  $281265  $327.955
14 |GavinFreiberg  Europe Warsaw $222863  $255684 5415483 Location
15 [Gardy Howsley America Toronto $420,105  $314,733  $499214
16 [Haley Dartan Asia Bangkok $395,150  $413,3%0  $169,368. oK ’Qi Cancel
17 [Hardy Eyckel Asia Manila $453,688 285903  $130577 —
18 |Hercules Almon Europe Warsaw $408311  $487,532  $142611  $323,942
19 |loy Liddyard Asia Manila 5124480  $360217  $103012 5196950





image284.png
B 5| @ ssesataxi T

&~ - O 0 B https://acmewidgets-my.sharepoint.com/xx;/r/personal/jsmith_acmewidgets_onmicrosoft_com/_layouts/15/WopiFrame.aspx?sourcedoc=%7B743f4 b g = 7. -

hn Smith
€ s | oA VEW  Q Telmewnatyouvanttodo | EDITINEXCEL

k@B ld (LIRS Wl J o D

Functon  Forms Table PiotTable Picture Shapes  Offie  Column Line Pl Bar  Ares Scatter Other Hyperink Comment
B - Adgins - - - - - - Crams-

Funcions Taes lsstons | Adine Crans Unke Commenss

PivotTable Fields x

Choose ields: >

00 o name.
0O region

0 sub-fegion
Do

O

O

Do

Drag flds betwen areas below

T FuTeRs I couumns

Rows 3 vawes

- HELIMPROVE OFRCE





image18.png
Info

Activity 1-1

Desktop » MOSS003_Excel_2016_3_ExerciseFiles » Starting Files for Activties » Lesson 1

Protect Workbook

Control what types of changes people can make to this workbook.

Activity 1-1 - Excel

Properties -
e
See more document
properties
oegores Bn ctegony




image285.png
FLE

fe

Function

Funcions

S RowLabels

DATA

REVIEW

EE L 409

Forms Table PiotTadle

Picture Shapes
sratons
e c
443083 431629
420100 425269
420100 425269
114980 380264
114380 380264
368612 382150
68612 382150
170905 153945
170305 153945
473996 286897
473435 286897
218203 277889
218208 277488
ass79 171975
a18s79 171975
86315 184778
86315 184778
sams 134202
41113 134202
22551 115951
224551 115951
169706 281265
165705 281265
222863 255684
222863 255684
420109 314733
420108 314733
395150 413390
395150 413390
av3688 285903
493688 285903
avss11  as7s32
08311 as7s32

SalesChart | _Sheet! | Data

VIEW  Q Tellme what you vant to do

kD= W

Column  Line

EDITIN EXCEL

Ares Scatter Oter  Hyperink  Comment

PivotTable Fields x
Choose filds: >

Full Name

Region
0 Sut-fegion

ar
O
Orag s betveen ares elon:
T FueRs 11 cowmns

Valoer -

= rows = vawes
Fulhame - sumeran B
Region -] sumora2 -

- HELIMPROVEOFRCE





image286.png
PivotTable Fields

Choose ields:

Full Name
Region

Drag flds betwen areas below

T FuTeRs I couumns
Values

= rows 3 vawEs
Full Name. Sumorat
Region Sumor 2

o 6




image287.png
FLE HOME

Funcions

S RowLabels

A EEE GOS8 mkDE @

Functon  Forms Table PiotTable Picture Shapes  Offie  Column Line Pl Bar  Ares Scatter Other Hyperink Comment

INSERT  DATA  REVEW ~ VIEW  Q Tellme what you want todo EDITIN EXCEL

T e O T msaw O
- s paoe e e | conmr -
s | c 1ol el f ot S KL M N0 " pivotTable Fields x
Choose fields: >
e
Region
S s Qs
w0 s a
o0 aasass g

114080 380264 oe
4980 380268

368612 382150

612 382150

170905 153945

170305 153945

473496 286897

73496 286897

28203 277489

2803 27789

w579 17975

ams7e 171975

386315 184778

315 184778 oy ae—er—

HIUS 134202 ¥ FLTERS 1l CoLUMNS
s 130202 e .
224551 115951

24551 115951

169705 281265

169706 281265

22863 255684

222865 255684

420109 314733

3 vawEs
220109 314733 Sumorat -
395150 413390 Sumor2 .

395150 413390
av3688 285903
493688 285903
avss11  as7s32
08311 as7s32

SalesChart | _Sheet! | Data ®

- HELIMPROVEOFRCE





image288.png
FLE

fe

Function  Forms Table PiotTable | Picture Shapes
Funcions Taes sratons

S RowLabels

A 8 c

1

2

3 lsumof @1 sumofaz
4 1110315 1077787
5 ‘Adda Ellwood 243083 431629
6 Debra Godman a18s79 171975
7 Ronald Burriss 247753 474183
8 = America 1916369 2089725
9 Aguste Fessier 429000 425263
10| ashiirousek 368612 382150
11 GardyHowsley 420109 314733
12| LuckyDelouch 363379 440399
13| Rochetteshelley 108576 345601
14| RosmnaSkeermor 136593 181573
15 asa 5287977 2632497
16 | Burton Wreath 170905 153045
17| Delainey Mont 386315 184778
18 | EboneeLouch 226551 115951
19| HaleyDartan 395150 413390
20 | Hardy Eyckel 93688 285903
21| JoyLddyard 148480 340217
22| RobertBalnaves 255103 134865
23| Rodger Campany 467602 266613
24 sivanoEstable 372755 12013
25 | Tucky Habishaw 210085 130985
2 | WandaRatiee 167342 476637
27 = Europe 3189113 3175154
28| Alethea Winyard 114980 380264
29 Christopher Feis 473495 286897
30 | codyluton 218203 277489
31 DrakeBecom 341113 130202
32| ErcaBusse 169706 281265
33| Galvin Freiberg 222863 255684
31| Hercules Almon 08311 ag7S32
35 | NealSolars 383254 418938
36 | sylvaneshmade a1sa18 379522
37 | TallyLeppington 436769 273361

HOME  INSERT

EE L 409

| Soeschart |_sheett | Date

DATA

REVIEW

VIEW  Q Tellme what you vant to do

kD= W

Column Lne  Pie  Bar

Adaine

EDITIN EXCEL

Area Saatter Otner
Crarts -

Crans Lnks

Hyperink | Comment

Commens

PivotTable Fields x

B Choose fields: >

Full Name
Region
00 sub-fegion
a

@

O

Do

Drag flds betwen areas below

T FuTeRs I couumns

Values -

- HEWIMPROVE OFRCE





image289.png
FLE  HOME INSERT ~DATA REVEW VIEW Q Tell mewhatyouwanttodo

fFBEEE B 8

Function | Forms Table PivotTable | Picture Shapes  Offce
. -~ addins
Funcions Taes lsstons | Adine
£ 425269
A e c )
1
2
3 Rowlabels ~sumofa1 sumofaz
4 = Afica 1110315 1077787
5 | - Nairobi 1110315 1077787
6 Adda Elwood 443083 431629
7 Debra Godman a18573 171975
8 Ronald Burrss 247753 474183
9 = America 1916369 2089725
10 = Toronto 1916369 _ 2089725
1 Aguste Fessier 429100]__a25269]
2 Ash Jirousek 3ess12 382150
3 Gardy Howsley 420108 314733
i Lucky Delouch 363379 440358
5 Rochette Shelley 198576 345601
16 RosannaSkeermor 136593 181573
17 casa 3287977 2632497
18 | = Bangkok 772578 1030012
19 Haley Dartan 305150 413390
20 Tucky Habishaw 210085 139985
Eil Wanda Ratlee: 167392 476637
2 | = Manila 2515399 1602485
23 Burton Wreath 170305 153945
2 Delainey Mont 86315 184778
2 Ebonee Louch 224551 115951
2 Hardy Eyckel 493688 285903
27 Joy Liddyard 108480 340217
2 Robert Balnaves 255103 134865
29 Rodger Campany 467602 266613
30 Silvano Estable 372755 120213
31 = Europe 3189113 3175154
32 = isbon 1185370 1310636
3 Alethea Winyard 114380 380264
34 Cody Luton 218203 277488
35 Syivan eshmade a1sa18 379522
36 Tally Leppington 436769 273361
37 | = Moscow 1372569 1121302

SalesChart | _Sheet! | Data

kD= W

Column  Line

EDITIN EXCEL

Ares Scatter Oter  Hyperink  Comment

PivotTable Fields x

Choose ields: >

Full Name
Region

Sub-Region -
a

@

O

Do

Drag flds betwen areas below

T FuTeRs I couumns
Values -

- HEWIMPROVE OFRCE





image290.png
Move Up

Move Down
Move to Beginning
Move to End

T Move to Report iter
Move to Row Labels

1l Move to Column Labels

= MovetoValues

X Remove Field





image291.png
Excel Online | John Smith > Lesson 6

File  Home Insert Data Review View Tell me what you wantto do  Open in Excel

fEHE BED O dxOEALH @
Function  Forms Tabld PivatTable |<(ure Shapes Offce Column Line Pie Bar Area Scatter Other  Hyperlink Comment

. v Addins v v+ v~ v Chamse
Functons T T llustrations | Addins Unis | Comments
K12 v A

A o e F G H
1 City Revenues  Operating Expenses _ Operating Profit _ Depreciation _Net Profit
2 Warner $125,319 $65,792 $59,527 54,667 554,860
3 East Natchitoches $423,924 $101,465 $332,459 $5,068 $327,391
4 yon 5135816 567,388 68,428 $5,700 562,728
5 Willow Run $233,255 $83,606. $149,649 $5,089 $144,560
5 Augusta 5248973 529,206 5219727 34,208 5215519
7 | Conyersille 5128691 367,175 61,516 54,956 556,560
8 Mount Baker $244913 $89,974 $154,939 $5,062 $149,877
o |Farmington Lake 5392518 582,675 $309,843 $6,100 303,743
10 Martins Corner $331,773 $85,288 $246,435 $5,795 $240,690
11 Pickerel Narrows $244,575 $100,834 $144,141 $5153 $138,988|
12 |willaha $137,925 $104,528 $33,397 $5,673 $27,724)
13 |Center $207,163 $73,705 $133,458 $5,599. $127,859)
14 |spring City 3432326 579,297 $353,029 sa872 5348157
15 | Mittenlane $177,789 $103,757 $74,032 $5,144 568,388
16 East Waterford $201,945 $83,178 $118,767 4,734 $114,033|
17 | Coltman $461,214 $86,688 $374,526 $6,066. $368,460)
18 Scottsville $440,462 $81,912 $358,550 4,842 $353,708|
19 Hebron $407,339 $88,286 $319,053 34,604 $314,445
20 |Longview 5376263 92,698 283,565 $5,195 5278370
21 Emerson $149,134 $87,513 $61,621 $5,168 $56,453
22 [Total $3,753,017
2
2

nancial Data Financial Scorecard @




image292.png
Create PivotTable

Choose the data that you want to analyze
Select a table or ange

Teble/Range: | ] x

Choose where you want the PivotTable report o be placed
[® NewWorkshest
O bsting Worksheet

Locatior:

Cone





image293.png
4 a5 c b e F 6 s .y kL M N o » o R S __ piotlable Fields

Choose fields:

@ ay
! O se
PivotTablel 0 office Type
O Revenues

) Operating Bxpenses
© Operating Profit
© Depreciation

© Netprofit

Drag feds betueen sress below:
W FILTERS = coLumns

0l Rows % vaLues

oo Sheet1 Financial Data Financial Scorecard | @




image294.png
|sum of Net Profit
215519
215519
127859
127859
368460
368460
56560
56560
327391
327291
114033
114033
56453
6453
303743
3202743
314409
314489
278370
278370
62728
62728

Financial Data Financial Scorecard €}

PivotTable Fields

Choose fields:
city

State

offce Type
Revenues
Operating Expenses
Operating Proft
Depreciation

Net Profit

DE®

®

Drag feds betueen sress below:

W FILTERS = coLumns
0l Rows 3 VALUES

aty « | Sum of Net Profit
State .




image19.png
Activity 1-1 Properties

General  Summary  Statitics Contents  Custom

Tite:

Subject

Author:

Manager:

Company:

Category:

Keywords:

Comments:

Hyperink
base:

Template;

[ save Thumbnails for AllExcel Documents





image295.png
otTable Fields

Choose fields:

Drag flds betwen areas below:
¥ FuTERs I couumns

3 vawes
Sum of Nt Prfit

i





image296.png
Row Labels

EMA
East Natchitoches
Lyon
Warner
‘Willow Run

EME
Augusta
Conyersville
Mount Baker

ENH
Farmington Lake
Martins Comner
Pickerel Narrows
Willaha

BN
Center
Spring City

ENY
Coltman
East Waterford
Mittenlane

BRIl
1

Sheet1 Financial Data

|sum of Net Profit

589539
327291
62728
54860
144560
421956
215519
56560
149877
711145
3202743
240690
138988
27728
476016
127859
248157
551381
368460
114033
6388
1002980

Financial Scorecard

a

PivotTable Fields

Choose fields:

ity
@ State

offce Type
Operating
@ Operating Profi.
Depreciation
) Net Profit

Drag feds betueen sress below:

W FILTERS = coLumns
0l Rows 3 VALUES
State « | Sum of Net Profit
aity .




image297.png
otTable Fields

Choose fields:

Drag flds between areas below:

¥ FuTERs 1 couumms

ol

3 vawes
State - Sumof Net rofit




image298.png
|Sum of Net Profit Icolumn Labels  [~]

Row Labels [~]co-owned Corporate _Franchise _Grand Total
EMA 62728 199420 327391 589539
East Natchitoches 327391 327391
Lyon 62728 62728
Warner 54360 54860
‘Willow Run 144560 144560
EME 365396 56560 421956
Augusta 215519 215519
Conyersville 56560 56560
Mount Baker 149877 149877
ENH 166712 544433 711145
Farmington Lake 303743 303743
Martins Comner 24069 240690
Pickerel Narrows 138988 138988
Willaha 7724 27724
BN 348157 127859 476016
Center 127859 127859
Spring City 248157 248157
ENY 68333 368460 114033 551381
Coltman 368460 368460
East Waterford 114033 114033
Mittenlane 68888 68888

Sheet1 Financial Data

Financial Scorecard

PivotTable Fields

Choose fields:

@ ity
“ State

|9/ Office Type

0 Revenes
© Operating b
© Operating Prof
@ Depre
Net Profit

Drag feds betueen sress below:

W FILTERS

0l Rows.
State

aity

= coLumns
Offce Type

3 VALUES
Sum of Net Profit




image299.png
@ oW

10
1
2
3
i
5
6
7
8
19

A 8 c
Row Labels ~sumofa1 sumofa2
+ Africa 1110315 1077787
' America 1 1916369 2089725
- Asia 3287977 2632497
Bangkok 772578 1030012
Haley Dartan 395150 413390
Tucky Habishaw 210085 139985
Wanda Ratlee: 167342 476637

= Manila 2515399 1602485
Burton Wreath 170305 153945
Delainey Mont 86315 184778
Ebonee Louch 220551 115951

Hardy Eyckel 493688 285903

Joy Liddyard 140480 340217
Robert Balnaves 255105 134865
RodgerCampany 467602 266613
Siivano Estable s72755 120213




image300.png
~olals wn -

Row Labels ~sumofa1 sumofa2
+ Africa 1110315 1077787

' America 1 1016369 2080725

Asia 3287977 2632497
i — 3180113 3175154




image301.png
A 3 c
Row Labels []sumofa1 sumofaz
- Afrca 10315 1077787
- America | 1916369 2089725
- Asia 287977 2632097
[= Europe] simous  s1zsis

[ bon] 1sss70 1310636

Cody Luton
syivan eshmade

Drake Becom
Erica Busse:
Nes Sollars

Calvin Fretbere
Hercules Amon
‘Grand Total

114380 380264
218205 277488
asa1s 379522
ase7es 273361

1372569 1121302
473495 286897
sa11s 134202
169705 281265
sss2se 418938
631172 743216
220863 255684
aoss1l 487532

9503774 8975163

PivotTable Fields

Choose ields:

Full Name
Region
Sub-Region
a

@

O

Do

Drag flds betwen areas below

FLTERS coLumns.
Values

VALES.
- sumora
Sumor2

i





image302.png
@~ o e

9
10
1
2
3
i
5
6
7
8
19
20
21

Row Labels lsum of a1 sum of 2

+ Africa (& Refresn
wAmerica | [ e
# Asia
Europe
= Lisbon
Alethea Winyard
Cody Luton

Syivan eshmade
Tally Leppington
= Moscow
Christopher Fleis
Drake Becom
Erica Busse
Neal Solars
= Warsaw
Galvin Freiberg
Hercules Almon
Grand Total

e

3189113
1185370
114380
218203
415618
436769
1372569
473496
341113
169706
388250
631174
222863
408311
9503774

1077787
2089725
2632097
3175154
1310636

380264
277489
379522
273361
1121302
286897
134202
281265
418938
743216
255684
487532
8975163




image303.png
@~ o e

9
10
1
2
3
i
5
6
7
8
19
20
21

A c
Row Labels ~|[sum of a1 Jsum of 2
# Africa Ti0s15 107778

 America 1916369 2089725

# Asia 3287977 2632497

= Europe 3189113 3175154

= Lisbon 1185370 1310636

AletheaWinyard 114980 380264

Cody Luton 218205 277488

Syivan eshmade asa1s 379522

Tally Leppington 436760 273361

= Moscow 1372569 1121302

ChristopherFleis 47349 286897

Drake Becom sa11s 134202

Erica Busse 169705 281265

Neal Solars sss2se 418938

= Warsaw 631172 743216

Galvin Freiberg 222863 255684

Hercules Almon aoss1l 487532

‘Grand Total 9503774 8975163




image304.png
<«

FLE

f

2

a ‘ [0 Sales Dataxisx

- O @

HOME  INSIRT = DATA

EE E

Function  Forms Tale PuofTavie  Pictre

><‘+

REVIEW

acmewidgets-my.sharepoint.com,

~

alfjsmith_acmy m

VIEW  Q Tellme what you vant to do EDITIN EXCEL

M= w0 @ D

Shapes  Office Comn Line FPie Bar Area Scaiter Other | Hyperink Comment

. - Adgis - - - - - - Chas-
Funcions Taes lusstons | Adins Crans Une Commenss
£ 1110315
A c D £ F G H ) K L
1
2
3
4
5
6 3287977 2632497
7 3189113 3175154
8 | Alsbon 1185370 1310636
9 AletheaWinyard 114980 380264
10 Cody Luton 218203 277489
1 Syivan Eshmade a1sa18 379522
2 TallyLeppington 436769 273361 Excel
13| = Moscow 1372569 1121302
1 GremiE | GEs  mEm Cannot change celsin  PvotTable resort.
5 Drake Becom 341113 13020 Give Feedback
16 Erica Busse 169705 281265
7 Neal Sollars 3ss2se 418938 oK
18| = Warsaw 174 743216
19 Galvin Freiberg 222863 255684
20 Hercules Almon 408311 487532
21 |GrandTotal 9503774 8975163
2

PivotTable Fields

Choose fields:

Full Name
Region
Sub-Region
a

Oa
Do

Drag flds between areas below:

T FuTeRs 11 couumns
Values





image20.png
Activity 1-1 Properties

General  Summary  Statitics Contents  Custom

Tite: Sales Goals and Bonus Report

Subject:
Author:
Manager:
Company:
Category:
Keywords:

Comments:

Hyperink
base:
Template;

[ save Thumbnails for AllExcel Documents





image305.png
FIE  HOME INSERT  DATA

L BE

g Ld

REVIEW ~ VIEW  Q Tell me what you want to do.

kDSl B @

Functon | Forms Table PhotTable
! T asains -
Funcions Tabes Wrssons | Acens
% 077787
A 3 c )
1
2
5 Rowtabels [“]sumofQ1 sumofaz
4 1077787
5« America 1916369 2089725
5 losa 287977 2632097
7 = Europe simous  s1zsis
8 | - Lisbon 1sss70 1310636
9 MetheaWinyard 114380 380263
10 CodyLuton 2803 277489
7 Syhaneshmade 415418 379522
2 Tallyleppington 436768 273361
3| = Moscow 1572569 1121302
14 Christopher s 473495 286897
15 Drake Becom sans 130
16 rica Busse 169706 281265
7w NealSollars see2ss 418938
8| = Warsaw 7 7326
19 Galin Freiberg amses  2ssess
2 Hercules Almon 408311 487532
21 Grand Total 950377 8975163
2
2
2%
2
2%
2
2
2
30
31
2
3
3
35
36
7

SalesChart | _Sheet! | Data

EDITIN EXCEL

- T s
Crans Lnks

D

Picture Shapes  Office  Coumn Line Ple Bar Area Scafter Other  Hyperink  Comment

Commens

PivotTable Fields

Choose ields:

Full Name
Region
Sub-Region
a

@

O

Do

omgs  Move Down

Teu
Move to End

T Move to Report iter
Move to Row Labels

1l Moveto Column Labels:

Remove Field

Region

Full Name. -

[
e

HELP IMPROVE OFFICE





image306.png
Value Field Settings x

Source Name: Q1

Custom Name: [ Sae]

SUMMARIZE VALUE BY SHOW VALUE AS

‘Summarize value field by
Choose the type of calculation that you want o use to summarize:
data from the selected field

[ [ [ enm





image307.png
FILE HOME  INSERT ~ DATA  REVEW VIEW  Q Tellmewhat you want to do EDITIN EXCEL
= < D A - =N
FEEE GO 8 kI W0 @
ot | e e, Pkl | e s | Ot | o e, P G A S Ot |
A meis | e .
fe 1077787
. s pmesm o f e w1l
.
.
[ P o
5 T
: e
: e
; ]
o [ e
5| ket st ss0en
W] comen i e
| owmtimaie  sovis  soss
2| T s e
trn [ s 112100
1] vt oo ey
B v i v
V] e s
] v oiine e
1o Memnrees o s
0| e ooy
> [ G o
B
:
.
:
:
=
B
-
3
H
B
:
B
:
:
s
.
SalesChart | _Sheet1 | Data ®

PivotTable Fields x

Choose ields:

Full Name
Region
Sub-Region
a

@

O

Do

Drag flds betwen areas below

T FuTeRs I couumns
Values -

= rows
Region .
Sub-Region -
Full Name. -

- HEWIMPROVE OFRCE





image308.png
o AW o

Row Labels [] Q1 Sales Sum of Q2
'+ Africa

America 1916369 2089725
# Asia 3287977 2632497
# Europe 3189113 3175154

GrandTotal 9503774 8975163




image309.png
PivotTable Fields x

Choose fields:

Full Name
Region
Sub-Region
a

@

O

Do

Move Up
omgs  Move Down
Move to Beginning

TR

Move to End -
T MovetoReportFiter
Move to Row Labels

1l Move to Column Labes
Move to Values

Remove Fied

I N

- Sumor@z B





image310.png
Value Field Settings x

Source Name: Q1

‘Custom Name: Q1 Soles

SUMMARIZE VALUE BY. SHOW VALUE AS

‘Summarize value field by
Choose the type of calcul
data from the selected field

ion that you wanit to use to summarize

[ o [





image311.png
@~ o e

mof Q2

+ Africa

370105

1077787

319394.8333
2632097

 America
# Asia
# Europe

208907
3189113

2089725

3175154

316792 4667

‘Grand Total

8975163




image312.png
Value Field Settings x
Source Name: Q1

Custom Name: [Average of Q1

SUMMARIZE VALUE BY 'SHOW VALUE AS

‘Show value as

9% of Grand Total
9% of Column Total

9% of Row Total

2% of

9% of Parent Row Total

9% of Parent Column Total
9% of Parent Total
Difference From

9% Diference From
[Running Total In

% Running Total In

[Rank Smallest to Largest

[Rank Largest to Smallest
[index





image313.png
File Home Insert Data  Review  View Tell me what you wanttodo ~ Open in Excel & Share  §J Comments
L [Am Cattoi BRI 2 irepTen General B D B E S 57 O
T Copy -
Pasts BIUD Merge & Center « | § + <8 3 Condional Format  Insert Delete Format > (iep. SOt Find&
27 S Format Painter v o $-% 0 WK o e, o PERT @ Fiter  Select ~

Undo Cipboara Font
nsly -] £ warner
A B c D E
1
2
3 sum of Net Profit Column Labels  [~]
4 Rowlabels []co-Owned Corporate _Franchise Grand Total
ERETTY 62728 199420 327391 589539
6 East Natchitoches 327391 327391
7 Lyon 62728 62728
8 Warner 54860 54860
9 ‘Willow Run 144560 144560
0 EME 36539 56560 421956
N Avgusta 215519 215519
12 Conyersville 56560 56560
13 Mount Baker 149277 149877
14 =NH 166712 544433 711145
15 Farmington Lake 303743 303743
16 | Martins Corner 24065 240650
17 Pickerel Narrows 138988 138988
18 Willaha 27724 27724
=L 348157 127859 476016
20 | Center 127859 127859
21 | springCity 348157 348157
22 |ony 68388 368460 114033 551381
23 Coltman 368460 368460
24 East Waterford 114033 114033
25 Mittenlane. 68888 68888

Sheet1 Financial Data

Financial Scorecard

Tables

PivotTable Fields

Choose fields:

@ ity
@ State
) Office Type

© Operating Prof
© Deprecation
) Net Profit

Drag feds betueen sress below:

W FILTERS = coLumns
Offce Type

0l Rows 3 VALUES

State « | Sum of Net Profit

aity .




image314.png
1
2

S SumofNetProfit  Columnlabels [<]

4 |Row Labels [lco-owned CorporateFranchise [Grand Total
s loma cmm 1000 s sassa
o ome 3539 5630 a210se
[T 166712 Seaazs 711145
& 7 ramingiontake so37e3 303743
9 | Martinscomer 200690 24069
10| pikerelNarrows 138088 138988
0 wisha s 27724
2 am samis7 1270 ar6016
B Center 127859 127859
4 spngcy sa1s7 sag157
(e Gomss  sesie0 114033 ssusmn
16| Cotman 368460 368460
7 Eastwaterford 03 1403
8 mitentane casss sasss
9 am saes27 soas3 1002080
20 Emerson seas3 seass
21| Hebron suaass 514449
2| Longiew 2570 278370
3| scotsile 353708 ss3708

24 GrandTotal 1593012 1061135 1098870 3753017




image21.png
Activity 1-1 Properties
General  Summary  Statitics Contents  Custom

Tite: Sales Goals and Bonus Report
Subject

Author: | John Smith]

Manager:
Company:
Category:
Keywords:

Comments:

Hyperink
base:
Template;

[ save Thumbnails for AllExcel Documents





image315.png
PivotTable Fields x

Choose fields:

Drag flds betwen areas below:
¥ FuTERs I couumns
Offce Type. -
Rows 5 vawes
State. -




image316.png
PivotTable Fields x

Choose fields:

Net Profit
Move Up
Move Down
Move to 8e

org e N
Move t

T A

T Moveto Report iter -
= Move to RowLabels
11 Move to Column Labets

Move o Values

Remove Field

Ve redsettngs gy

gy
& X




image317.png
Value Field Settings
Source Name: Net Proft

‘Custom Name: [Sum of Net Profit

SUMMARIZE VALUE BY SHOW VALUE AS

‘Summarize value field by
Choose the type of calculation that you want o use to summarize:
data from the selected field

[ o || e





image318.png
Value Field Settings
Source Name: Net Proft

Custom Name: [Average Net Profit

‘SUMMARIZE VALUE BY SHOW VALUE AS

‘Summarize value field by
Choose the type of calculation that you want o use to summarize:
data from the selected field

[ o || e





image319.png
Value Field Settings x

Source Name: Net Profit

‘Custom Name: | Average Net Profit

SUMMARIZE VALUE BY SHOW VALUE AS

‘Summarize value field by

Choose the type of calculation that you want o use to summarize:
data from the selected field

Sum =
|Count

IMin
Product

Number Format ok

Cancel





image320.png
@ 5 tessons -onedrive

5 Activity 6-22dsx

P
o iy ¥ = .
EB Copy.
Paste | Bl uop o
5 o 2
| s
Jx Average of Net Profit
A .

% ~

I+

£ https;//acmewidgets-my.sharepoint.com/sx/r/personal jsmi

ViEw @ Tellme what you vt todo EDTINEXCEL
EERIr Y General
H-o-A- $-% 0 W

Nmber
c ) 3 3 G

Sheet! | Financial Data

Financial Scorecard

\ acmewidgets_onmicrosoft com/ |

e

Conditoral Forms

Formatting -

Tabs

Format
asTable -

uts/15/dos

- o x
e [0 Y% | 92 £ 8 -
T N
o LRI )
It e fomst o (o Son Fra
e Fiter- Seect-
cas s -
L PivotTable Fields x
Choose fields: >
Gty
st
office Type
O Reverwes
[ Operating Expenses.
0 opeting ot
O Depreciation
Netpront
Org s e s bl
¥ fures 11 cowmms
o Tpe E
= > vauwes
e | hrage ot Netpr -
ay :
S —————





image321.png
Row tabels [~ Average of @1 Sumof @2

+ Africa Region Sort Ascending
[ America Suo-Region | £1 Sort Descending
 Asia
T ru Full Name Sort By Value...
GrandTotal  316792.4667

Label Fiters

Value Fitters

Fiter,





image322.png
Sort By Value (Region) x

Select value

[Average of Q1 ]

Sortoptions

© Smaliest to Largest

O Largest to Smallest
To change the selection press the up and down arrow

L]





image323.png
2
2
2
25
2
27
2
29
30
31

2

FLE  HOME  INSERT

= Format Painter

Cipboara

REVIEW

VIEW  Q Tellme what you vant to do

U p e -

s70105 1077787
s70105 1077787

Adda Elwood 43083 431629
Debra Godman a1gs79 171975
Ronald Burrss 247753 474183
America 5193948333 2089725
Toronto 3193948333 2089725
Aguste Fessier 420100 425263

Ash Jirousek sess12 382150
Gardy Howsley 420109 314733
Lucky Delouch 363379 440399
Rochette Shelley 108576 345601
Rosanna Skeermor 136593 181573
208907 2632497

257526 1030012

Haley Dartan 395150 413390
Tucky Habishaw 210085 130985
Wanda Ratlee: 167302 476637

= Manila 314424875 1602485
Burton Wreath 170505 153945
Delainey Mont 386315 184778
Ebonee Louch 226551 115951
Hardy Eyckel 93688 285903
Joy Liddyard 148480 330217
Robert Balnaves 255103 134865
Rodger Campany 467602 266613
Silvano Estable. 72755 120213
Europe 3189113 3175158
“Lisbon 2963425 1310636

| SaiesChat | sheett | Data

EDITIN EXCEL

e

Fommatting - - asTable
Tabs

— N
ES Sasosm - 87 O
It e fomst o (o Son Fra
e Fiter- Seect-
cas g -
*  PivotTable Fields x
Choose fields: >
Org s e s bl
¥ o 11 cowmms
Vi E
revelfy
= rows > vauwes
Regon Amora -
Scnegon Simoraz .
Pt

- HELIMPROVEOFRCE





image324.png
© o~ o v b w

A B c

Region (al) i

Row Labels ~] Average of Q1 Sumof Q2
= Bangkok 257526 1030012
Haley Dartan 395150 413390
Tucky Habishaw 210085 139985
Wanda Ratlee 167342 476637

Lisbon 2963425 1310636
Alethea Winard 114380 380264
Cody Luton 218203 277489




image22.png
Activity 1-1 Properties
General  Summary  Statitics Contents  Custom

Tite: Sales Goals and Bonus Report
Subject

Author: | John Smith

Manager:

Compny:  [36C widgets

Category:
Keywords:

Comments:

Hyperink
base:
Template;

[ save Thumbnails for AllExcel Documents





image325.png
Filter

Search Region

Select ftem:

(5] (setect an)
[ africa.

[ America
hsia
Europe





image326.png
1| Region (Muttiple tems)  [7]]

2

5 Rowtsbes  [“laversgeofal  sumofaz
4 - Bangkok 257526 1030012
S baleyDaran ss150 413350
6 Tucky Habishaw 210086 139985
7| Wandaatee i
& |auson 963425 1310636
9 | Alethea Winyard e
10 Cody Luton 218203 277489
T yvaneshmade s 379522
2 Taly Leppington sres 27t
73 - Maniia s10a2as7s 1602485
14 Bunonwreth 1005 153845
5 elameyhont sasmis  se77e
16| Eboncelouch st asest
7 HordyEvckel aosess 285503
B soyuddyrs a0 30217
19| RobertBalnaves e
20 Rodgercampany sorson 26613
21| sivanostable srss a0
22 | Moscow samaz2s 1z
23| chstopherfies 72035 280097
26| DrakeBecom P
35| Ercasusse 160706 281265
% Nealsolars [
27 = Warsaw swssw7 7amie
28 | Galvinfretberg e —
29 | Hercues Amon somssersn

30 Grand Total 3084328571 SB07651




image327.png
© |~ v & w0

10
1
12

Row Labels ~|averageofQ1 sumofaz

oA
= Nairobi
Adda Elwood

| osbrecotman

Ronald Burrss
America
“Toronto
Aguste Fessier
Aash sirousek

Region 'I}N Sort Ascending
Sub-Region *$EL Sort Descending
FulName Sort By Value..
247753
519394.8333 Label Fiters
319394.8333
429200
368612





image328.png
£l

F

Sort Ascending.
Sort Descending
Sort By Value.

Label Fitters

vseries B

Fiter.

Equal..

Does Not Equal..
Begins With.

Does Not Begin With..
Encs Wit

Does Not End With..
Contains..

Does Not Contain..
Greater Than..

Greater Than Or Equal To..
Less Than..

Less Than Or Equal To..
Betueen..
Not Between..




image329.png
# Sort Ascending
&l sort Descending
Sort 8y Value..

Label Fiters .

Value Fitters:

Fiter. equats..
Does Not Eaua..

Greater Tran..

Greater Than Or Equal To..

Less Than..
Lss Than Or Equel To.
Setueen..

Not Betueen.

Top 10.




image330.png
Custom Filter

Show items where: Region

erage o1at =
T — |





image331.png
© e e N o

1
12

Row Labels

Asia

= Bangkok
Haley Dartan
Tucky Habishaw
Wanda Ratlee:

= Manila
Burton Wreath
Delainey Mont
Ebonee Louch

/) Regin
Sub-region +

FulName

167382
314424875
17005
386315
228551

2

A

%

laverage of Q1 sum of a2

Sort Ascending
Sort Descencing

Sort 8y Valve

oo s fom ein |\
LabelFtters

Value Fiters g

Fiter.




image332.png
Drag filds between areas below:

¥ FuTeRs

Full Name.

11 couumns

Move Up
Move Down
Move to Beginning

Move to End

Move to Report Fiter

Move to Row Labels
Move to Column Labels:
Move to Values

Remove Field





image333.png
File Home Insert Data  Review  View Tell me what you wanttodo ~ Open in Excel & Share  §J Comments
i} [?QE“' Calibri e 2 Wiop Text Currency - B OB BRE sasee by O
= EF"W o BT U cgenComer s §- % 9 W Cordon Fomt | it Dot Fomst Q. SoR& Fron
N ormat Painter ormating v asTale v+ v~ ter « Select +
Undo Cipboara Font dtng
2 1 *| & GrandTotal
& B c B E PivotTable Fields x
g “ Choose fields:
2 v
3 Average of NetProfit  Column Labels [~] @ city
State
4 [Row Labels [~]co-Owned Corporate _ Franchise [Grand Total | @ otfiee Type
5 mMA 62728 99710 327391 14738475 B Revenues
5 182698 56560 140652 Operating
7 83356 2722165  177786.25 Operating Prof
s 38157 127859 238008 Deprecation
B 68388 368060 114033 183793.6667 @ NetProfit
0 @RI 315509 56453 250745
11 Grand Total 1991265 1768558333 183145 18765085
12
13
B Drag fields between areas below:
15
T FLTERS 2 cowmns
1 Office Type .
7
18
19
20
B 0l rows 3 vawes
» Sate «| Average of Net Proft
2 aty .
2

25





image334.png
PivotTable Fields x

Choose fields:

Drag flds betwen areas below:

¥ FuteRs 1 couumms

oy Offce Type. .

= rows 3 vawEs
State - | Average of Netprofi -
iy .




image23.png
Activity 1-1 Properties
General  Summary  Statitics Contents  Custom

Tite: Sales Goals and Bonus Report
Subject

Author: | John Smith

Manager:

Company: [ABC Widgets

Category: [sales and Bonuses]

Keywords:

Comments:

Hyperink
base:
Template;

[ save Thumbnails for AllExcel Documents





image335.png
= ‘ 5 Lesson 6 - OneDrive Activity 6-3xsx X |+ v - o x
& > 0 @ B https://acmewidgets-my.sharepoint.com/sx:/r/personal/jsmith_acmewidgets_onmicrosoft_com/ layouts/15/do ourc: Y = 7. -
FLE  HOME INSERT ~DATA REVEW VIEW Q Tell mewhatyouwanttodo EDITIN EXCEL

& X cut @ e
o B ‘T': b Caliori General - E EE O ESE a8y O

paste o P 1 §-% o G 4§ Condtional Foms Format isert Delete Fomat @ Ceyr.  Sot& Find’

- Fomat Painter fomatting- - aTabe- - - - Fiter - Seect-
Unco Cibosra Nt Tt coie g ~
£ RowLabels

A : < ° £ Fle | w L <L pivotTable Fields x
1 fomeeTine Cloase fickis >
3 |Rowlabels [~ |average of Net Profit aty
4 ema state
5 sME 5 oree e
LML [0 persing Eomnses
L] ] OperatingPrfit
e 1857936667 [ oeprciton
9 sm 250745 Net Profit
10 Grand Total 18765085
il
2
3
i
s
16
il
- Orag i s o
19 ¥ AuteRs I coumns
» OffcaType -
21
2
2
2%
2
% = = vawes
> e | ettt -
28
2
0
Bl v
< >
| Shect1 |Imeee ol I s @

https:/excelofficeapps.ive.com// layouts/iiewerinternal aspxui=en-USBirs=en-USBWWOPISre=https%3a%26) L e weoorce





image336.png
Filter
Search Ofice Type »
Select ftem:

] (select A1)
O Co-Onned
Corporate
[ Franchise:

ox L}J Cancel





image337.png
@~ o v b w e

A [

office Type _[corporate
Row Labels [~] Average of Net Profit

o MA 99710
# ME 182698
N 127859
ANy 368460

Grand Total 1768558333




image338.png
@~ o v b w e

A [

office Type _[corporate

Row Labels [ 7] Average of Net Profit

o MA 99710
# ME 182698
N 127859
ANy 368460

Grand Total 1768558333




image339.png
A

OfficeType __Corporate. =

Row Labels [~ [Average of Net Profit

o MA
# ME
N
ANy
‘Grand Total

State
city

2

2

Sort Ascending
Sort Descencing
Sort 8y Value..

Label Fiters
Value Fitters

Fiter.




image340.png
Sort By Value (State) x

Select value

Average of Net Profit

Sortoptions
Q smaliesttolaregt

(© targest to smalest]

TG dhange the seiection press the up and down arrow,

ox 'Xl Cancel





image341.png
@~ o e

A [

OfficeType __Corporate. =
Row Labes [~ [Average of Net Profit_|

Ny 368460
# ME 182698
N 127859
o MA 99710

‘Grand Total 1768558333




image342.png
<company>
<employee>
<name> Bob </name>
<fengloyee
Zemployee>
<name> Ji11 </name>
</employee>
</company>




image343.png
Home Inset  Pagelsyout Formulss  Data Deveioper R

\J E\ JPemrdMa(m a &:& D =Hl.T [=] Properties [@ 5 Import

se Relative References &) View Code 13 Brpansion Packs
Visual Mamr Add-  Excel COM Insert & Source e

Basic 4 Macro Security s Addins Addeins - runDiseo | NG
Code Addins Controls ML





image344.png
XML Source ¥ %
XMLmaps in this workbook:
‘company_Map -

£ company
©-{& employee

& name.

To map elements, drag the.
elements from the tree onto your
worksheet.

Options + | | XML Maps.

Verify Map for Export...

@ s for mapping XL




image24.png
Activity 1-1 Properties ?
General  Summary  Statitics Contents  Custom

Te: |Sales Goals and Borws Report
Subject:
Author: [ John Smith

Company: [ ABC Widgets

Category: | Sales and Bonuses.

Keywords: [ Sales Goals, Bonus, Bonuses, Sales

Hyperink
base:

Template;

[ save Thumbnais for Al Excel Documents:





image345.png
XML Source ¥ %

XML maps in this workbook:
company_Map





image346.png
XML Maps.

Preliew Data in Task Pane
Hide Help Text in the Task Pane

B Automatcally Merge Elements When Mapping
Bl My Data Has Headings





image347.png
XML Maps

XMLmaps in this workbook:

Name Root Namespace
company_Map company  <No Namespace>

Rename. Ada. peete | [0K

Cancel





image348.png
XML Maps

XMLmaps in this workbook:

Name

npany_Map

Root

Namespace
No Namespa

Rename.

Delete hl

ok

Cancel





image349.png
Microsoft Excel X

D\ you it s ma,you wit o tonerbe ai 0 mport o xprt Xt usin s X

ok ] [oncer





image350.png
Home et Pagelayout Formuas  Data PRI O el mewhat you want &

\J E\ JPemrdMa(m a &:& D =Hl.T [=] Properties [@ 5 Import

s Reltive References &3 View Code 13 Bxpansion Packs B}, Bport
Visual Mamr Add-  Excel COM Insert & Source e a

Basic & Macro Security ins  Add-ins Add-ins  ~

Code Add-ins Controls XML

Run Dialog





image351.png
N[«




image352.png




image353.png




image354.png
85 o .

Fle  Home et Pagelsyout Formulss  Data Deveioper R

\J E\ JPemrdMa(m a &:& D =Hl.T [=] Properties [@ 7 mport

s Reltive References &3 View Code 13 Bxpansion Packs B} Bport
Visual Mamr Add-  Excel COM Insert & Source e a

Basic & Macro Security ins  Add-ins Add-ins  ~

Code Add-ins Controls XML

Run Dialog





image25.png
Activity 1-1 Properties ?

General | Summary | Statistics Contents | Custom

Tite:

Subject:
Author:

Hyperink
base:

Template;

Sales Goals and Bonus Report

[John Smith

(ABC Widgets

Sales and Boruses.

sles Gosls, Bons, Bonuses, Sales

[ save Thumbnais for Al Excel Documents:

ok ] [ cance





image355.png
3 import XML
€ v E THEPC > Deskop

Organize v New folder

# Quick access. Name Date modified

Type

vo

Size

Search Desktop

[ company 25720161238 PM

= Deskeop

XML Document

KB

3 Downloads
Documents
= pictures

LY

B Microsoft Bxcel

7 OneDiive

This PC

Local Disk (C)

& Network

+4& Homegroup

File name: |company.

| [ XML Fites

Tools

- Import &





image356.png
Microsoft Excel [

The specified XML source does not refer to a schema. Excel will create.
a2 5chema based on the XML source data.

[ inthe future, do not show this message.

T Help





image357.png
Import Date 70X
Where do you want to put the data?
(@ XML table in existing worksheet:
sast
O XML table in new worksheet

Propertes. oK [ Cancel





image358.png
85 o .

Fle  Home et Pagelsyout Formulss  Data Deveioper R

T Record Macro B[] | |/ Epoperic import
HEW e Relative References g ge‘ g :1 & View Code L%E:jsxpanmm:

Basic 4 Macro Security s Addins Addeins - Run Dislog

- e Contros N -





image359.png
ES

Fle  Home Inset  Pagelayout  Formulas View  Developer

@ [ (Bl f, T | [y D Comecions

o E From Table [ Properties

From From From FromOther  Bisting  New Refresh

Access Web Text | Sourcesw | Connections | Query~ Lo Recent Sources | - [3 Edit Links
Get From SQL Server

Create a connection to a SQL Server table. Import data into Excel 25 2

Table or PivotTable report.

From Analysis Services

Create a connection to a SQL Server Analysis Services cube. Import data

into Excel as a Table o PivotTable report.

From Windows Azure Marketplace

Create a connection to a Microsoft Windows Azure DataMarket Feed.

Import data into Excel a5 2 Table or PivotTable report.

From OData Data Feed

Create a connection to an OData Data Feed. Import data into Excel a5 2

Table or PivotTable report.

From XML Data Import

Open or map a XML file into Excel.

B o) o7

From Data Connection Wizard I}

gt o e ot by vin Dt Cnnection i
izt

From oot auery

It or s e ot by usin theicrosf ey Wi
et o o e oty g e el Gusn ard

& & [md| b’




image360.png
31 Select Data Source:

<« © 4 B> ThisPC > Deskiop >

Organize v New folder

s Quick access
I Desicop
3 Downloads

Documents

LY

= Pictures
B Microsoft Bxcel

7 OneDiive

This PC

Local Disk (C)

& Network

+4& Homegroup

Name

Date modified

Type

vio

Size

Search Desktop

E

[ company

2/5/2016 1238 PM

XML Document

KB

New Source...

o @

File name: |company.

Tools





image361.png
Microsoft Excel [

The specified XML source does not refer to a schema. Excel will create.
a2 5chema based on the XML source data.

[ inthe future, do not show this message.

ok i Help





image362.png
Import Data T
Where do you want to put the data”
(@ XML table in existing worksheet:
sasil
isting worksheet:

[¢]

=sast
O New worksheet

‘Add this data to the Data Model

Propertes. oK i Cancel





image363.png
85 o .

Fle  Home et Pagelsyout Formulss  Data Deveioper R

T Record Macro B[] | |/ Epoperic import
HEW e Relative References g ge‘ g :1 & View Code L%E:jsxpanmm:

Basic 4 Macro Security s Addins Addeins - funDicog | [N
Code Addins Controls ML




image364.png
85 o .

Fle  Home et Pagelsyout Formulss  Data Deveioper R

\J E\ JPemrdMa(m a &:& D =Hl.T [=] Properties [@ 5 Import

s Reltive References &3 View Code 12 Bxpansion Packs [EJEAROR
Visual Mamr Add-  Excel COM Insert & Source e R

Basic & Macro Security ins  Add-ins Add-ins  ~

Code Add-ins Controls XML

Run Dialog





image26.png
Acvity 11 - xce - aaflEl
Johm St

Info

Activity 1-1

Desktop » MOSS003_Excel_2016_3_ExerciseFiles » Starting Files for Activties » Lesson 1

B Protect Workbook Properties ~
» Control what types of changes people can make to this workbook. Size 1.0kB
Protect
e Title Sales Goals and Bonus Report
Tags Sales Gosls, Bonus, Bonuses.
Categories Sales and Bonuses
@ Inspect Workbook Related Dates
Before publishing this fil, be aware that it contains:
Checkfor Document properties and author's name. LastModified  11/14/201412:20 AM
fasues Content that people ith disabiltiesfind ifficult to read Created 9/15/2006 900 PM
Asetting that automatically removes properties and personal information when Last Prnted

thefile s saved
Allow this information to be saved in your file

Related People

Author
John Smith
ﬁ Manage Workbook
Q Checkin,check out, and recover unsaved changes Add an author
A Manage ere are no unsaved changes. Last Modified By Not saved ye
Worbak- | 2 ™ < chang; 5 Notsaved yet
s Related Documents
Feedback & Browser View Options [} Open File Location
L@ Pick what users can see when this workbook is viewed on the Web. Show All Properties
Browser View

Options





image365.png
3 Export XML

A B> ThisPC » LocalDisk (C:) » Users > abewi > Desktop > v|®| | Search Desktop

Organize v New folder

# Quickaccess Name Date modified Type Size

B Desktop  # [ company 2/5/20161238PM XML Document 1K

& Downloads #
Documents #
Epiures 4

B Microsoft Bxcel

7 OneDiive

This PC
‘i Local Disk ()

& Network v

File name: | example|

Save astype: | XML Files

Authors: John Smith Tags: Addatag Title: Add atitle

A Hide Folders Tools ~ WL}J Cancel





image366.png
& Activity 6-1 - Excel = o

Inset  Pagelayout Fomulas  Data  Review  View  Developer  Q Tellmewhatyouwantt JohnSmith £, Share

iy o Catbr “[n B Wrap Tt General - £ [ Normal Bad Good ewsl || &= [ff) Zawosm - A O

B3 Copy - [ Fin-

Merge & Center - § - % » %3 g5 Conditional Formatas | Calculation Check Cell Explanatory _ | Insert Delete Format & i~ Sort & Find &

Fiter~ Select +

Formatting - Table~ -
& Number & Styles cells Editing “

Clipboard r. Font

Al ~ | £ v

Sheetl | Sheetz | sheets | @ i [ o)





image367.png
s Activity 6-1 - Excel

Home et Pagelayout Formuas  Data Deveioper IR

\J E\ JPemrdMa(m a &:& D =Hl.T [=] Properties [@ @?\ygm

< Relative References & View Code 2 Expansion Packs
Visual Mamr Add-  Excel COM Insert < Source e

Basic & Macro Security ins  Add-ins Add-ins  ~

Code Add-ins Controls XML

Run Dialog





image368.png
[ Import XML X

©  « 4 |[] <« Starting il for Acttes > Lesson [0 [ SeachLesson6 »

Organize v New folder

# Quickaccess Name Date modified Type Size

1B Desktop
& Downloads
Documents
= Pictures

[ Activiy 614 W/17/2013619AM XML Document T

LR SO

B Microsoft Bxcel

7 OneDiive

This PC

Local Disk (C)

& Network

+4& Homegroup

File name: [ Activity 6-1A | [ XML Fites v

Tools + Import ,:l Cancel





image369.png
Microsoft Excel [

The specified XML source does not refer to a schema. Excel will create.
a2 5chema based on the XML source data.

[ inthe future, do not show this message.

ok [ Help





image370.png
Import Data T
Where do you want to put the data”
(@ XML table in existing worksheet:
sasil
O XML table in new worksheet

Propertes. oK i Cancel





image371.png
s Activity 6-1 - Excel

Home et Pagelajout Formubs  Data  Review  View [JINEESEN O Tellmewhtyouwanttodo

ecord Macro a .u_n ‘/‘ [=] Properties @

R Mep Propertes (R Import

==L [ Use Reltive References &3 View Code 2 Expansion Pads B, Export
Ve s Add- Bl COM | Insert Design s
Basic A Macro Security ins  Add-ins Add-ins -~  Mode [3]RunDialog 1 Refresh Data
@ e s s
AL v i3 1574
AlsicD | E | F| G ' | ) |[K|L[M[N| o [P[Q|R 5 | T UV MW X | Y |

1574 2.99 5 14.95 Warehouse A 2358 339.99 5 1999.95 Warehouse B 1478 049 1587 777.63 Warehouse B 2358 399.99 54 21599.46 Warehouse A 2358 399.99 9 3599.91 Warehouse A

oo s w
i il ol el




image372.png
ES

Fle  Home Inset Pagelayout  Formulas  Data Developer

O‘)j E\ #7Record Macro a .u_n il' /" [ properties [@ [ Map Properties [ Import
L[5 Use Reltive References i &3 View Code 2 Expansion Padks B, Export
Visual Macros Add- Bcel COM  Insett Design Source
Basic A Macro Security ins  Add-ins Add-ins -~  Mode [3]RunDialog 1 Refresh Data
Code Add-ins Controls L
A2 - fo
AlBidDb | € |F| G mH 1 | 1 |[k[L/M|N| o |Pp|a

[ 78] 298 5 14.95 warehouse A 2358 399.99 5 1999.95 Warehouse B 1478 0.49 1587 777.63 Warehouse B 2358 399.99

1
4 -
3
4




image373.png
85 o .

Fle  Home Inset Pagelayos  Formulas  Data  Review Deveioper R

\J E\ JPemrdMa(m a &:& D =Hl.T [=] Properties [@ 5 Import

s Reltive References &3 View Code 12 Bxpansion Packs [EYBiROR
Visual Mamr Add-  Excel COM Insert & Source e R

Basic & Macro Security ins  Add-ins Add-ins  ~

Code Add-ins Controls XML

Run Dialog





image374.png
3 Export XML

2 [ « Completed Actities » Lesson & [0 [ SeachLesson6

Organize v New folder

# Quickaccess Name Date modified Type Size

M Desktop No tems match your search
& Downloads #
Documents #
[ Pictures

B Microsoft Bxcel

7 OneDiive

This PC
‘i Local Disk ()

& Network v

File name: [ Actvity 6-1A Complete

Save astype: | XML Files

Authors: John Smith Tags: Addatag Title: Add atitle

~ Hide Folders Tools ~ mhj Cancel





image27.png
Book! - Excel

Home Inset  Pagelsjout  Formuss  Data Review Q Tell me what you want t
= Dt [
EX e | Q [3 8 | 22 B 5
] i} LQ [} T Hide =
Normal Page Bresc Page Custom | (7] igines (V] Headings | Z00m 100% Zoomto  New Amange Freeze Suitch  Macros
Preview Layout Views Selection Window Al Panes - Windows = =

Workbook Views Show om Window





image375.png
Button1




image376.png




image377.png
[ CheckBox 3




image378.png




image379.png




image380.png
GroupBox 7

O checkBox3.
O checkBox 3.
O checkBox3.





image381.png




image382.png




image383.png
Bl =

Be e b Roslomr ot Bhn e PR O i e what you want tc
j E\ 27 Record Macro a {i? E =H|.T [=] Properties [@ 5 Import
Use Relative References &1 View Code S e
- Add- Bcel  COM | Insert & S
Basic 4 Macro Security s Add-ins Add-ins | IS Run Dizlog
Code Addins Form Controls
EMEE o
Aa B Gl

ActiveX Controls
O M EE 5
EHoaAREIL




image384.png
Button

w N -
\\‘




image28.png
Record Macro

Macro name:

Macrot|

Shortcut key:
ctrle

Store macro in:

This Workbook

Description:

oK

Cancel





image385.png




image386.png
Button15.





image387.png




image388.png
Format Control

?
Properties Margins. AltText
Fort Alignment size Protection

Font: Font style: size:

Calibri Regular 11

GalibriLight (Headings & 5

Halic s

Agency FB. Bold 10

Algerian Bold Htalic (I
arial 12

aral Black. 2 1 2
Underline: Color:

None | | —| 2 normai font
Effects Preview

[ strikethrough

O superscript calibri

O subscript

This is a TrueType font, The same font will be used on both your printer and

your screen.

=





image389.png
Bl =

Fle  Home et Pagelwout Fomulss  Dita  Review PR O el me what you want t

\J E\ JPemrdMa(m a &:& D =Hl.T EPmpemeb [:I 5 Import

< Relative References & View Col 2 Expansion Packs
Visual Mamr Add-  Excel COM Insert < Source Hee

Basic & Macro Security ins  Add-ins Add-ins  ~

Code Add-ins Controls XML

Run Dialog





image390.png




image391.png
Activity 6-2 - Bxcel

Fomulas  Data  Review  View Developer Tell mewhatyouwantts

“rj % cut Calbri B - BWepTet General B @'} Heading1 |Heading2 | Heading3 Headinga  |° &= ﬁ é:“““m Ay O

paste e atpainter [T Y- Merge & Center = § = % > | %8 £ ;C;::::;::‘;‘- me:.“ Title Total 20%-Accentl. | 20%-Accent2 | Insert Delete Format | ?T?Z,Ef Sr:ifi
Clipboara 5 Font 5 Aignment 5 Number stytes cels diting -

AL -] % || sk v

Y G H b |k [ L [ M| N o e | a | rR | s [T [ u | [E

1

2] 157 5 299 5 s 14.95 Warehouse A

3 2358 S 399.99 5 $  1,999.95 Warehouse B

4| 147 S o049 1587 S 777.63 WarehouseB

5| 28 s 39999 54 S 21599.46 Warehouse A

6| 147 S 12999 214 $ 2781785 WarehouseB

7] 1358 s a9 a5 S 2455 WarehouseA

8| 157 5 299 65 S 19435 WarehouseC

9 5167 $ 4250 45 $  1,912.50 Warehouse A

0] 238§ 399 ) S 3559911 WarehouseC

11| 1547 § 13458 8 $  1,076.64 Warehouse A

2| 235§ 56999 55 S 31,3945 Warehouse 8

B 167 s 14759 35 S 516565 WarehouseA

14| 1459 s 16.99 89 $ 151211 Warehouse B

15| 1478 S 045 84 S 41845 WarehouseA

16| 147§ 12995 475 $ 6174525 WarehouseA

7 a7 s sw 89 S 80011 WarehouseA

8] 34§ 75000 2 $ 1875000 Warehouse A

19 157§ 1mss 2 S 26916 Warehouse8

20| 1473 $ 0.49 4876 $  2,389.24 Warehouse B

21 358§ 3999 54 S 21599.46 Warehouse A

22| 147 S 12999 145 S 1884855 WarehouseB

23 1358 § 4 a5 S 2455 WarehouseA

24| 159 § 239 65 S 19435 WarehouseC

25| 5167 8 4250 45 $  1,912.50 Warehouse A

2| 2358 § 39999 %0 S 3599910 WarehouseC

27| 1547 $ 13458 8 $  1,076.64 Warehouse A

8| 235§ 50999 55 S 31,3945 Warehouse 8

9] 17§ 14759 35 S 516565 WarehouseA

30| 159§ 16.99 89 $ 151211 Warehouse B

31| 1478 S 049 87 S 4286 WarehouseA =

32| 147 S 1999 47 S 6122529 WarehouseA

B o s 8w 89 S 80011 WarehouseA -

Sheet3 ® [T o
Ready El 100%





image392.png
Bl =
File

=]

Visual Macros
Basic

Home Insert

#3Record Macro
[ Use Reltive References
& Mecrosecury

Code

Page Layout

Formulas

S S H

g N/ D properties
= b & View Code

Add- Excel COM |lnsett Design
ins  Add-ins Adc-ins | = Mode [3]RunDialog
Addins Form Controls

Bl o
f%a 3 &l

ActiveX Controls
[=15:] =zl
EHoaAREIL

Developer

Q Tell me what you want tc

ER Import
1) Bxpansion Packs

Source





image393.png
Drawing Tools Activity 62 - B Signin

Home mset Pagelsyout Formuas  Data Format  © Tell me what you want to

@ 7 Map Properties  [3 Import

L[5 Use Reltive References 11 2 2 view Code 2 Expansion Padks B, Export

Basic A Macro Security ins  Add-ins Add-ins Mode |3 Run Dialog [®1 Refresh Data

Button 1 - i3

4 F s H b |k | v | m | N[ o | p | @ | R | s [ T | u | 4

U U Qumiy Toulvae  toaten

2 1574 s 2.99 5 s 14.95 Warehouse A n Macro ? X

3 2358 $  399.99 5 $  1,999.95 Warehouse B Miscro name:

4 1478 s 0.49 1587 s 777.63 Warehouse B Tmm B 5 ‘ = ‘

5 2358 S 399.99 54 $  21,599.46 Warehouse A -

6| 17 s 12999 24 S 27,817.85 Warehouse8

7 1358 S 4.99 45 S 224.55 Warehouse A I}

8 1574 s 2.99 65 s 194.35 Warehouse C

9 5167 S 42.50 as $  1,912.50 Warehouse A

10 2358 s 399.99 89 $  35,599.11 Warehouse C

n 1547 S 134.58 8 $  1,076.64 Warehouse A

12 235 $ 569.99 55 $  31,349.45 Warehouse B

13 1567 S 147.59 35 $  5165.65 Warehouse A

16w S 16 8 S 150211 Werehoused Moz

15 1478 $ 0.49 854 S 418.46 Warehouse A Description

16 147 $ 129.99 475 $  61,745.25 Warehouse A

17 a7 S 8.99 89 S 800.11 Warehouse A

18 354 s 750.00 25 $  18,750.00 Warehouse A

Io| a7 5 sesa| 2 |$ 20516 warehouses

20 1478 s 0.49 4876 $  2,389.24 Warehouse B

21 2358 S 399.99 54 $  21,599.46 Warehouse A

22 147 s 129.99 145 $  18,848.55 Warehouse B

23 1358 S 4.99 45 S 224.55 Warehouse A

24 1574 s 2.99 65 s 194.35 Warehouse C

25 5167 S 42.50 as $  1,912.50 Warehouse A

26 2358 s 399.99 90 $  35,999.10 Warehouse C

27 1547 S 134.58 8 $  1,076.64 Warehouse A

28 235 $ 569.99 55 $  31,349.45 Warehouse B

29 1567 S 147.59 35 $  5165.65 Warehouse A

30 1459 s 16.99 89 $ 151211 Warehouse B

31 1478 S 0.49 874 S 428.26 Warehouse A u

32 147 $ 129.99 a7 $  61,225.29 Warehouse A

33 a7 $ 8.99 89 $ 800.11 Warehouse A -
Sheet3 €} i [ o)

Ready [::] 100%





image394.png
Assign Macro 70X

Macro name:

Delete

»
]

Macrosin: |All Open Workbooks

Description

o [ama |





image29.png
9 Microsolft Visual Basic for Applications - Book'xsx

Fle Edtt View Insert Format Debug Run Tools Add-ns Window Help

CHI Y BBRAYC ) 1 a R EEY 2O

ActiveCell.FormulaRiCl = "Jan"
Range ("B1") .Select
ActiveCell.FormulaRiCl = "Feb"
Range ("A1:B1") .Select
Selection.AutoFill Destination:=Range ("Al
Range ("A1:L1") .Select

£nd Sub

Immediate

Type:=x1FillDefaulc

EiRE

~| #y

Members of <globals>"
s abs

B ActiveCell

& ActiveChart

B ActivePrinter

I ActiveSheet

I ActiveWindow

& ActiveWorkbook

B Addins

BackstageGroupSleWaming

Beep

BroadcasiCapFileSizeLimited
BroadcastCapSupportsheetingNotes
BroadcasiCapSupportsUpdateDoc
BroadcastPaused

BroadcastStarted





image395.png
© N e W N

[ SKU  UnitPrice Quantity TotslVelue location |

1574 s 299 5 s 14.95 Warehouse A
2358 S 399.99 5 $  1,999.95 Warehouse B
1478 s 0.49 1587 s 777.63 Warehouse B
2358 S 39999 54 $  21593.46 Warehouse A
147 $ 12999 24 $  27,817.86 Warehouse B
1358 S 4.99 45 S 22455 Warehouse A
1574 s 299 65 s 194.35 Warehouse C
5167 S 42.50 as $  1,912.50 Warehouse A





image396.png
1
2 1574 s 299 5 s 14.95 Warehouse A
3 2358 S 399.99 5 $  1,999.95 Warehouse B
4 1478 s 0.49 1587 s 777.63 Warehouse B
5| 2358 5 399.99 54 $  21593.46 Warehouse A
6 147 $ 12999 24 $  27,817.86 Warehouse B
7 1358 S 4.99 45 S 22455 Warehouse A
8 1574 s 299 65 s 194.35 Warehouse C
9 5167 $ 4250 45 $  1,912.50 Warehouse A
10| 2358 S 399.99 $  35599.11 Warehouse C
11| 1547 S 13458 8 $  1,076.64 Warehouse A
12| 235§ 56999 55 $  31343.45 WarehouseB
13| 1567 S 14759 35 $  5,165.65 Warehouse A
14 158§ 16.99 $ 151211 Warehouse B
15| 1478 S 0.49 854 S 418.46 Warehouse A
6] 147 s 12999 a75 $ 6174525 Warehouse A
17 a7 $ 8.99 89 $ 800.11 Warehouse A

§Bun§r 3
% cu

iy Paste
EditText
Grouping ,
Oder »
Assign Macro.

%[m-uomu_h




image397.png
Format Control

?
Properties Margins ATt
Font Alignment Size Protection
Font: Font style: size
catiori Boldl u
Cambria (eadings ~| [Reguiar B
iaiic H
Agenq 7B 10
Algerian Bold talic (I
arial 12
il Black v 14
Underline: Color
None <] | 7| [ nomaitont
Eifeds

[ strikethrough
O superscript
O subscript

Preview

This is a TrueType font, The same font will be used on both your printer and

e

your screen.





image398.png
@ o w W

1574 s 299 5 s 14.95 Warehouse A
2358 S 399.99 5 $  1,999.95 Warehouse B
1478 s 0.49 1587 s 777.63 Warehouse B
2358 S 39999 54 $  21593.46 Warehouse A
147 $ 12999 24 $  27,817.86 Warehouse B
1358 S 4.99 45 S 22455 Warehouse A
1574 s 299 65 s 194.35 Warehouse C





image399.png
© N e W N o

| warehouse A

$ 5 $
2358 S 399.99 5 $  1,999.95 Warehouse B
147§ 043 1587 S 777.63 WarehouseB
25 S 3999 54 S 21599.46 Warehouse A
47 S 12999 24 $  27,817.86 Warehouse B
158 S 439 a5 $ 2455 WarehouseA
17 S 299 (3 $ 19435 WarehouseC
5167 S 42.50 as $  1,912.50 Warehouse A





image400.png
o m e w

1574 s 299 5 s 14.95 |Warehouse B
2358 S 399.99 5 $  1,999.95 Warehouse B
1478 s 0.49 1587 s 777.63 Warehouse A
2358 S 39999 54 $  21593.46 WarehouseB
147 S 129.99 214 $  27,817.86 Warehouse A





image30.png
9 Microsolft Visual Basic for Applications - Book2dsx

Fle Edt View lnsett Fomat Debug Run Tools Add-ns Window Help

> B EEE @

A Book1.xdsx - Modulel (Code)

VoAProrect (Bokiind || | 0omere)

Sub Maczol ()
Sheett (sheett) .

&) Thisworkbook
-4 Modules
2 i,
i vonerorec sookaisc | AR
45§ Microsoft Excel Objects ActiveCell.FormulaRiCl = "Jan"
‘Sheet1 (Sheet1) Range ("B1") .Select
48] Thisworkbook ActiveCell.FormulaR1Cl = "Feb"
Tonon (s Sease
e i hescsmacion
Senee (e Serees
2o s

* Macrol Maczo





image31.png
VBAProject (Book1.xisx)
=125 Microsoft Excel Objects.
Sheet1 (Sheett)





image32.png
VBAProject (Book1.xisx)
=125 Microsoft Excel Objects.
Sheet1 (Sheett)





image33.png
85 o .

Fle  Home Inset Pagelayost Formuas  Data  Review View [T O Tellmewhatyouwanttodo

== JPemrdMazm P E = Y = B import

< Relative References & View Code 2 Expansion Packs
Visusl Macros 3 Add- Bxcel COM | Insert Design Source e

Basic t Macro Security ins  Add-ins Add-ins  ~  Mode
Code Add-ins Controls XML

Run Dialog





image34.png
Excel Options
General
Help keep your documents safe and your computer secure and healthy.
Formules
Proofing Security & more
Save Visit Office.com to learn more about protecting your privacy and security.
Languzge Microsoft Trustworthy Comy
Advanced
Microsoft Excel Trust Center
Customize Ribbon
‘The Trust Center contains security and privacy settings. These settings help keep your -
Quick Access Toolbar computer secure. We recommend that you do not change these settings. Trust Center Settings...
{
Add

Trust Center





image35.png
Trust Center

Trusted Publishers
Trusted Locations
Trusted Documents
Trusted Add-in Catslogs
Addi

ActiveX Settings.

Protected View
Message Bar
Ecernal Content
Fil Block Setings

Privacy Options

Macro Settings
Disable ll macros without notifcation

Disable all macros with noifcation

Disable all macros except digitally signed macros

Enable all macros (not recommended; potentially dangerous code can run)

Developer Macro Settings
(1] Trust access to the VBA project object model





image36.png
Disable all macros with notification

) Disable all macros except digitally signed macros
Enable all macros (not recommended; potentially dangerous code can run)





image37.png
Developer Macro Settings
(1] Trust access to the VBA project object model




image38.png
Table Activity 1-2 - Excel = o

[ e ST S e SR Dccion [ RIS S Q) Sharc
i ?z“' . Calbri B General B e Output warningText "/ 2 i é‘::‘:““m A&y O
poste 3 T VesgediCenter + § - % » 5 #§ Condiionsl Fomatos| Heading 1 |Heading2 | Headings . nsert Delte Fomat Sot@r Fnd &
- ¥ Format Painter Formatting +  Table~ - - - &l e Select-
Clipboard 5 Font 5 Alignment 5 Number 5 stles celts Editing ~
AL - £ | sku v
|6 6 | | o [ ® | v | M [ N ] o | P | @ | R | s | T | U |A#
1
2| 15m s 29 5 14.95 Warehouse A
3| 2358 S 39999 s 1,999.95 Warehouse B
4| wum s os 17 777.63 Warehouse 8
5| 258 s 39999 54 21,599.46 Warehouse A
6| 147 5 199 24 27,817.85 Warehouse 8
7] 18 s a9 a5 22055 Warehouse A
8| 15m s 29 65 194.35 Warehouse C
9| s167 s a0 a5 1,912.50 Warehouse A
10| 2358 S 399.99 89 35,599.11 Warehouse C
11 157 s 13ass 5 1,076.64 Warehouse A
2] 235 S 56999 55 31,349.45 Warehouse B
3] 1567 8 14759 35 5,165.65 Warehouse A
1] a9 s 1699 9 1,512.11 Warehouse B
5| 147 s os s 41845 Warehouse A
6] 147 s 12999 ars 61,745.25 Warehouse A
17 a7 s s B 800.11 Warehouse A
18 34§ 75000 S 18,750.00 Warehouse A
19 157 8 1ass 2 269.16 Warehouse 8
20 1w s 0as  asm 2,389.24 Warehouse B
21| 2358 5 3399 54 21,599.46 Warehouse A
2| 147 5 1999 s 18,848.55 Warehouse B
23 158 s 499 a5 22255 Warehouse A
24| 15 s 299 65 194.35 Warehouse C
25| s167 s a0 a5 1,912.50 Warehouse A
2| 2358 s 39999 %0 3599910 Warehouse C
27| 1547 5 138 5 1,076.64 Warehouse A
28] 235 5 5699 55 31,349.45 Warehouse B
20 1567 s 14759 35 5,165.65 Warehouse A L]
30| w5 s 163 9 1,512.11 Warehouse B
31| e 5 o4 sm 42826 Warehouse A
2| 147 s 19 an 61,225.29 Warehouse A
Sheetl | Sheet2 | Sheets | & [ 1Dl
Ready 23 ]





image39.png
Activity 1-2 - xcel

R e e e cor S o e @ T e
W= O split i ]

T o | Q3 = 5 =
£ s B3 = B

Normal Page Break Page 7| Gridines [/ Headings | Zoom 100% Zoomto  New Amange Freeze Switch  Macros

Workbook Views Show om Window





image40.png
Record Macro

Macro name:

Workbook _Protection|

Shortcut key:
cti-

Store macro in:
This Workbook

Description:

oK

Cancel





image41.png
Record Macro

Macro name:

Workbook_Protection

Shortcut key:
ctrle

Store macro in:

This Workbook

Personal Macro Workbook
DedNew Workbook

oK Cancel





image42.png
Record Macro

Macro name:

Workbook_Protection

Shortcut key:
ctrle

Store macro in:

Description:

Cancel

o)





image43.png
s Table Tools Activity 1-2 - xcel

Home Inset  Pagelsyout Formulss View  Desgn  Q Tell mewhatyouwanttodo

s
B L5 O St Al o

SpengThe:auru: Smart | Translate  New Protect | Protect | Share
Lookup. Comment Show Ink Sheet Workhook Workbook

Proofing Insights | Language Comments Changes

) i i

3 Allow Users to Edit Ranges




image44.png
Protect Structure and Windows

Protect workbook for

Structure
Windows

Password (optional):

Copl

?

Cancel





image45.png




image46.png
Sheet1 | Shee

Ready [N





image47.png
s Table Tools Activity 1-2 - xcel

Home Inset  Pagelsyout Formulss View  Desgn  Q Tell mewhatyouwanttodo

WANEERPONNFS BN T 2

O Show AllComments 3 Allow Users to Edit Ranges

Spelling Thesaurus | Smart | Translate  New Protect | Protect | Share
Lookup. Comment Show Ink Sheet wm&m [Workbook
Proofing Insights | Language Comments Changes




image48.png
s Table Tools Activity 1-2 - xcel

Home Inset  Pagelsjout  Formuss  Data Review Design  Q Tellme wht yourwant to do
= Dt [
T o | Q3 [ | 2 1
’—L\ =4 L@ ™= = e jmem]
Normal Page BreskPage 7 Gidines ] Headings | Zoom 100% Zoomto  New Arange Freeze ~ Switch  Macros
Preview  Layout Selection Window Al Panes - Windows~ -

Workbook Views Show

om Window Macros




image49.png
Macros in:

Al Open Workbooks

Cancel





image50.png
s Table Tools Activity 1-2 - xcel

Home Inset  Pagelsyout Formulss View  Desgn  Q Tell mewhatyouwanttodo

s
B L5 O St Al o

SpengThe:auru: Smart | Translate  New Protect] Protect | Share
Lookup. Comment Show Ink Sheet [Workbook|Workbook

Proofing Insights | Language Comments Changes

HINEA [

3 Allow Users to Edit Ranges




image51.png
Macros in:

All Open Workbooks

Cancel





image52.png
4 Microsolft Visual Basic for Applications - Activity 1-2:d5x

Ele Edit View lnset Formet Debug Run Tools Add-lns Window Help

ME-J s anR ¢ naRIEFFY » @2

Project - VBAPraject
ElE]
'VBAProject (Activity 1-2
(=123 Microsoft Excel Objects
Sheet1 (sheet1)
‘Sheet2 (Sheet2)
Sheet3 (Sheets)
4] Thisworkbook
-5 Modues
48 Moduie1

Properties - Modulel
[Module1 Module

Aphabetic | Categorized |
Vodde1

48 Actvity 1-2550- Modulel (Code)

[tGeneran

[Workbook_Protection

Sub Workbook_Protection ()
" Workbook_Protection Macro

ActiveNorkbook. Protect Structure:=True, Window:
End Sub





image53.png
(General)

Sub Workbook_Protection ()

' Workbook_Protection Macro

ActiveWorkbook. Protect Structure:
£nd Sub





image54.png




image55.png
& cut
B2 Copy ~

Clipboard

Insert

Page Layout

-l

Font

Formulas

Data

Review.

- B

Alignment

Q Tell me what you want to do

Wiap Text
Merge & Center ~

Genersl
$-%

Number

Book! - Excel

Formatting~ _Table~

Good

Top/Bottom Rules

Data Bars

Color Scales

Icon Sets

Highlight Cells Rules »

»

[E NewRule
3 ClearRules
[E Manage Rules.





image56.png




image57.png
Top 10 Items...
PR rop 0%
Bottom 10 Items...
[——
Above Average...

Below A
erage...

More Rules...




image58.png




image59.png
EEEE
2 EEHE

More Rules...




image60.png
Directional
2V ¥
a=sw LEA T ]
AAVY AIDNY
AADNY

Shapes

eo0e @oe
eA® Lo X )
0000

Indicators
200 vIix
dald

Ratings

*fe v al
09030 il il all
HEEEES

More Rules.





image61.png




image62.png
Data

Review.

Q Tell me what you

antto

Book! - Excel

i
K R
Font
fo | 100
b | &

E Genersl
Merge & Center = § - % *
5 humber
Mo 3 K

- Normal
i
<g 91 Conditional Formatas| Good
Formatting~ _Table -

Highlight Cells Rules »

Top/Bottom Rules  »

€€ €€ €|

| v
Data Bars »
Color Scales ,
Icon Sets »
[E NewRule
7 Clear Rules »

[0 ManageRules... [\




image63.png
‘Conditional Formtting Rules Manager T
Show formatting rules for: B

[ NewRule,, | | A EdR Rul... | | X Delete Rute | | 4] | =

Rule (applied in order shown)  Format Applesto Stop f True

Icon set LN =sastsBss

ok Close Apply





image64.png
Book! - Excel

Formulas ~ Data  Review Q Tell me what you want to do

Normal
i

Merge & Center - § - % » | 4 £ | Conditional Formatas| Good
Formatting ™ _Table -

ﬁ % cut Calior i & A 5 Wiap Text General B
B3 Copy -

Clpboara B Font B 5 mmber  w
Highight Cells Rues »
AL - fo 100
B | ¢ | o | E F | G | H | 3| k| v Ui TopfBottomRules >
R
W af Data Bars »
¥ 57
¥ o Color Scales ,
¥ s
lcon Sets »
O NewRue..
B ClearRules ,

[E Manage Rules.




image65.png
New Formatting Rule ?

Select a Rule Type:

= Format only cels that contain

= Format only top or bottom ranked values.

= Format only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Editthe Rule Description:

Format al cells based on their values:
Format Style: | 2.Color Scale. 5

Minimum Maximum

Tpe: | Lowest value 5 Highest Value 5

Value: | (Lowest value] 4 (Highest value) B
Color: <

recer: [ |

o ] [ cne |





image66.png
Book! - Excel

Formulas ~ Data  Review Q Tell me what you want to do

I g"c“' Catbri T oA x - SWopTet General - £ [Nomal
BB Coy -
Paste Iu- @ Merge & Center - § - % » | % £  Conditional Formatas| Good
e e ul 9 $ RSN 7o~
Gipboars % Font . Jro— 5 wme n

Top/Bottom Rules

Data Bars

Color Scales

Icon Sets

[ NewRule
[3 ClarRules
[E Manage Rules.

Highlight Cells Rules »

Bad - &

Clear Rules from Selected Cels
Clear Rules from Entire Sheet
Clear Rules from This Table

Clear Rules from This PivotTable




image67.png
= o

Actity
T o e e e = e e e e e John Smith £ Share

ﬁg;z;y T BERErY WinpTex General A B [voma Bad - i é::'j‘“m Ay O

P Fomatpimer BT U7 [ Q- A~ Meges Center < § - % 2| 3§ Condilonal Format e (Good T |- || =t et omet| o, SE Foda
Cipboara 5 Font 5 Aignment 5 mmber  w cets ating ~

AL - fe | Weekly Sales & Bonus Payout v
Al s | c ) 3 3 s W ' | 3 L M N o 3 a R s

1 Week\|y Sales & Bonus Payout Weekly Bonus Amount

2] B 500.00

3|

4 |First Name _Last Name D Weekly Sales Weekly Goal _Bonus

5 |Jackie ‘Williamson Jackie_Williamson $ 16,785.14 $ 15,000.00 $500.00

6 |Lucas Bressan  Lucas_Bressan $ 1468750 $ 1500000 $ -

7 |Stanley  Prestwick Stanley_Prestwick $ 1347896 $ 1500000 $ -

8 |serry Harrison  Jerry_Harrison $ 21,689.47 $ 15,000.00 $500.00

9 |Leah Thompson Leah_Thompson $ 2547845 $ 15,000.00 $500.00

10|Robyn Fletcher  Robyn_Fletcher $  7,600.00 $ 1500000 $ -

11 Lisa McCain  Lisa_McCain $ 5685.00 $ 1500000 $ -

12|steven  stone Steven_Stone $ 12,346.87 $ 1500000 $ -

13 |Devon Lawrence Devon_Lawrence $ 11,687.00 $ 1500000 $ -

14|George  Jackson  George _Jackson $ 987445 $ 1500000 $ -

15|

16|

il

18

19

20

21

2|

2l

24|

2|

26|

27|

2|

2

30|

31| B

2 -

Sheetl | Sheet2 | Sheets | & [ 1Dl
Ready %3 [ 100%





image1.png
80 vele o




image68.png
A

c

D

Weekly Sales & Bonus Payout

First Name _Last Name D Weekly sales Weekly Goal _Bonus
1ackie ‘Williamson Jackie_Williamson $ 16,785.14 | $ 15,000.00 $500.00
Lucas  Bressan Lucas_Bressan $ 1468750/ $ 1500000 $ -
[Stanley  Prestwick  stanley_Prestwick $ 1347896 | $ 1500000 $ -
lerry  Harrison Jerry_Harrison S 21,689.47 | $ 1500000 $500.00
Leah Thompson Leah_Thompson $ 2547845 | $ 15,000.00 $500.00
Robyn Fletcher  Robyn_Fletcher $  7,600.00 | $ 1500000 $ -
Lisa McCain  Lisa_McCain $ 568900 |$ 1500000 $ -
Steven  Stone  Steven_Stone $ 1231687 |$ 1500000 § -
Devon  lawrence Devon_lawrence | $ 11,687.00 |$ 1500000 $ -
George  Jackson  George ackson $ GRa7as|s 1500000 § -

$

‘Weekly Bonus Amount

500.00




image69.png
Insert

Pagelayout  Formulass  Data

Q Tell me what you

Activity 1-3

antto do

Bxcel

() % cut Catbri “[n Accounting -
ER Copy ~
P e B I U~ Merge & Center - | $ - % 2 | 8
Cipboara 5 Font 5 Aignment 5 mmber  w
D5 - fo 16785.14
A |8 c | o | € Fl e | 8 | '
1 |Weekly Sales & Bonus Payout Weekly Bon
2] S
3|
4 |First Name _Last Name D Weekly Sales Weekly Goal _Bonus
5 [Jackie ‘Williamson Jackie_Williamson $ 15,000.00 $500.00
6 |lucss  Bressan  Lucas Bressan $ 1500000 5 -
7 |Stanley  Prestwick Stanley_Prestwick $ 1500000 $ -
8 |serry Harrison  Jerry_Harrison $ 15,000.00  $500.00
9 |Leah Thompson Leah_Thompson $ 15,000.00 $500.00
10|Robyn Fletcher  Robyn_Fletcher $ 1500000 $ -
11 |uisa McCain  Lisa_McCain $ 1500000 5 -
12/steven  stone steven_Stone $ 1500000 5 -
13|Devon  Lawrence  Devon_Lawrence $ 1500000 5 -
14 George  Jackson  George _lackson $ 1500000 $ -

Y | comma comma [0]

Conditional Format as | Currency currency [0]
Formatting ™ Table~

Highlight Cells Rules »

Top/Bottom Rules >

Data Bars ,

s B EE

N
teonsets EEEE

[E NewRule
B3 ClearRules »
[E Manage Rules.

EEEE

More Rules.





image70.png
A B

c D E

Weekly Sales & Bonus Payout

1
|

3]

4 |FirstName_Last Name [0} Weekly sales Weekly Goal _Bonus
5 [lackie  williamson Jackie_Williamson $ 15,000.00 | $500.00
6 lucas  Bressan  Lucas Bressan $ 1500000 $ -
7 |stanley  prestwick Stanley_Prestwick $1500000 $ -
8 |erry Harrison  Jerry_Harrison $ 15,000.00  $500.00
9 |Leah Thompson  Leah_Thompson $ 15,000.00  $500.00
10|Robyn  Fletcher  Robyn_Fletcher $1500000 $ -
11 |uisa McCain  Lisa_McCain $ 1500000 $ -
12/steven  stone steven stone $ 1500000 $ -
13|Devon  Lawrence Devon Lawrence $ 1500000 $ -
14|George  Jackson  George Jackson $1500000 $ -





image71.png
A

c

D E

Weekly Sales & Bonus Payout

FirstName_Last Name [0} Weekly sales Weekly Goal _Bonus
lackie williamson Jackie_Williamson $ 15,000.00 | $500.00
Lucas  Bressan Lucas Bressan $ 1500000 $ -
stanley  Prestwick  Stanley_Prestwick $1500000 $ -
erry Harrison  Jerry_Harrison $ 15,000.00  $500.00
Leah Thompson  Leah_Thompson $ 15,000.00  $500.00
Robyn  Fletcher  Robyn_Fletcher $1500000 $ -
Lisa McCain  Lisa_McCain $ 1500000 $ -
Steven  Stone  Steven_Stone $ 1500000 $ -
Devon  Lawrence Devon_Lawrence $ 1500000 $ -
George  Jackson  George _ackson $ 1500000 $ -




image72.png
Activity

Formulas ~ Data  Review Q Tell me what you want to do

% cut Catior A - EewWapTen Accounting - comme
pase BB Copy -
aste BIu- - O A Merge &uCenter = § + % | 8 4 Curren
e e - A 9 $ Formatting®. Table -
Gipboard 5 Font 5 Aignment 5 wme 6
Highlight Cells Rules »
D5 - fo 16785.14
ottom »
A | B | c | D l 3 L F | 6 | H | ! Top/Bottom Rules
1 |Weekly Sales & Bonus Payout Weekly Bon Doto Bars R
2] B
3| Color Scales »
4 |First Name _Last Name D Weekly sales Weekly Goal _Bonus
5 [1ackie ‘Williamson Jackie_Williamson $ 15,000.00 | $500.00 LconSets )
6 [lucas  Bressan Lucas Bressan $ 1500000 5 - -
7 |stanley  Prestwick Stanley_Prestwick $ 1500000 $ - [ NewRule..
8 [rery Harrison  Jerry_Harrison $ 15,000.00  $500.00  Clearfules N R
9 |Leah Thompson Leah_Thompson $ 15,000.00 $500.00 -
10|Robyn  Fletcher  Robyn Fletcher $ 1500000 § - [E Manage Rules.





image73.png
New Formatting Rule ?

Select a Rule Type:

= Format only cels that contain

= Format only top or bottom ranked values.

= Format only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Editthe Rule Description:

Format al cells based on their values:
Format Style: | 2.Color Scale. 5

Minimum Maximum

Tpe: | Lowest value 5 Highest Value 5

Value: | (Lowest value] 4 (Highest value) B
Color: <

recer: [ |

o ] [ cne |





image74.png
Edit the Rule Description:

Format al clls based on their values:

Format Style: | 2Color Scale. -
[2-Color Scale
Minim|3-C20r Se2le Maximum
Type: | LowedData Bar Highest Value -
Value: | (LowesEvalie) (Highest value) Eq
Color: - -

recer: [ |

o ] [ cne |





image75.png
Edit the Rule Description:

Format i cels basd ontheirvalues:
Fomatsbielcan sets b e

wnstie (@@ @ [+ O snowiconony

Display each icon according to these rules:

Value Type
] whenvaers <l [ | [percnt
[] whencorans [ [m =il
[
7] when<3 reretie





image76.png
Edit the Rule Description:

Formatall cels based on their values:
Fomat Style: [1con Sets | [ Reverse 1con Orger

wnstie (@O @ [+ O snowiconony

Display each icon according to these rules:

Value e
@ |7 whenvalueis >= [v] [1s000 | [Number v
@ ] when<omna <5 % [

@ | wenen





image77.png
Edit the Rule Description:

Format al cells based on their values:

Fomat Style: [1con Sets | [ Reverse 1con Orger

wnstie (@O @ [+ O snowiconony

Display each icon according to these rules:

Type
] whenveters = s | omser

] wnen<1so00ana 5= ) [ | [peeen

[+ wnen <35 ]

Formula
Percentile





image2.png




image78.png
Editthe Rule Description:

Format al cells based on their values:

Fomat Style: [1con Sets | [ Reverse 1con Orger

wnstie (@O @ [+ O snowiconony

Display each icon according to these rules:

Va Type
] whenvotueis = ] [rsom ] [number
|~ | when<1s000ana  [>= [v] | 10000 | [Number

[+ wnen <o





image79.png
New Formatting Rule.

Select a Rule Type:

~Format all cels based on their values
= Format only cels that contain

= Format only top or bottom ranked values.

= Format only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Editthe Rule Description:

Format al cells based on their values:
Format Style: |icon Sets v

Display each icon according to these rules:

Reverse Icon Order

Icon Ste | 1 show con ony

Value
[7] whenvatueis <] [1s000
[+ when < 15000ang <) [1o0od

[+ wnen <o

Type
| [Number v

| [Number v





image80.png
A B c J— F
1 |Weekly Sales & Bonus Payout

a|

3|

4 |First Name _Last Name D Weekly sales Bonus
5 |Jackie ‘Williamson Jackie_Williamson s $500.00
6 |lucas  Bressan Lucas Bressan s s -
7 |Stanley  Prestwick Stanley_Prestwick $ s -

8 |serry Harrison  Jerry_Harrison B $500.00
9 |Leah Thompson Leah_Thompson $ $500.00
10|Robyn Fletcher  Robyn_Fletcher $ s -
11 |uisa McCain  Lisa_McCain s s -
12|Steven  Stone Steven_Stone s s -
13|Devon Lawrence Devon_Lawrence s s -
14 George  Jackson  George _lackson $ s -





image81.png
s Book! - Excel

Home Inset  Pagelsyout Formulss View  © Tell me what you want to do

&= [show Queries [=] Connections a0

Bl B B Bgr- 5

Fom From From FromOther  Bisting  New Refresh 7l Sot  Fiter _ Tetto

Access Web Tet Sources~  Connections | Query~ L Recent Sources - Vo Advanced | Columns
Get External Data Get & Tansform @D Sort & Filter

NS

5 B

Flash Remove  Data  Consolidate
Fill - Duplicates Validation ~
Data Tools

Manage
Data Model

?

What-If Forec;
Analysis ~ Sheet

Forecast




image82.png
Data Validation [

{Seitings ] Input Message  Error Alert

Validation crteria
Allow:
Any value | 7 1gnore blank.
Data:
between <

‘Apply these changes to all other cells with the same settings

Clear Al oK Cancel





image83.png
Home Insert

Page Layout

Formulas

Activity 1-4 - Excel

View  Q Tell me what you want to do

=

o

JohnSmith ), Share

Ready

f& [show Queries (] Connections 5 YY,oear Loy =l I‘E = EQE =] @ == Show Detail
@[y [3 ] Eﬁgrmmwe [F) = — & () Vorewpy | D2 7 = 58 ? i e
From From From FromOther  Bisting  New Refresh 7| Sot Fitter Tetto Flash Remove Data  Consolidate Relationships Manage  What-ff Forecast Group Ungroup Subtotal
Access Web Tet Sources~  Comnections  Query~ L RecentSources | - [Jditlinks | A Vo Advanced  Columns Fill Duplcates Valdation - DataModel Anabsis~ Shest = - -
Get External Data Get & Transtorm Connections Sort & Fiter Data Tools Forecast Outiine 5l
AL - £ | Employee# v
Py S| 8 | ¢ | o | ¢ F 6 | H | b | k | v | mM | N | 0o | p | @ | R | s | T | u | | w |
1 [Employee # |review Rating (1-10)
2| 58697
3| asers
4| seass
5| ae7ns
5| 33
7| 64867
5| 3398
o | 3071
10| 2m8
|
12|
1)
1l
Bl
Gl
il
ial
ol
2l
2l
=
2l
2
=l
2
Il
2l
Bl
Bl
Bl L
)
ES -
Sheetl | Sheet2 | Sheets | & [ Dl
iz2) 100%





image84.png




image85.png
s Activity 1-4 - Excel

Home Insert  Pagelayout  Formulas T O o e o e

= [ Show Queries [ Connections | 4 = v

BLE D B B2 |k & 5 1
Access Web Tet Sources~ Connections Query~ O Recent Sources | - Yo Advanced | Columns Fill Duplicates Validation *

Get External Data Get & Transform Connections Sort & Filter Data e




image86.png
Data Validation

Settings | Input Message

Validation crteria
Allow:

Error Alert

Any value

] [ gnore biank.

List
Date

Time

Text length
|custom

ESm———

‘Apply these changes to all other cells with the same settings

Clear Al

oK

Cancel





image87.png
Data Validation [

Settings | Input Message  Error Alert

Validation crteria

Allow:

Whole number | Hignore blank.

3

=

‘Apply these changes to all other cells with the same settings

Clear Al oK Cancel





